Linux filesystem development
 help / color / mirror / Atom feed
 messages from 2025-09-15 09:12:10 to 2025-09-16 00:23:46 UTC [more...]

[RFC v5] fuse: containerize ext4 for safer operation
 2025-09-16  0:23 UTC  (22+ messages)
` [PATCHSET RFC v5 1/8] fuse: general bug fixes
` [PATCHSET RFC v5 2/8] iomap: cleanups ahead of adding fuse support
` [PATCHSET RFC v5 3/8] fuse: "
` [PATCHSET RFC v5 4/8] fuse: allow servers to use iomap for better file IO performance
` [PATCHSET RFC v5 5/8] fuse: allow servers to specify root node id
` [PATCHSET RFC v5 6/8] fuse: handle timestamps and ACLs correctly when iomap is enabled
` [PATCHSET RFC v5 7/8] fuse: cache iomap mappings for even better file IO performance
` [PATCHSET RFC v5 8/8] fuse: run fuse servers as a contained service
` [PATCHSET RFC v5 1/6] libfuse: general bug fixes
` [PATCHSET RFC v5 2/6] libfuse: allow servers to use iomap for better file IO performance
` [PATCHSET RFC v5 3/6] libfuse: allow servers to specify root node id
` [PATCHSET RFC v5 4/6] libfuse: implement syncfs
` [PATCHSET RFC v5 5/6] libfuse: cache iomap mappings for even better file IO performance
` [PATCHSET RFC v5 6/6] libfuse: run fuse servers as a contained service
` [PATCHSET RFC v5 2/9] fuse4fs: fork a low level fuse server
` [PATCHSET RFC v5 3/9] libext2fs: refactoring for fuse2fs iomap support
` [PATCHSET RFC v5 4/9] fuse2fs: use fuse iomap data paths for better file I/O performance
` [PATCHSET RFC v5 5/9] fuse4fs: specify the root node id
` [PATCHSET RFC v5 6/9] fuse2fs: handle timestamps and ACLs correctly when iomap is enabled
` [PATCHSET RFC v5 7/9] fuse2fs: cache iomap mappings for even better file IO performance
` [PATCHSET RFC v5 8/9] fuse2fs: improve block and inode caching

[PATCH v2 0/7] vma count: fixes, test and improvements
 2025-09-16  0:05 UTC  (13+ messages)
` [PATCH v2 1/7] mm: fix off-by-one error in VMA count limit checks
` [PATCH v2 2/7] mm/selftests: add max_vma_count tests
` [PATCH v2 3/7] mm: introduce vma_count_remaining()
` [PATCH v2 4/7] mm: rename mm_struct::map_count to vma_count
` [PATCH v2 5/7] mm: harden vma_count against direct modification
` [PATCH v2 6/7] mm: add assertion for VMA count limit
` [PATCH v2 7/7] mm/tracing: introduce max_vma_count_exceeded trace event

[PATCH v2 0/7] fs/9p: Reuse inode based on path (in addition to qid)
 2025-09-15 23:31 UTC  (6+ messages)

Any way to ensure minimal folio size and alignment for iomap based direct IO?
 2025-09-15 23:20 UTC  (6+ messages)

[PATCH v2] fs/fuse: fix potential memory leak from fuse_uring_cancel
 2025-09-15 23:04 UTC  (7+ messages)

[PATCH v2 00/33] ns: support file handles
 2025-09-15 22:59 UTC  (39+ messages)
` [PATCH v2 11/33] net: use ns_common_init()
` [PATCH v2 17/33] nstree: make iterator generic
` [PATCH v2 18/33] mnt: support ns lookup
` [PATCH v2 19/33] cgroup: "
` [PATCH v2 20/33] ipc: "
` [PATCH v2 21/33] net: "
` [PATCH v2 22/33] pid: "
` [PATCH v2 23/33] time: "
` [PATCH v2 24/33] user: "
` [PATCH v2 25/33] uts: "
` [PATCH v2 26/33] ns: add to_<type>_ns() to respective headers
` [PATCH v2 27/33] nsfs: add current_in_namespace()
` [PATCH v2 28/33] nsfs: support file handles
` [PATCH v2 29/33] nsfs: support exhaustive "
` [PATCH v2 30/33] nsfs: add missing id retrieval support

[PATCH 0/5] fuse: {io-uring} Allow to reduce the number of queues and request distribution
 2025-09-15 22:18 UTC  (5+ messages)
` [PATCH 5/5] fuse: {io-uring} Allow reduced number of ring queues

[PATCH v5] hfs: update sanity check of the root record
 2025-09-15 22:27 UTC  (3+ messages)

[RFC PATCH v6 0/2] mm: Refactor KVM guest_memfd to introduce guestmem library
 2025-09-15 21:25 UTC  (4+ messages)
` [RFC PATCH v6 1/2] mm: guestmem: "
` [RFC PATCH v6 2/2] userfaulfd: add minor mode for guestmem

[PATCH RESEND 00/62] initrd: remove classic initrd support
 2025-09-15 21:05 UTC  (23+ messages)
` [PATCH RESEND 01/62] init: remove deprecated "load_ramdisk" command line parameter, which does nothing
` [PATCH RESEND 02/62] init: remove deprecated "prompt_ramdisk" "
` [PATCH RESEND 03/62] init: sh, sparc, x86: remove unused constants RAMDISK_PROMPT_FLAG and RAMDISK_LOAD_FLAG
` [PATCH RESEND 04/62] init: x86, arm, sh, sparc: remove variable rd_image_start, which controls starting block number of initrd
` [PATCH RESEND 05/62] init: remove "ramdisk_start" command line parameter, "
` [PATCH RESEND 06/62] arm: init: remove special logic for setting brd.rd_size
` [PATCH RESEND 08/62] arm: init: remove FLAG_RDLOAD and FLAG_RDPROMPT
` [PATCH RESEND 13/62] ext2: remove ext2_image_size and associated code
` [PATCH RESEND 16/62] brd: remove "ramdisk_size" command line parameter
` [PATCH RESEND 17/62] doc: modernize Documentation/filesystems/ramfs-rootfs-initramfs.rst

[linux-next20250911]Kernel OOPs while running generic/256 on Pmem device
 2025-09-15 18:20 UTC  (7+ messages)
  ` [External] "

[Linux Kernel Bug] KASAN: slab-out-of-bounds Read in hfsplus_strcasecmp
 2025-09-15 17:29 UTC  (2+ messages)

[PATCH 00/62] initrd: remove classic initrd support
 2025-09-15 16:43 UTC  (2+ messages)

[PATCH V12 0/5] riscv: mm: Add soft-dirty and uffd-wp support
 2025-09-15 17:05 UTC  (11+ messages)
` [PATCH V12 1/5] mm: softdirty: Add pgtable_supports_soft_dirty()
` [PATCH V12 2/5] mm: userfaultfd: Add pgtable_supports_uffd_wp()
` [PATCH V12 3/5] riscv: Add RISC-V Svrsw60t59b extension support
` [PATCH V12 4/5] riscv: mm: Add soft-dirty page tracking support
` [PATCH V12 5/5] riscv: mm: Add userfaultfd write-protect support

[PATCH v2 00/16] fuse: use iomap for buffered reads + readahead
 2025-09-15 16:05 UTC  (9+ messages)
` [PATCH v2 05/16] iomap: propagate iomap_read_folio() error to caller
` [PATCH v2 12/16] iomap: add bias for async read requests

[PATCH v1 1/1] lock_mount(): Remove unused function
 2025-09-15 16:02 UTC 

[PATCH] ovl: check before dereferencing s_root field
 2025-09-15 15:29 UTC  (3+ messages)

[PATCH v2 0/4] writeback: Avoid lockups when switching inodes
 2025-09-15 15:13 UTC  (3+ messages)

[PATCH v2 00/16] expand mmap_prepare functionality, port more users
 2025-09-15 15:04 UTC  (24+ messages)
` [PATCH v2 03/16] mm: add vma_desc_size(), vma_desc_pages() helpers
` [PATCH v2 05/16] mm/vma: rename __mmap_prepare() function to avoid confusion
` [PATCH v2 08/16] mm: add ability to take further action in vm_area_desc
` [PATCH v2 16/16] kcov: update kcov to use mmap_prepare

[PATCH v2] rcu: Remove redundant rcu_read_lock/unlock() in spin_lock critical sections
 2025-09-15 14:40 UTC  (3+ messages)

[RFC PATCH v3 0/4] ->i_state accessors
 2025-09-15 14:16 UTC  (7+ messages)
` [PATCH v3 2/4] fs: hide ->i_state handling behind accessors

[PATCH] fs: rename generic_delete_inode() and generic_drop_inode()
 2025-09-15 14:10 UTC  (3+ messages)

[PATCH] fs: expand dump_inode()
 2025-09-15 13:42 UTC  (4+ messages)

[PATCH] init: INITRAMFS_PRESERVE_MTIME should depend on BLK_DEV_INITRD
 2025-09-15 13:02 UTC  (3+ messages)

[PATCH] initramfs: Replace strcpy() with strscpy() in find_link()
 2025-09-15 12:52 UTC  (2+ messages)

[PATCH] initrd: Use str_plural() in rd_load_image()
 2025-09-15 12:47 UTC  (2+ messages)

[PATCHES] simple part of ->d_name stuff
 2025-09-15 12:46 UTC  (13+ messages)
` [PATCH 1/6] security_dentry_init_security(): constify qstr argument
  ` [PATCH 2/6] exfat_find(): "
  ` [PATCH 3/6] afs_edit_dir_{add,remove}(): "
  ` [PATCH 4/6] afs_dir_search: "
  ` [PATCH 5/6] generic_ci_validate_strict_name(): constify name argument
  ` [PATCH 6/6] make it easier to catch those who try to modify ->d_name

[PATCH] initramfs: Use struct_size() helper to improve dir_add()
 2025-09-15 12:43 UTC  (2+ messages)

[PATCH v2] fs: expand dump_inode()
 2025-09-15 12:31 UTC  (2+ messages)

[PATCH v2] initrd: Fix unused variable warning in rd_load_image() on s390
 2025-09-15 12:27 UTC  (2+ messages)

[PATCH] ocfs2: retire ocfs2_drop_inode() and I_WILL_FREE usage
 2025-09-15 12:21 UTC  (16+ messages)
` [External] : "

[PATCH 0/3] fs: replace wq users and add WQ_PERCPU to alloc_workqueue() users
 2025-09-15 12:20 UTC  (3+ messages)

[PATCH] fs: use the switch statement in init_special_inode()
 2025-09-15 12:19 UTC  (2+ messages)

[PATCH] fs/proc/namespaces: make ns_entries const
 2025-09-15 12:18 UTC  (2+ messages)

[PATCH 0/6] VFS: more prep for change to directory locking
 2025-09-15 12:10 UTC  (3+ messages)
` [PATCH 4/6] VFS: unify old_mnt_idmap and new_mnt_idmap in renamedata

[PATCHES] file->f_path safety and struct path constifications
 2025-09-15 12:07 UTC  (45+ messages)
` [PATCH 01/21] backing_file_user_path(): constify struct path *
  ` [PATCH 02/21] constify path argument of vfs_statx_path()
  ` [PATCH 03/21] filename_lookup(): constify root argument
  ` [PATCH 04/21] done_path_create(): constify path argument
  ` [PATCH 05/21] bpf...d_path(): "
  ` [PATCH 06/21] nfs: constify path argument of __vfs_getattr()
  ` [PATCH 07/21] rqst_exp_get_by_name(): constify path argument
  ` [PATCH 08/21] export_operations->open(): "
  ` [PATCH 09/21] check_export(): "
  ` [PATCH 10/21] ksmbd_vfs_path_lookup_locked(): root_share_path can be const struct path *
  ` [PATCH 11/21] ksmbd_vfs_kern_path_unlock(): constify path argument
  ` [PATCH 12/21] ksmbd_vfs_inherit_posix_acl(): "
  ` [PATCH 13/21] ksmbd_vfs_set_init_posix_acl(): "
  ` [PATCH 14/21] ovl_ensure_verity_loaded(): constify datapath argument
  ` [PATCH 15/21] ovl_validate_verity(): constify {meta,data}path arguments
  ` [PATCH 16/21] ovl_get_verity_digest(): constify path argument
  ` [PATCH 17/21] ovl_lower_dir(): "
  ` [PATCH 18/21] ovl_sync_file(): "
  ` [PATCH 19/21] ovl_is_real_file: constify realpath argument
  ` [PATCH 20/21] apparmor/af_unix: constify struct path * arguments
  ` [PATCH 21/21] configfs:get_target() - release path as soon as we grab configfs_item reference
` [PATCH 2/2] Have cc(1) catch attempts to modify ->f_path

[syzbot] [netfs?] kernel BUG in netfs_perform_write
 2025-09-15 11:58 UTC  (3+ messages)
` [PATCH] netfs: Prevent duplicate unlocking

[PATCH v4 0/4] procfs: make reference pidns more user-visible
 2025-09-15 11:54 UTC  (4+ messages)

[PATCH v4 0/4] allow partial folio write with iomap_folio_state
 2025-09-15 11:29 UTC  (5+ messages)
` [PATCH 4/4] iomap: don't abandon the whole copy when we have iomap_folio_state

[PATCH v2 0/2] Fix the initialization of max_hw_wzeroes_unmap_sectors for stacking drivers
 2025-09-15 10:43 UTC  (3+ messages)

[PATCH v7 0/1] exfat: Add support for FS_IOC_{GET,SET}FSLABEL
 2025-09-15 10:39 UTC  (3+ messages)
  ` [PATCH v7 1/1] "

[PATCH] initrd: Fix logged Minix/Ext2 block numbers in identify_ramdisk_image()
 2025-09-15 10:30 UTC  (4+ messages)

[PATCH v3] hfs: introduce KUnit tests for HFS string operations
 2025-09-15  9:29 UTC  (2+ messages)

[PATCH 1/4] iomap: make sure iomap_adjust_read_range() are aligned with block_size
 2025-09-15  9:12 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox