Linux filesystem development
 help / color / mirror / Atom feed
 messages from 2025-11-28 16:51:28 to 2025-12-01 17:08:09 UTC [more...]

[PATCH v6 00/15] Create and use APIs to centralise locking for directory ops
 2025-12-01 17:08 UTC  (11+ messages)
` [PATCH v6 06/15] VFS: introduce start_creating_noperm() and start_removing_noperm()
    ` [PATCH] fuse: fix conversion of fuse_reverse_inval_entry() to start_removing()

Can we sort out the prototypes within the cifs headers?
 2025-12-01 16:55 UTC  (2+ messages)

[PATCH v10] exec: Fix dead-lock in de_thread with ptrace_attach
 2025-12-01 16:49 UTC  (23+ messages)
` [PATCH v11] "
  ` [PATCH v12] "
    ` [PATCH v13] "
      ` [PATCH v14] "
        ` [PATCH v15] "
          ` [PATCH v16] "
            ` [PATCH v17] "
              ` [PATCH v18] "
                    ` [RFC][PATCH] exec: Move cred computation under exec_update_lock
                        ` Are setuid shell scripts safe? (Implied by security_bprm_creds_for_exec)

[PATCH v3 00/14] ext4: replace ext4_es_insert_extent() when caching on-disk extents
 2025-12-01 16:42 UTC  (19+ messages)
` [PATCH v3 01/14] ext4: subdivide EXT4_EXT_DATA_VALID1
` [PATCH v3 02/14] ext4: don't zero the entire extent if EXT4_EXT_DATA_PARTIAL_VALID1
` [PATCH v3 03/14] ext4: don't set EXT4_GET_BLOCKS_CONVERT when splitting before submitting I/O
` [PATCH v3 04/14] ext4: correct the mapping status if the extent has been zeroed
` [PATCH v3 05/14] ext4: don't cache extent during splitting extent
` [PATCH v3 06/14] ext4: drop extent cache after doing PARTIAL_VALID1 zeroout
` [PATCH v3 07/14] ext4: drop extent cache when splitting extent fails
` [PATCH v3 08/14] ext4: cleanup zeroout in ext4_split_extent_at()
` [PATCH v3 09/14] ext4: cleanup useless out label in __es_remove_extent()
` [PATCH v3 10/14] ext4: make __es_remove_extent() check extent status
` [PATCH v3 11/14] ext4: make ext4_es_cache_extent() support overwrite existing extents
` [PATCH v3 12/14] ext4: adjust the debug info in ext4_es_cache_extent()
` [PATCH v3 13/14] ext4: replace ext4_es_insert_extent() when caching on-disk extents
` [PATCH v3 14/14] ext4: drop the TODO comment in ext4_es_insert_extent()

[PATCH v2 0/2] ext4: fixes for mb_check_buddy integrity checks
 2025-12-01 16:23 UTC  (2+ messages)

[PATCH 0/2] filelock: fix conflict detection with userland file delegations
 2025-12-01 16:01 UTC  (6+ messages)
` [PATCH 1/2] filelock: add lease_dispose_list() helper
` [PATCH 2/2] filelock: allow lease_managers to dictate what qualifies as a conflict

[PATCH v13 0/4] New trait OwnableRefCounted for ARef<->Owned conversion
 2025-12-01 16:00 UTC  (11+ messages)
` [PATCH v13 1/4] rust: types: Add Ownable/Owned types
` [PATCH v13 2/4] rust: `AlwaysRefCounted` is renamed to `RefCounted`
` [PATCH v13 3/4] rust: Add missing SAFETY documentation for `ARef` example
` [PATCH v13 4/4] rust: Add `OwnableRefCounted`

[GIT PULL 00/17 for v6.19] v6.19
 2025-12-01 14:15 UTC  (9+ messages)
` [GIT PULL 11/17 for v6.19] minix
` [GIT PULL 12/17 for v6.19] vfs directory delegations
` [GIT PULL 13/17 for v6.19] vfs directory locking
` [GIT PULL 14/17 for v6.19] overlayfs cred guards
` [GIT PULL 15/17 for v6.19] autofs
` [GIT PULL 16/17 for v6.19] vfs fd prepare
` [GIT PULL 17/17 for v6.19] vfs fd prepare minimal

[syzbot] [fs?] kernel BUG in sctp_getsockopt_peeloff_common
 2025-12-01 14:07 UTC  (4+ messages)

[Bug report] hash_name() may cross page boundary and trigger sleep in RCU context
 2025-12-01 13:28 UTC  (29+ messages)
            ` [Bug report] hash_name() may cross page boundary and trigger

[PATCH] fs: assert on I_FREEING not being set in iput() and iput_not_last()
 2025-12-01 13:20 UTC 

[PATCH RESEND v3] vfs: remove the excl argument from the ->create() inode_operation
 2025-12-01 13:11 UTC 

[syzbot] Monthly fs report (Dec 2025)
 2025-12-01 12:38 UTC 

[PATCH RFC 0/13] fsnotify: Rework inode tracking
 2025-12-01 12:20 UTC  (3+ messages)

[syzbot] [overlayfs?] WARNING in fast_dput
 2025-12-01 12:11 UTC  (8+ messages)

[PATCH v2 00/11] ntfsplus: ntfs filesystem remake
 2025-12-01 11:46 UTC  (15+ messages)
` [PATCH v2 01/11] ntfsplus: in-memory, on-disk structures and headers
` [PATCH v2 06/11] ntfsplus: add iomap and address space operations
` [PATCH v2 07/11] ntfsplus: add attrib operatrions

[BUG] Recursive locking deadlock in hfsplus
 2025-12-01 10:51 UTC 

[syzbot] Monthly exfat report (Dec 2025)
 2025-12-01 10:41 UTC 

[PATCH v5 0/9] cifs: Miscellaneous prep patches for rewrite of I/O layer
 2025-12-01  9:49 UTC  (10+ messages)
` [PATCH v5 1/9] cifs: Rename mid_q_entry to smb_message
` [PATCH v5 2/9] cifs: Remove the RFC1002 header from smb_hdr
` [PATCH v5 3/9] cifs: Make smb1's SendReceive() wrap cifs_send_recv()
` [PATCH v5 4/9] cifs: Clean up some places where an extra kvec[] was required for rfc1002
` [PATCH v5 5/9] cifs: Replace SendReceiveBlockingLock() with SendReceive() plus flags
` [PATCH v5 6/9] cifs: Remove the server pointer from smb_message
` [PATCH v5 7/9] cifs: Don't need state locking in smb2_get_mid_entry()
` [PATCH v5 8/9] cifs: Add a tracepoint to log EIO errors
` [PATCH v5 9/9] cifs: Do some preparation prior to organising the function declarations

[PATCH v2] f2fs: add overflow/underflow checks to update_sit_entry
 2025-12-01  9:17 UTC 

[PATCH v2] fs: hide names_cache behind runtime const machinery
 2025-12-01  8:51 UTC  (2+ messages)

[PATCH v3] lib: xarray: free unused spare node in xas_create_range()
 2025-12-01  8:39 UTC  (2+ messages)

[PATCH 1/2] fs: move getname and putname handlers into namei.h
 2025-12-01  7:54 UTC  (4+ messages)
` [PATCH 2/2] fs: hide namei_cachep behind runtime const machinery

[PATCH bpf-next 0/3] Introduce bpf_kern_path and bpf_path_put
 2025-12-01  7:32 UTC  (6+ messages)
` [PATCH bpf-next 2/3] bpf: Add bpf_kern_path and bpf_path_put kfuncs

[PATCH v17 00/47] DEPT(DEPendency Tracker)
 2025-12-01  7:18 UTC  (5+ messages)
` [PATCH v17 44/47] dept: introduce APIs to set page usage and use subclasses_evt for the usage

[GIT PULL] hfs/hfsplus changes for 6.19-rc1
 2025-12-01  3:36 UTC 

[syzbot] [fuse?] possible deadlock in __folio_end_writeback
 2025-11-30 22:47 UTC  (2+ messages)

[PATCH v2] hfs: replace BUG_ONs with error handling
 2025-11-30 20:34 UTC  (3+ messages)

[syzbot] [fs?] [mm?] kernel BUG in __filemap_add_folio
 2025-11-30 15:51 UTC  (3+ messages)

[RFC PATCH v2 1/2] ARM/mm/fault: always goto bad_area when handling with page faults of kernel address
 2025-11-30 11:20 UTC  (8+ messages)

[PATCH] hfs: Validate CNIDs in hfs_read_inode
 2025-11-30 10:07 UTC  (6+ messages)
` [PATCH v2 1/2] "

[RFC PATCH 0/2] mm: continue using per-VMA lock when retrying page faults after I/O
 2025-11-30  5:38 UTC  (8+ messages)

[RFC PATCH v2 00/18] io_uring, struct filename and audit
 2025-11-30  4:38 UTC  (23+ messages)
` [RFC PATCH v2 01/18] do_faccessat(): import pathname only once
` [RFC PATCH v2 02/18] do_fchmodat(): "
` [RFC PATCH v2 03/18] do_fchownat(): "
` [RFC PATCH v2 04/18] do_utimes_path(): "
` [RFC PATCH v2 05/18] chdir(2): "
` [RFC PATCH v2 06/18] chroot(2): "
` [RFC PATCH v2 07/18] user_statfs(): "
` [RFC PATCH v2 08/18] do_sys_truncate(): "
` [RFC PATCH v2 09/18] do_readlinkat(): "
` [RFC PATCH v2 10/18] get rid of audit_reusename()
` [RFC PATCH v2 11/18] ntfs: ->d_compare() must not block
` [RFC PATCH v2 12/18] getname_flags() massage, part 1
` [RFC PATCH v2 13/18] getname_flags() massage, part 2
` [RFC PATCH v2 14/18] struct filename: use names_cachep only for getname() and friends
` [RFC PATCH v2 15/18] struct filename: saner handling of long names
` [RFC PATCH v2 16/18] allow incomplete imports of filenames
` [RFC PATCH v2 17/18] fs: touch up predicts in putname()
` [RFC PATCH v2 18/18] struct filename ->refcnt doesn't need to be atomic

[RFC PATCH 2/2] swsusp: make it possible to hibernate to device mapper devices
 2025-11-30  0:56 UTC 

[PATCH v2 00/13] ext4: replace ext4_es_insert_extent() when caching on-disk extents
 2025-11-29 18:41 UTC  (16+ messages)
` [PATCH v2 03/13] ext4: don't zero the entire extent if EXT4_EXT_DATA_PARTIAL_VALID1
` [PATCH v2 07/13] ext4: drop extent cache before splitting extent

[PATCH 3/3] ceph: add subvolume metrics collection and reporting
 2025-11-29 16:51 UTC  (2+ messages)

[PATCH] ceph: fix potential NULL dereferenced issue in ceph_fill_trace()
 2025-11-29 16:47 UTC  (3+ messages)

[PATCH 0/2] Optimize /proc/stat idle/iowait fluctuation
 2025-11-29 13:35 UTC  (3+ messages)
` [PATCH 1/2] timers/nohz: Revise a comment about broken iowait counter update race
` [PATCH 2/2] timers/nohz: Avoid /proc/stat idle/iowait fluctuation when cpu hotplug

[PATCH v2] fs/hfs: fix s_fs_info leak on setup_bdev_super() failure
 2025-11-29 13:06 UTC  (19+ messages)

[PATCH] fuse: limit debug log output during ring teardown
 2025-11-29 11:06 UTC 

[PATCH v7 0/3] statmount: accept fd as a parameter
 2025-11-29  9:11 UTC  (4+ messages)
` [PATCH v7 1/3] statmount: permission check should return EPERM
` [PATCH v7 2/3] statmount: accept fd as a parameter
` [PATCH v7 3/3] selftests: statmount: tests for STATMOUNT_BY_FD

[RFC PATCH 0/7] Enable exfat_get_block to support obtaining multiple clusters
 2025-11-29  1:56 UTC  (4+ messages)
` [RFC PATCH 6/7] exfat: introduce exfat_count_contig_clusters

[PATCH] afs: Fix uninit var in afs_alloc_anon_key()
 2025-11-29  0:49 UTC  (2+ messages)

[PATCH v2] VFS: namei: fix start_dirop() kernel-doc warnings
 2025-11-28 22:06 UTC 

[syzbot] Monthly fuse report (Nov 2025)
 2025-11-28 21:22 UTC 

[GIT PULL] vfs fixes
 2025-11-28 21:15 UTC  (2+ messages)

Ideas for RAIDZ-like design to solve write-holes, with larger fs block size
 2025-11-28 20:30 UTC  (5+ messages)

[RFC PATCH 0/1] IDR fix for potential id mismatch
 2025-11-28 17:50 UTC  (10+ messages)
` [RFC PATCH 1/1] idr: do not create idr if new id would be outside given range

[PATCH v4 0/4] Landlock: Disconnected directory handling
 2025-11-28 17:24 UTC  (5+ messages)
` [PATCH v4 1/4] landlock: Fix handling of disconnected directories

[PATCH v5 0/4] Landlock: Disconnected directory handling
 2025-11-28 17:21 UTC  (5+ messages)
` [PATCH v5 1/4] landlock: Fix handling of disconnected directories
` [PATCH v5 2/4] landlock: Improve variable scope
` [PATCH v5 3/4] selftests/landlock: Add tests for access through disconnected paths
` [PATCH v5 4/4] selftests/landlock: Add disconnected leafs and branch test suites


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox