messages from 2025-12-15 03:20:16 to 2025-12-16 15:21:33 UTC [more...]
[PATCH 00/14] Assorted kernel-doc fixes
2025-12-16 15:21 UTC (24+ messages)
` [PATCH 01/14] genalloc: Describe @start_addr parameter in genpool_algo_t
` [PATCH 02/14] mm: Describe @flags parameter in memalloc_flags_save()
` [PATCH 03/14] textsearch: Describe @list member in ts_ops search
` [PATCH 04/14] mm: vmalloc: Fix up vrealloc_node_align() kernel-doc macro name
` [PATCH 05/14] mm, kfence: Describe @slab parameter in __kfence_obj_info()
` [PATCH 06/14] virtio: Describe @map and @vmap members in virtio_device struct
` [PATCH 07/14] fs: Describe @isnew parameter in ilookup5_nowait()
` [PATCH 08/14] VFS: fix __start_dirop() kernel-doc warnings
` [PATCH 09/14] drm/amd/display: Don't use kernel-doc comment in dc_register_software_state struct
` [Linaro-mm-sig] "
` [PATCH 10/14] drm/amdgpu: Describe @AMD_IP_BLOCK_TYPE_RAS in amd_ip_block_type enum
` [PATCH 11/14] drm/gem/shmem: Describe @shmem and @size parameters
` [PATCH 12/14] drm/scheduler: Describe @result in drm_sched_job_done()
` [PATCH 13/14] drm/gpusvm: Fix drm_gpusvm_pages_valid_unlocked() kernel-doc comment
` [PATCH 14/14] net: bridge: Describe @tunnel_hash member in net_bridge_vlan_group struct
[PATCH] dcache: Replace simple_strtoul with kstrtoul in set_dhash_entries
2025-12-16 14:52 UTC
[linux-next:master 1617/1848] include/linux/compiler_types.h:630:45: error: call to '__compiletime_assert_612' declared with attribute error: min(((pos + len - 1) >> 12) - (pos >> 12) + 1, max_pages) signedness error
2025-12-16 11:02 UTC
[PATCH] sysctl: Remove unused ctl_table forward declarations
2025-12-16 12:44 UTC (3+ messages)
[PATCH 6.18 570/614] cifs: Fix handling of a beyond-EOF DIO/unbuffered read over SMB1
2025-12-16 11:15 UTC (2+ messages)
` [PATCH 6.18 571/614] cifs: Fix handling of a beyond-EOF DIO/unbuffered read over SMB2
[PATCH 6.17 469/507] cifs: Fix handling of a beyond-EOF DIO/unbuffered read over SMB1
2025-12-16 11:15 UTC (2+ messages)
` [PATCH 6.17 470/507] cifs: Fix handling of a beyond-EOF DIO/unbuffered read over SMB2
[RFC PATCH v2 0/6] fuse: LOOKUP_HANDLE operation
2025-12-16 12:02 UTC (32+ messages)
` [RFC PATCH v2 2/6] fuse: move fuse_entry_out structs out of the stack
` [RFC PATCH v2 3/6] fuse: initial infrastructure for FUSE_LOOKUP_HANDLE support
` [RFC PATCH v2 4/6] fuse: implementation of the FUSE_LOOKUP_HANDLE operation
` [RFC PATCH v2 5/6] fuse: factor out NFS export related code
` [RFC PATCH v2 6/6] fuse: implementation of export_operations with FUSE_LOOKUP_HANDLE
[PATCH 6.12 328/354] cifs: Fix handling of a beyond-EOF DIO/unbuffered read over SMB2
2025-12-16 11:14 UTC
[PATCH] namespace: Replace simple_strtoul with kstrtoul to parse boot params
2025-12-16 8:41 UTC (4+ messages)
[PATCH] sysctl: Add missing kernel-doc for proc_dointvec_conv
2025-12-16 8:40 UTC (2+ messages)
[RFC][PATCH] get rid of bogus __user in struct xattr_args::value
2025-12-16 8:19 UTC
6.19 tmpfs __d_lookup() lockup
2025-12-16 8:04 UTC (16+ messages)
` shmem_rename() bugs (was Re: 6.19 tmpfs __d_lookup() lockup)
` [RFC][PATCH 2/2] shmem: fix recovery on rename failures
` [git pull] shmem rename fixes
[PATCH v2 0/1] fs/writeback: skip AS_NO_DATA_INTEGRITY mappings in wait_sb_inodes()
2025-12-16 7:07 UTC (4+ messages)
` [PATCH v2 1/1] "
[PATCH] hfsplus: fix missing hfs_bnode_get() in hfs_bnode_create()
2025-12-16 6:01 UTC (3+ messages)
[RFC PATCH v3 00/59] struct filename work
2025-12-16 5:23 UTC (62+ messages)
` [RFC PATCH v3 01/59] do_faccessat(): import pathname only once
` [RFC PATCH v3 02/59] do_fchmodat(): "
` [RFC PATCH v3 03/59] do_fchownat(): "
` [RFC PATCH v3 04/59] do_utimes_path(): "
` [RFC PATCH v3 05/59] chdir(2): "
` [RFC PATCH v3 06/59] chroot(2): "
` [RFC PATCH v3 07/59] user_statfs(): "
` [RFC PATCH v3 08/59] do_sys_truncate(): "
` [RFC PATCH v3 09/59] do_readlinkat(): "
` [RFC PATCH v3 10/59] get rid of audit_reusename()
` [RFC PATCH v3 11/59] ntfs: ->d_compare() must not block
` [RFC PATCH v3 12/59] getname_flags() massage, part 1
` [RFC PATCH v3 13/59] getname_flags() massage, part 2
` [RFC PATCH v3 14/59] struct filename: use names_cachep only for getname() and friends
` [RFC PATCH v3 15/59] struct filename: saner handling of long names
` [RFC PATCH v3 16/59] fs: hide names_cache behind runtime const machinery
` [RFC PATCH v3 17/59] allow incomplete imports of filenames
` [RFC PATCH v3 18/59] struct filename ->refcnt doesn't need to be atomic
` [RFC PATCH v3 19/59] allow to use CLASS() for struct filename *
` [RFC PATCH v3 20/59] file_getattr(): filename_lookup() accepts ERR_PTR() as filename
` [RFC PATCH v3 21/59] file_setattr(): "
` [RFC PATCH v3 22/59] move_mount(): "
` [RFC PATCH v3 23/59] ksmbd_vfs_path_lookup(): vfs_path_parent_lookup() accepts ERR_PTR() as name
` [RFC PATCH v3 24/59] ksmbd_vfs_rename(): "
` [RFC PATCH v3 25/59] do_filp_open(): DTRT when getting ERR_PTR() as pathname
` [RFC PATCH v3 26/59] rename do_filp_open() to do_file_open()
` [RFC PATCH v3 27/59] do_sys_openat2(): get rid of useless check, switch to CLASS(filename)
` [RFC PATCH v3 28/59] simplify the callers of file_open_name()
` [RFC PATCH v3 29/59] simplify the callers of do_open_execat()
` [RFC PATCH v3 30/59] simplify the callers of alloc_bprm()
` [RFC PATCH v3 31/59] switch {alloc,free}_bprm() to CLASS()
` [RFC PATCH v3 32/59] file_[gs]etattr(2): switch to CLASS(filename_maybe_null)
` [RFC PATCH v3 33/59] mount_setattr(2): don't mess with LOOKUP_EMPTY
` [RFC PATCH v3 34/59] do_open_execat(): don't care about LOOKUP_EMPTY
` [RFC PATCH v3 35/59] vfs_open_tree(): use CLASS(filename_uflags)
` [RFC PATCH v3 36/59] name_to_handle_at(): "
` [RFC PATCH v3 37/59] fspick(2): use CLASS(filename_flags)
` [RFC PATCH v3 38/59] do_fchownat(): unspaghettify a bit
` [RFC PATCH v3 39/59] chdir(2): "
` [RFC PATCH v3 40/59] do_utimes_path(): switch to CLASS(filename_uflags)
` [RFC PATCH v3 41/59] do_sys_truncate(): switch to CLASS(filename)
` [RFC PATCH v3 42/59] do_readlinkat(): switch to CLASS(filename_flags)
` [RFC PATCH v3 43/59] do_f{chmod,chown,access}at(): use CLASS(filename_uflags)
` [RFC PATCH v3 44/59] io_openat2(): use CLASS(filename_complete_delayed)
` [RFC PATCH v3 45/59] io_statx(): "
` [RFC PATCH v3 46/59] do_{renameat2,linkat,symlinkat}(): use CLASS(filename_consume)
` [RFC PATCH v3 47/59] do_{mknodat,mkdirat,unlinkat,rmdir}(): "
` [RFC PATCH v3 48/59] namei.c: convert getname_kernel() callers to CLASS(filename_kernel)
` [RFC PATCH v3 49/59] namei.c: switch user pathname imports to CLASS(filename{,_flags})
` [RFC PATCH v3 50/59] filename_...xattr(): don't consume filename reference
` [RFC PATCH v3 51/59] move_mount(2): switch to CLASS(filename_maybe_null)
` [RFC PATCH v3 52/59] chroot(2): switch to CLASS(filename)
` [RFC PATCH v3 53/59] quotactl_block(): "
` [RFC PATCH v3 54/59] statx: switch to CLASS(filename_maybe_null)
` [RFC PATCH v3 55/59] user_statfs(): switch to CLASS(filename)
` [RFC PATCH v3 56/59] mqueue: "
` [RFC PATCH v3 57/59] ksmbd: use CLASS(filename_kernel)
` [RFC PATCH v3 58/59] alpha: switch osf_mount() to strndup_user()
` [RFC PATCH v3 59/59] sysfs(2): fs_index() argument is _not_ a pathname
[PATCH] mm/readahead: read min folio constraints under invalidate lock
2025-12-16 3:53 UTC (6+ messages)
move blk-crypto-fallback to sit above the block layer v2
2025-12-16 3:16 UTC (11+ messages)
` [PATCH 3/9] block: merge bio_split_rw_at into bio_split_io_at
` [PATCH 7/9] blk-crypto: use mempool_alloc_bulk for encrypted bio page allocation
` [PATCH 8/9] blk-crypto: optimize data unit alignment checking
[PATCH v1 00/30] fuse/io-uring: add kernel-managed buffer rings and zero-copy
2025-12-16 3:07 UTC (11+ messages)
` [PATCH v1 22/30] io_uring/rsrc: refactor io_buffer_register_bvec()/io_buffer_unregister_bvec()
` [PATCH v1 23/30] io_uring/rsrc: split io_buffer_register_request() logic
[PATCH] vfs: fix EBUSY on FSCONFIG_CMD_CREATE retry
2025-12-16 2:39 UTC (6+ messages)
[RFC PATCH v2 00/18] io_uring, struct filename and audit
2025-12-16 2:18 UTC (5+ messages)
` [RFC PATCH v2 10/18] get rid of audit_reusename()
` [RFC PATCH v2 18/18] struct filename ->refcnt doesn't need to be atomic
[PATCH v2] ceph: fix kernel crash in ceph_open()
2025-12-15 21:53 UTC
[PATCH 00/46] Allow inlining C helpers into Rust when using LTO
2025-12-15 21:40 UTC (3+ messages)
` (subset) "
[PATCH v2] hfs: replace BUG_ONs with error handling
2025-12-15 19:09 UTC (8+ messages)
[PATCH v2] fs/buffer: add alert in try_to_free_buffers() for folios without buffers
2025-12-15 18:00 UTC (4+ messages)
[PATCH v4 1/3] init: remove deprecated "load_ramdisk" and "prompt_ramdisk" command line parameters
2025-12-15 17:59 UTC (2+ messages)
[viro-vfs:work.filename 32/59] fs/namespace.c:4993:38: sparse: sparse: incorrect type in argument 1 (different address spaces)
2025-12-15 17:47 UTC
[PATCH RFC v2] 9p/virtio: convert to extract_iter_to_sg()
2025-12-15 16:46 UTC (4+ messages)
[ANNOUNCE] util-linux v2.41.3
2025-12-15 15:02 UTC
[RESEND PATCH v6 0/5] proc: subset=pid: Relax check of mount visibility
2025-12-15 14:58 UTC (6+ messages)
[PATCH] 9p/virtio: restrict page pinning to user_backed_iter() iovec
2025-12-15 14:37 UTC (9+ messages)
[PATCH] virtiofs: fix NULL dereference in virtio_fs_add_queues_sysfs()
2025-12-15 14:32 UTC (2+ messages)
[PATCH v2 0/2] filelock: fix conflict detection with userland file delegations
2025-12-15 14:20 UTC (2+ messages)
[PATCH v6 00/15] Create and use APIs to centralise locking for directory ops
2025-12-15 14:19 UTC (9+ messages)
` [PATCH v6 06/15] VFS: introduce start_creating_noperm() and start_removing_noperm()
` [PATCH] fuse: fix conversion of fuse_reverse_inval_entry() to start_removing()
[PATCH v3] iomap: replace folio_batch allocation with stack allocation
2025-12-15 14:17 UTC (2+ messages)
[PATCH] media: mc: fix potential use-after-free in media_request_alloc()
2025-12-15 14:13 UTC (2+ messages)
[PATCH] fs: Remove internal old mount API code
2025-12-15 14:02 UTC (2+ messages)
[PATCH v2] chardev: Switch to guard(mutex) and __free(kfree)
2025-12-15 12:43 UTC (2+ messages)
[RFC LPC2026 PATCH v2 00/11] Specific Purpose Memory NUMA Nodes
2025-12-15 12:38 UTC (6+ messages)
` [RFC PATCH v2 01/11] mm: constify oom_control, scan_control, and alloc_context nodemask
` [RFC PATCH v2 02/11] mm: change callers of __cpuset_zone_allowed to cpuset_zone_allowed
[PATCH v2 0/6] Exposing case folding behavior
2025-12-15 12:37 UTC (3+ messages)
` [PATCH v2 1/6] fs: Add case sensitivity info to file_kattr
[syzbot] [gfs2] KASAN: use-after-free Read in iomap_read_inline_data (2)
2025-12-15 10:44 UTC
[PATCH] virtio_fs: use sysfs_emit_at() instead of snprintf()
2025-12-15 10:02 UTC
[PATCH] chardev: Switch to guard(mutex)
2025-12-15 9:46 UTC (2+ messages)
[PATCH v18 00/42] DEPT(DEPendency Tracker)
2025-12-15 9:06 UTC (8+ messages)
` [PATCH v18 25/42] dept: add documents for dept
` [PATCH v18 41/42] SUNRPC: relocate struct rcu_head to the first field of struct rpc_xprt
[regression] 0c58a97f919c ("fuse: remove tmp folio for writebacks and internal rb tree") results in suspend-to-RAM hang on AMD Ryzen 5 5625U on test scenario involving podman containers, x2go and openjdk workload
2025-12-15 4:44 UTC (3+ messages)
FUSE: [Regression] Fuse legacy path performance scaling lost in v6.14 vs v6.8/6.11 (iodepth scaling with io_uring)
2025-12-15 4:30 UTC (8+ messages)
[viro-vfs:work.filename 58/59] arch/alpha/kernel/osf_sys.c:474:15: error: conflicting types for 'devname'; have 'char *'
2025-12-15 4:21 UTC
[PATCH] fuse: use sysfs_emit() instead of sprintf()
2025-12-15 4:06 UTC (2+ messages)
[PATCH v4] lib: xarray: free unused spare node in xas_create_range()
2025-12-15 3:42 UTC (2+ messages)
[PATCH] adfs: fix memory leak in sb->s_fs_info
2025-12-15 3:14 UTC (2+ messages)
` [PATCH v3] "
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox