messages from 2025-12-16 03:54:49 to 2025-12-18 05:21:53 UTC [more...]
[PATCHSET V4 1/2] fs: generic file IO error reporting
2025-12-18 5:21 UTC (9+ messages)
` [PATCH 1/6] uapi: promote EFSCORRUPTED and EUCLEAN to errno.h
` [PATCH 2/6] fs: report filesystem and file I/O errors to fsnotify
` [PATCH 3/6] iomap: report file I/O errors to the VFS
` [PATCH 4/6] xfs: report fs metadata errors via fsnotify
` [PATCH 5/6] xfs: translate fsdax media errors into file "data lost" errors when convenient
` [PATCH 6/6] ext4: convert to new fserror helpers
NFS dentry caching regression? was Re: [GIT PULL] Please pull NFS client updates for Linux 6.19
2025-12-18 5:13 UTC (5+ messages)
` [External] : "
[PATCH] lib/buildid: use __kernel_read() for sleepable context
2025-12-18 5:13 UTC (2+ messages)
[PATCH] VFS: fix dentry_create() kernel-doc comment
2025-12-18 5:05 UTC
[PATCH] mm/readahead: read min folio constraints under invalidate lock
2025-12-18 4:03 UTC (7+ messages)
[PATCH v2] ceph: fix kernel crash in ceph_open()
2025-12-18 3:50 UTC (4+ messages)
[PATCH] exec: do not call sched_mm_cid_after_execve() on exec fail
2025-12-18 3:23 UTC
[PATCH 00/14] Assorted kernel-doc fixes
2025-12-18 3:14 UTC (15+ messages)
` [PATCH 02/14] mm: Describe @flags parameter in memalloc_flags_save()
` [PATCH 05/14] mm, kfence: Describe @slab parameter in __kfence_obj_info()
` [PATCH 06/14] virtio: Describe @map and @vmap members in virtio_device struct
` [PATCH 09/14] drm/amd/display: Don't use kernel-doc comment in dc_register_software_state struct
` [Linaro-mm-sig] "
` [PATCH 10/14] drm/amdgpu: Describe @AMD_IP_BLOCK_TYPE_RAS in amd_ip_block_type enum
` [PATCH 14/14] net: bridge: Describe @tunnel_hash member in net_bridge_vlan_group struct
[PATCH] mm/memremap: fix spurious large folio warning for FS-DAX
2025-12-18 3:11 UTC (4+ messages)
[PATCHSET V4 2/2] fs: send uevents on mount and unmount
2025-12-18 2:05 UTC (5+ messages)
` [PATCH 1/4] fs: send uevents for filesystem mount events
` [PATCH 2/4] xfs: send uevents when major filesystem events happen
` [PATCH 3/4] ext4: convert ext4_root to a kset
` [PATCH 4/4] ext4: send uevents when major filesystem events happen
[PATCH v4 0/9] dax/hmem, cxl: Coordinate Soft Reserved handling with CXL and HMEM
2025-12-17 23:17 UTC (9+ messages)
` [PATCH v4 1/9] dax/hmem, e820, resource: Defer Soft Reserved insertion until hmem is ready
` [PATCH v4 3/9] dax/hmem: Gate Soft Reserved deferral on DEV_DAX_CXL
[PATCH] 9p/virtio: restrict page pinning to user_backed_iter() iovec
2025-12-17 21:49 UTC (3+ messages)
[RFC PATCH v2 0/6] fuse: LOOKUP_HANDLE operation
2025-12-17 18:02 UTC (46+ messages)
` [RFC PATCH v2 2/6] fuse: move fuse_entry_out structs out of the stack
` [RFC PATCH v2 3/6] fuse: initial infrastructure for FUSE_LOOKUP_HANDLE support
` [RFC PATCH v2 4/6] fuse: implementation of the FUSE_LOOKUP_HANDLE operation
` [RFC PATCH v2 6/6] fuse: implementation of export_operations with FUSE_LOOKUP_HANDLE
` "
[PATCH] fs/proc: Expose mm_cpumask in /proc/[pid]/status
2025-12-17 17:33 UTC (2+ messages)
[PATCH] fuse: Wait on congestion for async readahead
2025-12-17 13:56 UTC (3+ messages)
` [PATCH v2 0/1] fuse: fix performance regression in buffered sequential reads
` [PATCH v2 1/1] fuse: wait on congestion for async readahead
[PATCH] dcache: Replace simple_strtoul with kstrtoul in set_dhash_entries
2025-12-17 12:54 UTC (2+ messages)
re-enable IOCB_NOWAIT writes to files v3
2025-12-17 12:42 UTC (15+ messages)
` [PATCH 01/10] fs: remove inode_update_time
` [PATCH 02/10] fs: allow error returns from generic_update_time
` [PATCH 03/10] fs: exit early in generic_update_time when there is no work
` [PATCH 04/10] fs: factor out a mark_inode_dirty_time helper
` [PATCH 05/10] fs: allow error returns from inode_update_timestamps
` [PATCH 06/10] fs: factor out a sync_lazytime helper
` [PATCH 07/10] fs: add a ->sync_lazytime method
` [PATCH 08/10] fs: add support for non-blocking timestamp updates
` [PATCH 09/10] xfs: implement ->sync_lazytime
` [PATCH 10/10] xfs: enable non-blocking timestamp updates
[PATCH v2] sysctl: Remove unused ctl_table forward declarations
2025-12-17 12:16 UTC
[PATCH] sysctl: Remove unused ctl_table forward declarations
2025-12-17 12:09 UTC (5+ messages)
[RFC PATCH v2] fs: touch up symlink clean up in lookup
2025-12-17 11:45 UTC (3+ messages)
FUSE: [Regression] Fuse legacy path performance scaling lost in v6.14 vs v6.8/6.11 (iodepth scaling with io_uring)
2025-12-17 11:34 UTC (11+ messages)
` "
[RFC PATCH] fs: touch up symlink clean up in lookup
2025-12-17 11:16 UTC (2+ messages)
[PATCH v2] fs: make sure to fail try_to_unlazy() and try_to_unlazy() for LOOKUP_CACHED
2025-12-17 10:48 UTC (7+ messages)
[PATCH] sysctl: Add missing kernel-doc for proc_dointvec_conv
2025-12-17 8:24 UTC (4+ messages)
[PATCH 0/7] sysctl: Replace the converter macros with functions
2025-12-17 8:04 UTC (8+ messages)
` [PATCH 1/7] sysctl: Return -ENOSYS from proc_douintvec_conv when CONFIG_PROC_SYSCTL=n
` [PATCH 2/7] sysctl: clarify proc_douintvec_minmax doc
` [PATCH 3/7] sysctl: Add CONFIG_PROC_SYSCTL guards for converter macros
` [PATCH 4/7] sysctl: Replace UINT converter macros with functions
` [PATCH 5/7] sysctl: Add kernel doc to proc_douintvec_conv
` [PATCH 6/7] sysctl: Replace unidirectional INT converter macros with functions
` [PATCH 7/7] sysctl: replace SYSCTL_INT_CONV_CUSTOM macro "
[PATCH] mm/filemap: fix NULL pointer dereference in do_read_cache_folio()
2025-12-17 7:33 UTC (11+ messages)
move blk-crypto-fallback to sit above the block layer v3
2025-12-17 6:06 UTC (10+ messages)
` [PATCH 1/9] fscrypt: pass a real sector_t to fscrypt_zeroout_range_inline_crypt
` [PATCH 2/9] fscrypt: keep multiple bios in flight in fscrypt_zeroout_range_inline_crypt
` [PATCH 3/9] blk-crypto: add a bio_crypt_ctx() helper
` [PATCH 4/9] blk-crypto: submit the encrypted bio in blk_crypto_fallback_bio_prep
` [PATCH 5/9] blk-crypto: optimize bio splitting in blk_crypto_fallback_encrypt_bio
` [PATCH 6/9] blk-crypto: use on-stack skcipher requests for fallback en/decryption
` [PATCH 7/9] blk-crypto: use mempool_alloc_bulk for encrypted bio page allocation
` [PATCH 8/9] blk-crypto: optimize data unit alignment checking
` [PATCH 9/9] blk-crypto: handle the fallback above the block layer
[PATCH] fs: Remove internal old mount API code
2025-12-17 4:21 UTC (3+ messages)
[PATCH 00/18] cifs: Scripted header file cleanup
2025-12-16 21:57 UTC (2+ messages)
[PATCH] hfsplus: fix missing hfs_bnode_get() in hfs_bnode_create()
2025-12-16 20:28 UTC (4+ messages)
[RFC PATCH v3 00/59] struct filename work
2025-12-16 20:29 UTC (39+ messages)
` [RFC PATCH v3 14/59] struct filename: use names_cachep only for getname() and friends
` [RFC PATCH v3 15/59] struct filename: saner handling of long names
` [RFC PATCH v3 17/59] allow incomplete imports of filenames
` [RFC PATCH v3 18/59] struct filename ->refcnt doesn't need to be atomic
` [RFC PATCH v3 20/59] file_getattr(): filename_lookup() accepts ERR_PTR() as filename
` [RFC PATCH v3 22/59] move_mount(): "
` [RFC PATCH v3 23/59] ksmbd_vfs_path_lookup(): vfs_path_parent_lookup() accepts ERR_PTR() as name
` [RFC PATCH v3 24/59] ksmbd_vfs_rename(): "
` [RFC PATCH v3 25/59] do_filp_open(): DTRT when getting ERR_PTR() as pathname
` [RFC PATCH v3 26/59] rename do_filp_open() to do_file_open()
` [RFC PATCH v3 27/59] do_sys_openat2(): get rid of useless check, switch to CLASS(filename)
` [RFC PATCH v3 28/59] simplify the callers of file_open_name()
` [RFC PATCH v3 29/59] simplify the callers of do_open_execat()
` [RFC PATCH v3 30/59] simplify the callers of alloc_bprm()
` [RFC PATCH v3 31/59] switch {alloc,free}_bprm() to CLASS()
` [RFC PATCH v3 32/59] file_[gs]etattr(2): switch to CLASS(filename_maybe_null)
` [RFC PATCH v3 33/59] mount_setattr(2): don't mess with LOOKUP_EMPTY
` [RFC PATCH v3 34/59] do_open_execat(): don't care about LOOKUP_EMPTY
` [RFC PATCH v3 35/59] vfs_open_tree(): use CLASS(filename_uflags)
` [RFC PATCH v3 36/59] name_to_handle_at(): "
` [RFC PATCH v3 37/59] fspick(2): use CLASS(filename_flags)
` [RFC PATCH v3 38/59] do_fchownat(): unspaghettify a bit
` [RFC PATCH v3 39/59] chdir(2): "
` [RFC PATCH v3 40/59] do_utimes_path(): switch to CLASS(filename_uflags)
` [RFC PATCH v3 41/59] do_sys_truncate(): switch to CLASS(filename)
` [RFC PATCH v3 42/59] do_readlinkat(): switch to CLASS(filename_flags)
` [RFC PATCH v3 43/59] do_f{chmod,chown,access}at(): use CLASS(filename_uflags)
` [RFC PATCH v3 44/59] io_openat2(): use CLASS(filename_complete_delayed)
` [RFC PATCH v3 45/59] io_statx(): "
` [RFC PATCH v3 46/59] do_{renameat2,linkat,symlinkat}(): use CLASS(filename_consume)
` [RFC PATCH v3 47/59] do_{mknodat,mkdirat,unlinkat,rmdir}(): "
` [RFC PATCH v3 48/59] namei.c: convert getname_kernel() callers to CLASS(filename_kernel)
` [RFC PATCH v3 49/59] namei.c: switch user pathname imports to CLASS(filename{,_flags})
` [RFC PATCH v3 50/59] filename_...xattr(): don't consume filename reference
[PATCH v3] hfs: Replace BUG_ON with error handling for CNID count checks
2025-12-16 20:16 UTC (2+ messages)
[PATCH v3] ceph: rework co-maintainers list in MAINTAINERS file
2025-12-16 20:00 UTC
[PATCH fstests v3 0/3] generic: new testcases for delegation support
2025-12-16 18:22 UTC (7+ messages)
` [PATCH fstests v3 3/3] generic: add tests for file delegations
[PATCH v2 0/1] fs/writeback: skip AS_NO_DATA_INTEGRITY mappings in wait_sb_inodes()
2025-12-16 18:13 UTC (5+ messages)
` [PATCH v2 1/1] "
[PATCH] fuse: change fuse_wr_pages() to avoid signedness error from min()
2025-12-16 14:16 UTC
[linux-next:master 1617/1848] include/linux/compiler_types.h:630:45: error: call to '__compiletime_assert_612' declared with attribute error: min(((pos + len - 1) >> 12) - (pos >> 12) + 1, max_pages) signedness error
2025-12-16 11:02 UTC
[PATCH 6.18 570/614] cifs: Fix handling of a beyond-EOF DIO/unbuffered read over SMB1
2025-12-16 11:15 UTC (2+ messages)
` [PATCH 6.18 571/614] cifs: Fix handling of a beyond-EOF DIO/unbuffered read over SMB2
[PATCH 6.17 469/507] cifs: Fix handling of a beyond-EOF DIO/unbuffered read over SMB1
2025-12-16 11:15 UTC (2+ messages)
` [PATCH 6.17 470/507] cifs: Fix handling of a beyond-EOF DIO/unbuffered read over SMB2
[PATCH 6.12 328/354] cifs: Fix handling of a beyond-EOF DIO/unbuffered read over SMB2
2025-12-16 11:14 UTC
[PATCH] namespace: Replace simple_strtoul with kstrtoul to parse boot params
2025-12-16 8:41 UTC (4+ messages)
[RFC][PATCH] get rid of bogus __user in struct xattr_args::value
2025-12-16 8:19 UTC
6.19 tmpfs __d_lookup() lockup
2025-12-16 8:04 UTC (11+ messages)
` shmem_rename() bugs (was Re: 6.19 tmpfs __d_lookup() lockup)
` [git pull] shmem rename fixes
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox