messages from 2026-07-06 15:35:54 to 2026-07-07 18:55:20 UTC [more...]
[PATCH] Documentation: remove the requirement for LLM attribution
2026-07-07 18:55 UTC (28+ messages)
[PATCH v2] hfsplus: validate thread record before delete key rebuild
2026-07-07 18:53 UTC (4+ messages)
[RFC PATCH 0/6] mm/hugetlb: Dynamic, NUMA-aware HugePage Cache & Free Page Reporting
2026-07-07 18:46 UTC (18+ messages)
` [PATCH 1/6] mm/hugetlb: add Kconfig and basic cache infrastructure
` [PATCH 2/6] mm/hugetlb: implement cache recycling and allocation
` [PATCH 3/6] mm/hugetlb: add sysfs interfaces for cache
` [PATCH 4/6] mm/hugetlb: add memory shrinker "
` [PATCH 5/6] Documentation/admin-guide/mm/hugetlbpage.rst: document cache interfaces
` [PATCH 6/6] mm/hugetlb: support free page reporting for cached hugepages
[RFC PATCH v2 00/13] mm: rework anon_vma and remove anon_vma_chain
2026-07-07 17:09 UTC (22+ messages)
` [RFC PATCH v2 01/13] mm: add CONFIG_ANON_VMA_FRACTAL
` [RFC PATCH v2 02/13] mm: implement helpers for ANON_VMA_FRACTAL
` [RFC PATCH v2 03/13] mm: implement __anon_node_prepare "
` [RFC PATCH v2 04/13] mm: implement anon_node_clone "
` [RFC PATCH v2 05/13] mm: implement anon_node_fork_with_prev "
` [RFC PATCH v2 06/13] mm: implement unlink_anon_nodes "
` [RFC PATCH v2 07/13] mm: handle rmap_base changes "
` [RFC PATCH v2 08/13] mm: implement anonymous folio rmap "
` [RFC PATCH v2 09/13] mm: prepare anon_node replacement "
` [RFC PATCH v2 10/13] mm: replace anon_vma with anon_node "
` [RFC PATCH v2 11/13] mm: optimize rmap for ANON_VMA_FRACTAL with PVL
` [RFC PATCH v2 12/13] mm: shared semaphores for ANON_VMA_FRACTAL
` [RFC PATCH v2 13/13] mm: Enable CONFIG_ANON_VMA_FRACTAL by default
[PATCH 0/2] minix: modernize function declarations and eliminating some magic numbers
2026-07-07 16:54 UTC (5+ messages)
` [PATCH 1/2] minix: define constants for dirsize and namelen
` [PATCH 2/2] minix: modernize function declarations in minix.h
[PATCH 0/2] fs: refuse O_TMPFILE creation with an unmapped fsuid or fsgid
2026-07-07 16:47 UTC (7+ messages)
` [PATCH 1/2] "
[PATCH 00/30] mm: make VMA page offset handling more consistent
2026-07-07 16:26 UTC (26+ messages)
` [PATCH 01/30] mm: move vma_start_pgoff() into mm.h and clean up
` [PATCH 02/30] mm: add kdoc comments for vma_start/last_pgoff()
` [PATCH 11/30] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
` [PATCH 12/30] mm/vma: clean up anon_vma_compatible()
` [PATCH 21/30] mm/vma: add and use vma_[add/sub]_pgoff()
` [PATCH 22/30] mm/vma: move __install_special_mapping() to vma.c
` [PATCH 25/30] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
` [PATCH 27/30] mm/vma: correct incorrect vma.h inclusion
` [PATCH 29/30] tools/testing/vma: default VMA flag bits to 64-bit
` [PATCH 17/30] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
[PATCH v2 0/4] fs/pipe: unify the page pools into a single per-pipe pool
2026-07-07 15:29 UTC (6+ messages)
` [PATCH v2 1/4] fs/pipe: move the prealloc pool to per-pipe infrastructure
` [PATCH v2 2/4] fs/pipe: add per-pipe pool push, prefill and trim helpers
` [PATCH v2 3/4] fs/pipe: switch the read and write paths to the per-pipe pool
` [PATCH v2 4/4] fs/pipe: remove the old on-stack prealloc helpers and tmp_page[2]
[PATCH v2] fs/proc/task_mmu: fix PAGEMAP_SCAN written state for unpopulated ptes
2026-07-07 15:13 UTC
[PATCH] vfs: missing inode operation should return a consistent error code
2026-07-07 14:27 UTC (3+ messages)
[PATCH v3 00/14] vfs: add O_CREAT|O_DIRECTORY to open*(2)
2026-07-07 14:18 UTC (38+ messages)
` [PATCH v3 01/14] fs/namei.c: use trailing_slashes()
` [PATCH v3 03/14] vfs: prepare vfs_creat|mkdir_no_perm for reuse in lookup_open()
` [PATCH v3 04/14] vfs: call audit_inode_child() in lookup_open() on failure too
` [PATCH v3 05/14] fs/namei.c: update docstring of atomic_open()
` [PATCH v3 07/14] vfs: move ->create check in lookup_open() to before try_break_deleg()
` [PATCH v3 08/14] vfs: lookup_open(): use vfs_create_no_perm()
` [PATCH v3 09/14] vfs: add O_CREAT|O_DIRECTORY to open*(2)
` [PATCH v3 10/14] vfs: move O_IS_MKDIR check from lookup_open() into individual filesystems
` [PATCH v3 13/14] selftest: fix headers in fclog.c
` [PATCH v3 14/14] selftest: add tests for open*(O_CREAT|O_DIRECTORY)
[PATCH v19 00/40] DEPT(DEPendency Tracker)
2026-07-07 14:18 UTC (6+ messages)
` [PATCH v19 22/40] dept: track PG_locked with dept
` [PATCH v19 31/40] dept: assign unique dept_key to each distinct wait_for_completion() caller
[PATCH v19 0/8] rust: add `Ownable` trait and `Owned` type
2026-07-07 13:04 UTC (5+ messages)
` [PATCH v19 3/8] rust: implement `ForeignOwnable` for `Owned`
` [PATCH v19 4/8] rust: page: convert to `Ownable`
[PATCH v2 6/7] nfs: Optimize direct I/O to use folios for requests
2026-07-07 12:08 UTC (6+ messages)
[RFC PATCH] fs: introduce pluggable ELF interpreter loader registry
2026-07-07 11:34 UTC (5+ messages)
` [RFC PATCH] fs: binfmt_misc: introduce eBPF-based matching and interpreter selection
[PATCH v2 0/3] VFS: refactor lookup_open and add vfs_lookup()
2026-07-07 11:26 UTC (7+ messages)
` [PATCH v2 3/3] VFS: add vfs_lookup_open() for nfsd
[PATCH v2] audit: add FSOPEN record to log filesystem name
2026-07-07 11:23 UTC (2+ messages)
[PATCH 1/3] iomap: consolidate bio submission
2026-07-07 11:06 UTC (4+ messages)
[PATCH net-next v4 0/3] net: af_unix: useful handling of LSM denials on SCM_RIGHTS
2026-07-07 11:02 UTC (8+ messages)
` [PATCH net-next v4 1/3] net: scm: move scm_detach_fds() from common path to scm_recv_unix()
` [PATCH net-next v4 2/3] net: af_unix: useful handling of LSM denials on SCM_RIGHTS
` [PATCH net-next v4 3/3] selftest: Add tests for "
[PATCH v13 0/4] ext4: deferred iput framework for EA inodes
2026-07-07 11:00 UTC (4+ messages)
` [syzbot ci] "
[PATCH v6 0/2] Avoid synchronize_rcu() for every thread drop in Rust Binder
2026-07-07 10:43 UTC (3+ messages)
` [PATCH v6 1/2] rust: poll: use kfree_rcu() for PollCondVar
` [PATCH v6 2/2] rust_binder: move (e)poll wait queue to Process
[PATCH 00/13] convert more vm_flags_t users to vma_flags_t
2026-07-07 10:16 UTC (9+ messages)
` [PATCH 02/13] mm/vma: update do_mmap() to use vma_flags_t
` [PATCH 03/13] mm: convert __get_unmapped_area() "
` [PATCH 04/13] mm: update generic_get_unmapped_area[_topdown]() "
[PATCH v3 0/5] Fix quota evasion on xfs and add capable_noaudit
2026-07-07 9:26 UTC (7+ messages)
` [PATCH v3 2/5] capability: Add new capable_noaudit
` [PATCH v3 4/5] xfs: replace ns_capable_noaudit
[PATCH 0/4] fs: mark selected blocking waits as freezable
2026-07-07 7:50 UTC (3+ messages)
[PATCH v6 0/3] iomap: add simple dio path for small direct I/O
2026-07-07 6:57 UTC (11+ messages)
` [PATCH v6 3/3] "
[PATCH v1] fs: fix two spelling mistakes in comments
2026-07-07 6:49 UTC (3+ messages)
` "
[PATCH 1/1] iomap: avoid compaction for costly folio order allocation
2026-07-07 6:22 UTC (4+ messages)
[PATCH] netfs: fix ENOMEM handling in netfs_writepages() to drain all dirty folios
2026-07-07 6:13 UTC (2+ messages)
[PATCH] iomap: add a separate bio_set for iomap_split_ioend
2026-07-07 5:04 UTC (3+ messages)
[PATCH v2 0/6] ext4: fix unaligned edge handling in FALLOC_FL_WRITE_ZEROES
2026-07-07 5:01 UTC (8+ messages)
` [PATCH v2 1/6] ext4: move partial block zeroing earlier in ext4_zero_range()
` [PATCH v2 2/6] ext4: clarify return semantics of ext4_load_tail_bh()
` [PATCH v2 3/6] ext4: track partial-zero outcome per edge in ext4_zero_partial_blocks()
` [PATCH v2 4/6] ext4: zero out whole block for clean edges in WRITE_ZEROES
` [PATCH v2 5/6] ext4: write back partial-zeroed "
` [PATCH v2 6/6] ext4: protect WRITE_ZEROES written extents with orphan list
[PATCH 6.6.y] coredump: fix pidfs file refcount leak in umh_coredump_setup
2026-07-07 3:46 UTC
[Question] QNX4 write support?
2026-07-07 3:29 UTC
[PATCH] fs/proc/task_mmu: count KSM-placed zero pages in smaps
2026-07-07 2:49 UTC (4+ messages)
[PATCH] fuse: add folio_max_order and folio_min_order controls in fusectl
2026-07-07 1:06 UTC (3+ messages)
[PATCH v6 0/8] lsm: Replace security_sb_mount with granular mount hooks
2026-07-06 23:50 UTC (9+ messages)
` [PATCH v6 1/8] lsm: Add "
` [PATCH v6 2/8] apparmor: Remove redundant MS_MGC_MSK stripping in apparmor_sb_mount
` [PATCH v6 3/8] apparmor: Convert from sb_mount to granular mount hooks
` [PATCH v6 4/8] selinux: "
` [PATCH v6 5/8] landlock: "
` [PATCH v6 6/8] tomoyo: "
` [PATCH v6 7/8] vfs: Replace security_sb_mount/security_move_mount with granular hooks
` [PATCH v6 8/8] lsm: Remove security_sb_mount and security_move_mount
[PATCH v2] hfs: port HFS+ b-tree bitmap corruption check
2026-07-06 23:11 UTC (2+ messages)
[PATCH] hfs: fix error code when writing beyond volume capacity
2026-07-06 22:18 UTC
[PATCH] hfsplus: fix error code when writing beyond volume capacity
2026-07-06 22:17 UTC
[syzbot] [netfs?] WARNING in netfs_writepages (3)
2026-07-06 21:44 UTC
how about enabling Sashiko responses on this list
2026-07-06 21:07 UTC
[PATCH] proc: Fix broken error paths for namespace links
2026-07-06 20:59 UTC (4+ messages)
[PATCH 1/2] proc: protect ptrace_may_access() with exec_update_lock (part 1)
2026-07-06 18:24 UTC (5+ messages)
` [PATCH] "
[PATCH v2] proc: only bump parent nlink when registering directories
2026-07-06 17:39 UTC (5+ messages)
[RFC] Null Namespaces
2026-07-06 17:10 UTC (8+ messages)
[PATCH v5 00/21] netfs: Keep track of folios in a segmented bio_vec[] chain
2026-07-06 15:51 UTC (2+ messages)
[PATCH v5 00/21] netfs: Keep track of folios in a segmented bio_vec[] chain
2026-07-06 15:34 UTC (12+ messages)
` [PATCH v5 11/21] cachefiles: Don't rely on backing fs storage map for most use cases
` [PATCH v5 12/21] netfs: Add the cache object ID to netfs_read/write tracepoints
` [PATCH v5 13/21] netfs: Switch to using bvecq rather than folio_queue and rolling_buffer
` [PATCH v5 14/21] smbdirect: Remove support for ITER_FOLIOQ from smbdirect_map_sges_from_iter()
` [PATCH v5 15/21] netfs: Remove netfs_alloc/free_folioq_buffer()
` [PATCH v5 16/21] netfs: Remove netfs_extract_user_iter()
` [PATCH v5 17/21] iov_iter: Remove ITER_FOLIOQ
` [PATCH v5 18/21] netfs: Remove folio_queue and rolling_buffer
` [PATCH v5 19/21] netfs: Check for too much data being read
` [PATCH v5 20/21] netfs: Limit the minimum trigger for progress reporting
` [PATCH v5 21/21] netfs: Combine prepare and issue ops and grab the buffers on request
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox