From mboxrd@z Thu Jan 1 00:00:00 1970 From: hooanon05@yahoo.co.jp Subject: vfs_splice_read()? Date: Mon, 23 Jul 2007 23:39:43 +0900 Message-ID: To: linux-fsdevel@vger.kernel.org Return-path: Received: from vsmtp01.dti.ne.jp ([202.216.231.136]:55281 "EHLO vsmtp01.dti.ne.jp" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753834AbXGWOtq (ORCPT ); Mon, 23 Jul 2007 10:49:46 -0400 Received: from jroun (PPPa1889.e4.eacc.dti.ne.jp [124.255.43.119]) by vsmtp01.dti.ne.jp (3.11v) with ESMTP AUTH id l6NEdif4027115 for ; Mon, 23 Jul 2007 23:39:44 +0900 (JST) Received: from jro by jroun id 1ICz4Z-0000rU-PD for ; Mon, 23 Jul 2007 23:39:43 +0900 Sender: linux-fsdevel-owner@vger.kernel.org List-Id: linux-fsdevel.vger.kernel.org Hello list, I am developing a filesystem which supports f_op->sendfile. Recently I noticed, in -git tree, ->sendfile is removed and it should be replaced by ->splice_read. If VFS helper for splice_read, like vfs_read(), existed, it had to be very helpful. There already exists a static function called do_splice_to() and I'd like to suggest to rename it to vfs_splice_read() and make it global, EXPORT_SYMBOL. If fsdevel members agree with that, I will send a small patch for it. Junjiro Okajima