Linux filesystem development
 help / color / mirror / Atom feed
From: Matthew Wilcox <willy@infradead.org>
To: Amy Parker <apark0006@student.cerritos.edu>
Cc: linux-fsdevel@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] dax: use switch statement over chained ifs
Date: Tue, 17 Jan 2023 02:41:37 +0000	[thread overview]
Message-ID: <Y8YK4c6KQg2xjM+E@casper.infradead.org> (raw)
In-Reply-To: <CAPOgqxF_xEgKspetRJ=wq1_qSG3h8mkyXC58TXkUvx0agzEm_A@mail.gmail.com>

On Mon, Jan 16, 2023 at 06:11:00PM -0800, Amy Parker wrote:
> This patch uses a switch statement for pe_order, which improves
> readability and on some platforms may minorly improve performance. It
> also, to improve readability, recognizes that `PAGE_SHIFT - PAGE_SHIFT' is
> a constant, and uses 0 in its place instead.
> 
> Signed-off-by: Amy Parker <apark0006@student.cerritos.edu>

Hi Amy,

Thanks for the patch!  Two problems.  First, your mailer seems to have
mangled the patch; in my tree these are tab indents, and the patch has
arrived with four-space indents, so it can't be applied.

The second problem is that this function should simply not exist.
I forget how we ended up with enum page_entry_size, but elsewhere
we simply pass 'order' around.  So what I'd really like to see is
a patch series that eliminates page_entry_size everywhere.

I can outline a way to do that in individual patches if that would be
helpful.

>  fs/dax.c | 13 ++++++++-----
>  1 file changed, 8 insertions(+), 5 deletions(-)
> 
> diff --git a/fs/dax.c b/fs/dax.c
> index c48a3a93ab29..e8beed601384 100644
> --- a/fs/dax.c
> +++ b/fs/dax.c
> @@ -32,13 +32,16 @@
> 
>  static inline unsigned int pe_order(enum page_entry_size pe_size)
>  {
> -    if (pe_size == PE_SIZE_PTE)
> -        return PAGE_SHIFT - PAGE_SHIFT;
> -    if (pe_size == PE_SIZE_PMD)
> +    switch (pe_size) {
> +    case PE_SIZE_PTE:
> +        return 0;
> +    case PE_SIZE_PMD:
>          return PMD_SHIFT - PAGE_SHIFT;
> -    if (pe_size == PE_SIZE_PUD)
> +    case PE_SIZE_PUD:
>          return PUD_SHIFT - PAGE_SHIFT;
> -    return ~0;
> +    default:
> +        return ~0;
> +    }
>  }
> 
>  /* We choose 4096 entries - same as per-zone page wait tables */
> -- 
> 2.39.0

  reply	other threads:[~2023-01-17  2:50 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-01-17  2:11 [PATCH] dax: use switch statement over chained ifs Amy Parker
2023-01-17  2:41 ` Matthew Wilcox [this message]
2023-01-17  5:07   ` Amy Parker
2023-01-17 14:23     ` Matthew Wilcox
2023-01-17 15:52 ` David Laight

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Y8YK4c6KQg2xjM+E@casper.infradead.org \
    --to=willy@infradead.org \
    --cc=apark0006@student.cerritos.edu \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox