From: "Lorenzo Stoakes (ARM)" <ljs@kernel.org>
To: "Matthew Wilcox (Oracle)" <willy@infradead.org>
Cc: Andrew Morton <akpm@linux-foundation.org>,
Jane Chu <jane.chu@oracle.com>,
linux-mm@kvack.org, Muchun Song <muchun.song@linux.dev>,
Oscar Salvador <osalvador@suse.de>,
David Hildenbrand <david@kernel.org>,
Miaohe Lin <linmiaohe@huawei.com>,
Naoya Horiguchi <nao.horiguchi@gmail.com>,
Jan Kara <jack@suse.cz>,
linux-fsdevel@vger.kernel.org,
Christian Brauner <christian@brauner.io>,
Jiaqi Yan <jiaqiyan@google.com>
Subject: Re: [PATCH v9 00/15] Use generic_file_read_iter() in hugetlbfs
Date: Thu, 13 Aug 2026 09:37:41 +0100 [thread overview]
Message-ID: <an2B3q2apR0qrS_N@lucifer> (raw)
In-Reply-To: <20260805210557.1118966-1-willy@infradead.org>
On Wed, Aug 05, 2026 at 10:05:40PM +0100, Matthew Wilcox (Oracle) wrote:
> This set of patches are separated out from Jane's earlier series.
> https://lore.kernel.org/linux-mm/20260617172534.1740152-1-jane.chu@oracle.com/
>
> We need three things to use filemap_read_iter() instead of a hugetlbfs
> specific read_iter: hwpoison handling, treating gaps in the pagecache as
> holes, and having hugetlb set the folio size in the mapping. hwopison
> handling turned out to need a lot of prep work; the other two things
> are fairly straightforward.
>
> Sashiko complains that the implementation of AS_AUTHORITATIVE is
> incomplete, but hugetlbfs doesn't use any of that functionality.
> We'll add it when we need it, either when hugetlbfs uses it, or when we
> convert shmem to use filemap.
>
> v8 here:
> https://lore.kernel.org/linux-mm/20260731200802.574821-1-willy@infradead.org/
>
> Changes from v7:
> - Fix the KPF_HWPOISON blooper
> - Expand HVO in a comment
> - Collect R-b tags from Gregory & Jane
>
> Jane Chu (2):
> filemap: Add hwpoison handling to filemap_read()
> hugetlb: replace hugetlbfs_read_iter() with generic_file_read_iter()
>
> Matthew Wilcox (Oracle) (13):
> memory-failure: Fix hardware poison check in unpoison_memory() again
> memory-failure: Prevent hugetlb freeing during unpoisoning
> mm: Rename folio_contain_hwpoison_page() to folio_has_hwpoison_page()
> hugetlb: Mark some function arguments as const
> guest_memfd: Use folio_has_hwpoisoned_page()
> kpageflags: Use is_page_hwpoison() to set KPF_HWPOISON
> hugetlb: Move poison to pages before clearing hugetlb page type
> hugetlb: Use the has_hwpoisoned flag
> mm: Remove locking mf_mutex in is_raw_hwpoison_page_in_hugepage()
> mm: Check individual hugetlb pages for poison
> filemap: Remove checks in mapping_set_folio_order_range()
> hugetlb: Set mapping folio order
> filemap: Add support for authoritative mappings
>
> fs/Kconfig | 2 +-
> fs/hugetlbfs/inode.c | 123 +++--------------------
> fs/proc/page.c | 8 +-
> include/linux/hugetlb.h | 43 +++++---
> include/linux/mm_types.h | 4 +-
> include/linux/page-flags.h | 64 ++++++++++--
> include/linux/pagemap.h | 45 +++++----
> mm/Kconfig | 6 +-
> mm/filemap.c | 51 +++++++++-
> mm/huge_memory.c | 2 +-
> mm/hugetlb.c | 41 ++++----
> mm/memory-failure.c | 197 +++++++++++++++++++++++++------------
> mm/memory_hotplug.c | 2 +-
> mm/rmap.c | 43 +++++---
Much as I'd like to not look at this, nor think about it, nor even admit that
any of this actually exists, I do co-maintain the rmap with David so please do
cc- me on future revisions :)
> mm/shmem.c | 2 +-
> mm/vmscan.c | 2 +-
> virt/kvm/guest_memfd.c | 2 +-
> 17 files changed, 368 insertions(+), 269 deletions(-)
>
> --
> 2.47.3
>
>
--
Cheers, Lorenzo
prev parent reply other threads:[~2026-08-13 8:38 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-05 21:05 [PATCH v9 00/15] Use generic_file_read_iter() in hugetlbfs Matthew Wilcox (Oracle)
2026-08-05 21:05 ` [PATCH v9 01/15] memory-failure: Fix hardware poison check in unpoison_memory() again Matthew Wilcox (Oracle)
2026-08-05 21:05 ` [PATCH v9 02/15] memory-failure: Prevent hugetlb freeing during unpoisoning Matthew Wilcox (Oracle)
2026-08-05 21:05 ` [PATCH v9 03/15] mm: Rename folio_contain_hwpoison_page() to folio_has_hwpoison_page() Matthew Wilcox (Oracle)
2026-08-13 7:20 ` David Hildenbrand (Arm)
2026-08-05 21:05 ` [PATCH v9 04/15] hugetlb: Mark some function arguments as const Matthew Wilcox (Oracle)
2026-08-05 21:05 ` [PATCH v9 05/15] guest_memfd: Use folio_has_hwpoisoned_page() Matthew Wilcox (Oracle)
2026-08-13 7:20 ` David Hildenbrand (Arm)
2026-08-13 11:50 ` Matthew Wilcox
2026-08-05 21:05 ` [PATCH v9 06/15] kpageflags: Use is_page_hwpoison() to set KPF_HWPOISON Matthew Wilcox (Oracle)
2026-08-13 7:25 ` David Hildenbrand (Arm)
2026-08-13 9:01 ` David Hildenbrand (Arm)
2026-08-05 21:05 ` [PATCH v9 07/15] hugetlb: Move poison to pages before clearing hugetlb page type Matthew Wilcox (Oracle)
2026-08-05 21:05 ` [PATCH v9 08/15] hugetlb: Use the has_hwpoisoned flag Matthew Wilcox (Oracle)
2026-08-13 8:29 ` David Hildenbrand (Arm)
2026-08-13 11:12 ` Pedro Falcato
2026-08-05 21:05 ` [PATCH v9 09/15] mm: Remove locking mf_mutex in is_raw_hwpoison_page_in_hugepage() Matthew Wilcox (Oracle)
2026-08-05 21:05 ` [PATCH v9 10/15] mm: Check individual hugetlb pages for poison Matthew Wilcox (Oracle)
2026-08-05 21:05 ` [PATCH v9 11/15] filemap: Add hwpoison handling to filemap_read() Matthew Wilcox (Oracle)
2026-08-13 10:55 ` Pedro Falcato
2026-08-05 21:05 ` [PATCH v9 12/15] filemap: Remove checks in mapping_set_folio_order_range() Matthew Wilcox (Oracle)
2026-08-13 11:05 ` Pedro Falcato
2026-08-05 21:05 ` [PATCH v9 13/15] hugetlb: Set mapping folio order Matthew Wilcox (Oracle)
2026-08-13 11:06 ` Pedro Falcato
2026-08-05 21:05 ` [PATCH v9 14/15] filemap: Add support for authoritative mappings Matthew Wilcox (Oracle)
2026-08-13 11:10 ` Pedro Falcato
2026-08-05 21:05 ` [PATCH v9 15/15] hugetlb: replace hugetlbfs_read_iter() with generic_file_read_iter() Matthew Wilcox (Oracle)
2026-08-13 11:10 ` Pedro Falcato
2026-08-06 19:47 ` [PATCH v9 00/15] Use generic_file_read_iter() in hugetlbfs jane.chu
2026-08-13 8:37 ` Lorenzo Stoakes (ARM) [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=an2B3q2apR0qrS_N@lucifer \
--to=ljs@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=christian@brauner.io \
--cc=david@kernel.org \
--cc=jack@suse.cz \
--cc=jane.chu@oracle.com \
--cc=jiaqiyan@google.com \
--cc=linmiaohe@huawei.com \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=muchun.song@linux.dev \
--cc=nao.horiguchi@gmail.com \
--cc=osalvador@suse.de \
--cc=willy@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox