Linux GPIO subsystem development
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@intel.com>
To: Mika Westerberg <mika.westerberg@linux.intel.com>
Cc: Matti Vaittinen <matti.vaittinen@fi.rohmeurope.com>,
	mazziesaccount@gmail.com, Andy Shevchenko <andy@kernel.org>,
	Linus Walleij <linus.walleij@linaro.org>,
	linux-gpio@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 0/3] Use new GPIO direction defines for intel pinctrl
Date: Thu, 12 Dec 2019 15:29:35 +0200	[thread overview]
Message-ID: <20191212132935.GL32742@smile.fi.intel.com> (raw)
In-Reply-To: <20191212112135.GE2110480@lahna.fi.intel.com>

On Thu, Dec 12, 2019 at 01:21:35PM +0200, Mika Westerberg wrote:
> On Thu, Dec 12, 2019 at 08:33:54AM +0200, Matti Vaittinen wrote:
> > We added definitions for GPIO line directions here:
> > https://git.kernel.org/pub/scm/linux/kernel/git/linusw/linux-gpio.git/commit/?id=9208b1e77d6e8e9776f34f46ef4079ecac9c3c25
> > 
> > Let's use them on Intel pincontrollers too.
> > 
> > Changes for v2:
> >   - Replaced ternary operator with if() for better readability
> > 
> > ---
> > 
> > Matti Vaittinen (3):
> >   pinctrl: pinctrl-intel: Use GPIO direction definitions
> >   pinctrl: pinctrl-cherryview: Use GPIO direction definitions
> >   pinctrl: pinctrl-baytrail: Use GPIO direction definitions
> 
> Andy, please pick these up with my,
> 
> Acked-by: Mika Westerberg <mika.westerberg@linux.intel.com>

Pushed to my review and testing queue, thanks!

-- 
With Best Regards,
Andy Shevchenko



      reply	other threads:[~2019-12-12 13:29 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-12-12  6:33 [PATCH v2 0/3] Use new GPIO direction defines for intel pinctrl Matti Vaittinen
2019-12-12  6:34 ` [PATCH v2 1/3] pinctrl: pinctrl-intel: Use GPIO direction definitions Matti Vaittinen
2019-12-12  6:35 ` [PATCH v2 2/3] pinctrl: pinctrl-cherryview: " Matti Vaittinen
2019-12-12  6:35 ` [PATCH v2 3/3] pinctrl: pinctrl-baytrail: " Matti Vaittinen
2019-12-12  6:37   ` Vaittinen, Matti
2019-12-12 11:21 ` [PATCH v2 0/3] Use new GPIO direction defines for intel pinctrl Mika Westerberg
2019-12-12 13:29   ` Andy Shevchenko [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20191212132935.GL32742@smile.fi.intel.com \
    --to=andriy.shevchenko@intel.com \
    --cc=andy@kernel.org \
    --cc=linus.walleij@linaro.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=matti.vaittinen@fi.rohmeurope.com \
    --cc=mazziesaccount@gmail.com \
    --cc=mika.westerberg@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox