Linux GPIO subsystem development
 help / color / mirror / Atom feed
 messages from 2026-07-27 07:43:36 to 2026-07-27 11:23:37 UTC [more...]

[PATCH v8 0/9] gpio: realtek: Add support for Realtek DHC RTD1625
 2026-07-27 11:23 UTC  (5+ messages)
` [PATCH v8 9/9] gpio: realtek: Add driver for Realtek DHC RTD1625 SoC

[PATCH v2] gpio: gpio-by-pinctrl: Apply initial value in direction output wrapper
 2026-07-27 11:14 UTC  (2+ messages)

[PATCH 00/36] treewide: remove conditional returns with no effect
 2026-07-27 11:08 UTC  (4+ messages)

[PATCH v1 0/7] gpiolib: kill gpio_request_one()
 2026-07-27  9:53 UTC  (5+ messages)
` [PATCH v1 2/7] media: em28xx: Split em28xx_pctv_290e_set_lna_gpio() helper
` [PATCH v1 3/7] media: em28xx: Open code gpio_request_one()

[PATCH v7 00/34] pinctrl: airoha: split on shared and SoC drivers, add more SoCs
 2026-07-27  9:46 UTC  (45+ messages)
` [PATCH v7 01/34] dt-bindings: pinctrl: airoha: en7581: fix misprint in i2s function name
` [PATCH v7 02/34] dt-bindings: pinctrl: airoha: en7581: fix pwm pin-groups
` [PATCH v7 04/34] pinctrl: airoha: an7581: fix misprint in bitfield name
` [PATCH v7 07/34] dt-bindings: pinctrl: airoha: an7583: remove i2c pin function
` [PATCH v7 12/34] pinctrl: airoha: add missed get_direction() function for gpio_chip
` [PATCH v7 13/34] pinctrl: airoha: add set_direction() helper "
` [PATCH v7 14/34] pinctrl: airoha: fix potential kenel panic in IRQ handling code
` [PATCH v7 15/34] pinctrl: airoha: fix IRQ mask/unmask code
` [PATCH v7 16/34] pinctrl: airoha: add missed IRQ resource helpers
` [PATCH v7 17/34] pinctrl: airoha: fix edge-triggered interrupts handling
` [PATCH v7 18/34] pinctrl: airoha: remove not needed irq_type[] array
` [PATCH v7 20/34] pinctrl: airoha: split driver on shared code and SoC specific drivers
` [PATCH v7 21/34] pinctrl: airoha: an7581: remove en7581 prefix from variable names
` [PATCH v7 22/34] pinctrl: airoha: an7583: remove an7583 prefix from variable names and definitions
` [PATCH v7 23/34] pinctrl: airoha: an7583: rename registers to match its an7583 names
` [PATCH v7 24/34] pinctrl: airoha: an7583: add support for npu_uart pinmux
` [PATCH v7 25/34] dt-bindings: pinctrl: airoha: an7583: add npu_uart pin group
` [PATCH v7 26/34] pinctrl: airoha: an7583: add support for pon_alt pinmux
` [PATCH v7 27/34] dt-bindings: pinctrl: airoha: an7583: add pon_alt pin group
` [PATCH v7 28/34] pinctrl: airoha: an7583: add support for olt pinmux
` [PATCH v7 29/34] dt-bindings: pinctrl: airoha: an7583: add olt function/group
` [PATCH v7 30/34] pinctrl: airoha: add support of en7523 SoC
` [PATCH v7 31/34] pinctrl: airoha: try to find chip scu node by phandle first
` [PATCH v7 32/34] dt-bindings: pinctrl: airoha: add support of en7523 pin controller
` [PATCH v7 33/34] pinctrl: airoha: add support of an7563 SoC
` [PATCH v7 34/34] dt-bindings: pinctrl: airoha: add support of an7563 pin controller

[GIT PULL] Pin control fixes for v7.2
 2026-07-27  9:25 UTC 

[PATCH v2] gpio: pca953x: fix cache_only and IRQ state on restore_context() failure
 2026-07-27  8:02 UTC 

[GIT PULL] gpio: legacy interface cleanups for 7.3
 2026-07-27  7:57 UTC  (2+ messages)

[PATCH] gpio: pca953x: restore cache_only state on resume failure
 2026-07-27  7:53 UTC  (3+ messages)

[PATCH v4 00/13] notifier: add device-managed registration APIs and convert drivers
 2026-07-27  7:47 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox