Linux GPIO subsystem development
 help / color / mirror / Atom feed
 messages from 2026-07-27 07:43:45 to 2026-07-27 20:15:59 UTC [more...]

[PATCH v8 00/35] pinctrl: airoha: split on shared and SoC drivers, add more SoCs
 2026-07-27 20:15 UTC  (39+ messages)
` [PATCH v8 01/35] dt-bindings: pinctrl: airoha: en7581: fix misprint in i2s function name
` [PATCH v8 02/35] dt-bindings: pinctrl: airoha: en7581: fix pwm pin-groups
` [PATCH v8 03/35] dt-bindings: pinctrl: airoha: an7583: fix device tree binding schema
` [PATCH v8 04/35] pinctrl: airoha: fix mdio bitfield names
` [PATCH v8 05/35] pinctrl: airoha: an7581: fix pinconf of i2c_scl/i2c_sda pins
` [PATCH v8 06/35] pinctrl: airoha: an7583: fix I2C0_SDA_PD register bit order
` [PATCH v8 07/35] pinctrl: airoha: an7583: there are no muxes to enable i2c buses
` [PATCH v8 08/35] dt-bindings: pinctrl: airoha: an7583: remove i2c pin function
` [PATCH v8 09/35] pinctrl: airoha: an7581: fix mux/conf of pcie_reset pins
` [PATCH v8 10/35] dt-bindings: pinctrl: airoha: en7581: allow configuration of pcie_reset pins as gpio or pwm
` [PATCH v8 11/35] pinctrl: airoha: an7583: fix muxing of non-gpio default pins
` [PATCH v8 12/35] dt-bindings: pinctrl: airoha: an7583: allow configuration of non-gpio default pins as gpio and pwm
` [PATCH v8 13/35] pinctrl: airoha: add missed get_direction() function for gpio_chip
` [PATCH v8 14/35] pinctrl: airoha: add set_direction() helper "
` [PATCH v8 15/35] pinctrl: airoha: fix getting gpiochip/pinctrl pointers in the IRQ handling code
` [PATCH v8 16/35] pinctrl: airoha: fix IRQ mask/unmask code
` [PATCH v8 17/35] pinctrl: airoha: add missed IRQ resource helpers
` [PATCH v8 18/35] pinctrl: airoha: fix edge-triggered interrupts handling
` [PATCH v8 19/35] pinctrl: airoha: remove not needed irq_type[] array
` [PATCH v8 20/35] pinctrl: airoha: move common definitions to the separate header
` [PATCH v8 21/35] pinctrl: airoha: split driver on shared code and SoC specific drivers
` [PATCH v8 22/35] pinctrl: airoha: an7581: remove en7581 prefix from variable names
` [PATCH v8 23/35] pinctrl: airoha: an7583: remove an7583 prefix from variable names and definitions
` [PATCH v8 24/35] pinctrl: airoha: an7583: rename registers to match its an7583 names
` [PATCH v8 25/35] pinctrl: airoha: an7583: add support for npu_uart pinmux
` [PATCH v8 26/35] dt-bindings: pinctrl: airoha: an7583: add npu_uart pin group
` [PATCH v8 27/35] pinctrl: airoha: an7583: add support for pon_alt pinmux
` [PATCH v8 28/35] dt-bindings: pinctrl: airoha: an7583: add pon_alt pin group
` [PATCH v8 29/35] pinctrl: airoha: an7583: add support for olt pinmux
` [PATCH v8 30/35] dt-bindings: pinctrl: airoha: an7583: add olt function/group
` [PATCH v8 31/35] pinctrl: airoha: add support of en7523 SoC
` [PATCH v8 32/35] pinctrl: airoha: try to find chip scu node by phandle first
` [PATCH v8 33/35] dt-bindings: pinctrl: airoha: add support of en7523 pin controller
` [PATCH v8 34/35] pinctrl: airoha: add support of an7563 SoC
` [PATCH v8 35/35] dt-bindings: pinctrl: airoha: add support of an7563 pin controller

[PATCH] pinctrl: samsung: exynos: replace irq_of_parse_and_map with modern APIs
 2026-07-27 19:48 UTC 

[PATCH v4 00/13] notifier: add device-managed registration APIs and convert drivers
 2026-07-27 18:48 UTC  (7+ messages)
` [PATCH v4 10/13] platform/x86: uniwill-wmi: use devm_blocking_notifier_chain_register()
` [PATCH v4 12/13] gpio: gpiolib-kunit: "

[PATCH] gpio: pch: use raw_spinlock_t for the register lock
 2026-07-27 15:18 UTC  (4+ messages)

[PATCH] pinctrl: qcom: ipq9650: fix audio_sec_mclk_in1/out1 group pins
 2026-07-27 14:48 UTC  (2+ messages)

[PATCH] pinctrl: qcom: Add irq_get/set_irqchip_state() for msm gpio irqchip
 2026-07-27 14:24 UTC  (2+ messages)

[RESEND V2 1/2] dt-bindings: pinctrl: tegra264: fix DAP2 DIN/DOUT pin names
 2026-07-27 14:11 UTC  (2+ messages)
` [RESEND V2 2/2] pinctrl: tegra264: fix DAP2 DIN/DOUT pin assignment

[PATCH v8 0/9] gpio: realtek: Add support for Realtek DHC RTD1625
 2026-07-27 14:07 UTC  (7+ messages)
` [PATCH v8 9/9] gpio: realtek: Add driver for Realtek DHC RTD1625 SoC

[PATCH 0/6] iio: adc: Add AD7768/AD7768-4 ADC driver support
 2026-07-27 14:01 UTC  (10+ messages)
` [PATCH 1/6] dt-bindings: iio: adc: Add AD7768

[PATCH 00/36] treewide: remove conditional returns with no effect
 2026-07-27 12:59 UTC  (7+ messages)

[PATCH v2] gpio: pca953x: fix cache_only and IRQ state on restore_context() failure
 2026-07-27 12:58 UTC  (2+ messages)

[PATCH v7 00/34] pinctrl: airoha: split on shared and SoC drivers, add more SoCs
 2026-07-27 12:48 UTC  (40+ messages)
` [PATCH v7 01/34] dt-bindings: pinctrl: airoha: en7581: fix misprint in i2s function name
` [PATCH v7 02/34] dt-bindings: pinctrl: airoha: en7581: fix pwm pin-groups
` [PATCH v7 04/34] pinctrl: airoha: an7581: fix misprint in bitfield name
` [PATCH v7 07/34] dt-bindings: pinctrl: airoha: an7583: remove i2c pin function
` [PATCH v7 12/34] pinctrl: airoha: add missed get_direction() function for gpio_chip
` [PATCH v7 13/34] pinctrl: airoha: add set_direction() helper "
` [PATCH v7 14/34] pinctrl: airoha: fix potential kenel panic in IRQ handling code
` [PATCH v7 15/34] pinctrl: airoha: fix IRQ mask/unmask code
` [PATCH v7 16/34] pinctrl: airoha: add missed IRQ resource helpers
` [PATCH v7 17/34] pinctrl: airoha: fix edge-triggered interrupts handling
` [PATCH v7 18/34] pinctrl: airoha: remove not needed irq_type[] array
` [PATCH v7 20/34] pinctrl: airoha: split driver on shared code and SoC specific drivers
` [PATCH v7 23/34] pinctrl: airoha: an7583: rename registers to match its an7583 names
` [PATCH v7 27/34] dt-bindings: pinctrl: airoha: an7583: add pon_alt pin group
` [PATCH v7 29/34] dt-bindings: pinctrl: airoha: an7583: add olt function/group
` [PATCH v7 30/34] pinctrl: airoha: add support of en7523 SoC
` [PATCH v7 31/34] pinctrl: airoha: try to find chip scu node by phandle first
` [PATCH v7 32/34] dt-bindings: pinctrl: airoha: add support of en7523 pin controller
` [PATCH v7 33/34] pinctrl: airoha: add support of an7563 SoC
` [PATCH v7 34/34] dt-bindings: pinctrl: airoha: add support of an7563 pin controller

[PATCH] pinctrl: fix PINCTRL_GENERIC_MUX not always being selectable
 2026-07-27 12:20 UTC 

[PATCH v2] gpio: gpio-by-pinctrl: Apply initial value in direction output wrapper
 2026-07-27 11:14 UTC  (2+ messages)

[PATCH v1 0/7] gpiolib: kill gpio_request_one()
 2026-07-27  9:53 UTC  (5+ messages)
` [PATCH v1 2/7] media: em28xx: Split em28xx_pctv_290e_set_lna_gpio() helper
` [PATCH v1 3/7] media: em28xx: Open code gpio_request_one()

[GIT PULL] Pin control fixes for v7.2
 2026-07-27  9:25 UTC 

[GIT PULL] gpio: legacy interface cleanups for 7.3
 2026-07-27  7:57 UTC  (2+ messages)

[PATCH] gpio: pca953x: restore cache_only state on resume failure
 2026-07-27  7:53 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox