Linux GPIO subsystem development
 help / color / mirror / Atom feed
 messages from 2026-08-03 13:05:21 to 2026-08-05 19:32:29 UTC [more...]

[PATCH v3 0/5] rtc: s35390a: Allow use of output pin for interrupt signal 1 for wakealarm
 2026-08-05 19:32 UTC  (2+ messages)
` [PATCH v3 1/5] dt-bindings: rtc: Add pinctrl for S35390A

[PATCH v10 00/36] pinctrl: airoha: split on shared and SoC drivers, add more SoCs
 2026-08-05 12:34 UTC  (37+ messages)
` [PATCH v10 01/36] dt-bindings: pinctrl: airoha: en7581: fix misprint in i2s function name
` [PATCH v10 02/36] dt-bindings: pinctrl: airoha: an7583: fix device tree binding schema
` [PATCH v10 03/36] pinctrl: airoha: fix mdio bitfield names
` [PATCH v10 04/36] pinctrl: airoha: an7581: fix pinconf of i2c_scl/i2c_sda pins
` [PATCH v10 05/36] pinctrl: airoha: an7583: fix I2C0_SDA_PD register bit order
` [PATCH v10 06/36] pinctrl: airoha: an7581: fix mux/conf of pcie_reset pins
` [PATCH v10 07/36] dt-bindings: pinctrl: airoha: en7581: allow configuration of pcie_reset pins as gpio or pwm
` [PATCH v10 08/36] pinctrl: airoha: an7583: fix muxing of non-gpio default pins
` [PATCH v10 09/36] dt-bindings: pinctrl: airoha: an7583: allow configuration of non-gpio default pins as gpio and pwm
` [PATCH v10 10/36] pinctrl: airoha: fix I2C1 pin mux config for AN7581
` [PATCH v10 11/36] pinctrl: airoha: fix I2C pin mux config for AN7583
` [PATCH v10 12/36] pinctrl: airoha: fix AN7583 MDIO pin mux config
` [PATCH v10 13/36] pinctrl: airoha: an7583: fix spi group pins
` [PATCH v10 14/36] pinctrl: airoha: add missed get_direction() function for gpio_chip
` [PATCH v10 15/36] pinctrl: airoha: add set_direction() helper "
` [PATCH v10 16/36] pinctrl: airoha: minor improvements
` [PATCH v10 17/36] pinctrl: airoha: fix getting gpiochip/pinctrl pointers in the IRQ handling code
` [PATCH v10 18/36] pinctrl: airoha: add missed IRQ resource helpers
` [PATCH v10 19/36] pinctrl: airoha: fix IRQ mask/unmask code
` [PATCH v10 20/36] pinctrl: airoha: fix edge-triggered interrupts handling
` [PATCH v10 21/36] pinctrl: airoha: remove not needed irq_type[] array
` [PATCH v10 22/36] pinctrl: airoha: statically allocate gpio regs structure
` [PATCH v10 23/36] pinctrl: airoha: move common definitions to the separate header
` [PATCH v10 24/36] pinctrl: airoha: split driver on shared code and SoC specific drivers
` [PATCH v10 25/36] pinctrl: airoha: an7581: remove en7581 prefix from variable names
` [PATCH v10 26/36] pinctrl: airoha: an7583: remove an7583 prefix from variable names and definitions
` [PATCH v10 27/36] pinctrl: airoha: an7583: rename registers to match its an7583 names
` [PATCH v10 28/36] pinctrl: airoha: an7583: add support for npu_uart pinmux
` [PATCH v10 29/36] pinctrl: airoha: an7583: add support for pon_alt pinmux
` [PATCH v10 30/36] pinctrl: airoha: an7583: add support for olt pinmux
` [PATCH v10 31/36] dt-bindings: pinctrl: airoha: an7583: add missed features
` [PATCH v10 32/36] pinctrl: airoha: add support of en7523 SoC
` [PATCH v10 33/36] pinctrl: airoha: try to find chip scu node by phandle first
` [PATCH v10 34/36] dt-bindings: pinctrl: airoha: add support of en7523 pin controller
` [PATCH v10 35/36] pinctrl: airoha: add support of an7563 SoC
` [PATCH v10 36/36] dt-bindings: pinctrl: airoha: add support of an7563 pin controller

[PATCH] pinctrl: airoha: fix wrong value for PCIe reset pin
 2026-08-05 12:13 UTC  (3+ messages)

[linusw-pinctrl:for-next] BUILD SUCCESS 80da2ff35d5ae8450300e82d6b81f916dca04bb5
 2026-08-05 12:03 UTC 

[linusw-pinctrl:fixes] BUILD SUCCESS 696ff859f5f93a7cedab2a2afa20bd1635918fcf
 2026-08-05 12:02 UTC 

[linusw-pinctrl:devel] BUILD SUCCESS 41c59b22370d2e1785e0e80f8ad7bd9946a1ca82
 2026-08-05 12:01 UTC 

[PATCH v2 0/2] gpio: add support for Axiado SGPIO controller
 2026-08-05 10:29 UTC  (7+ messages)
` [PATCH v2 1/2] dt-bindings: gpio: Add "
` [PATCH v2 2/2] gpio: axiado: add SGPIO controller support

[RESEND V2 1/2] dt-bindings: pinctrl: tegra264: fix DAP2 DIN/DOUT pin names
 2026-08-05  7:45 UTC  (4+ messages)

[PATCH v3] driver: fpga: xilinx-selectmap: add csi and rdwr support
 2026-08-05  5:56 UTC  (3+ messages)

[PATCH 0/2] pinctrl: sx150x: IRQ handling updates
 2026-08-05  5:55 UTC  (3+ messages)
` [PATCH 1/2] pinctrl: sx150x: Return IRQ_NONE if no pending irq
` [PATCH 2/2] pinctrl: sx150x: get parent IRQ trigger type from firmware

[PATCH] pinctrl: stm32: fix the unit of the hwspinlock timeout
 2026-08-05  3:28 UTC 

[PATCH v4 00/21] Add basic pinctrl drivers for JHB100 SoC
 2026-08-04 20:30 UTC  (10+ messages)
` [PATCH v4 01/21] dt-bindings: pincfg-node: Add property 'input-debounce-ns'
` [PATCH v4 04/21] pinctrl: starfive: Add StarFive JHB100 sys0 controller driver

[PATCH RFC v6 0/7] mfd: ls2kbmc: multiple fixes for this driver
 2026-08-04 19:34 UTC  (9+ messages)
` [PATCH RFC v6 1/7] mfd: ls2kbmc: Make a copy when parsing mode string
` [PATCH RFC v6 2/7] mfd: ls2kbmc: Sanity check for the connected pci port
` [PATCH RFC v6 3/7] mfd: ls2kbmc: Redraw using exported functions
` [PATCH RFC v6 4/7] mfd: ls2kbmc: Cancel the work queue on removal
` [PATCH RFC v6 5/7] ipmi: ls2k: adjust dependency to its mfd driver
` [PATCH RFC v6 6/7] mfd: ls2kbmc: Able to be compiled as a module
` [PATCH RFC v6 7/7] mfd: ls2kbmc: Capture the reset event of BMC through GPIO

[PATCH RFC v3 0/7] mfd: ls2kbmc: multiple fixes for this driver
 2026-08-04 19:08 UTC  (9+ messages)

[PATCH v9 00/36] pinctrl: airoha: split on shared and SoC drivers, add more SoCs
 2026-08-04 18:19 UTC  (39+ messages)
` [PATCH v9 01/36] dt-bindings: pinctrl: airoha: en7581: fix misprint in i2s function name
` [PATCH v9 02/36] dt-bindings: pinctrl: airoha: an7583: fix device tree binding schema
` [PATCH v9 03/36] pinctrl: airoha: fix mdio bitfield names
` [PATCH v9 04/36] pinctrl: airoha: an7581: fix pinconf of i2c_scl/i2c_sda pins
` [PATCH v9 05/36] pinctrl: airoha: an7583: fix I2C0_SDA_PD register bit order
` [PATCH v9 06/36] pinctrl: airoha: an7581: fix mux/conf of pcie_reset pins
` [PATCH v9 07/36] dt-bindings: pinctrl: airoha: en7581: allow configuration of pcie_reset pins as gpio or pwm
` [PATCH v9 08/36] pinctrl: airoha: an7583: fix muxing of non-gpio default pins
` [PATCH v9 09/36] dt-bindings: pinctrl: airoha: an7583: allow configuration of non-gpio default pins as gpio and pwm
` [PATCH v9 10/36] pinctrl: airoha: fix I2C1 pin mux config for AN7581
` [PATCH v9 11/36] pinctrl: airoha: fix I2C pin mux config for AN7583
` [PATCH v9 12/36] pinctrl: airoha: fix AN7583 MDIO pin mux config
` [PATCH v9 13/36] pinctrl: airoha: an7583: fix spi group pins
` [PATCH v9 14/36] pinctrl: airoha: add missed get_direction() function for gpio_chip
` [PATCH v9 15/36] pinctrl: airoha: add set_direction() helper "
` [PATCH v9 16/36] pinctrl: airoha: minor improvements
` [PATCH v9 17/36] pinctrl: airoha: fix getting gpiochip/pinctrl pointers in the IRQ handling code
` [PATCH v9 18/36] pinctrl: airoha: add missed IRQ resource helpers
` [PATCH v9 19/36] pinctrl: airoha: fix IRQ mask/unmask code
` [PATCH v9 20/36] pinctrl: airoha: fix edge-triggered interrupts handling
` [PATCH v9 21/36] pinctrl: airoha: remove not needed irq_type[] array
` [PATCH v9 22/36] pinctrl: airoha: statically allocate gpio regs structure
` [PATCH v9 23/36] pinctrl: airoha: move common definitions to the separate header
` [PATCH v9 24/36] pinctrl: airoha: split driver on shared code and SoC specific drivers
` [PATCH v9 25/36] pinctrl: airoha: an7581: remove en7581 prefix from variable names
` [PATCH v9 26/36] pinctrl: airoha: an7583: remove an7583 prefix from variable names and definitions
` [PATCH v9 27/36] pinctrl: airoha: an7583: rename registers to match its an7583 names
` [PATCH v9 28/36] pinctrl: airoha: an7583: add support for npu_uart pinmux
` [PATCH v9 29/36] pinctrl: airoha: an7583: add support for pon_alt pinmux
` [PATCH v9 30/36] pinctrl: airoha: an7583: add support for olt pinmux
` [PATCH v9 31/36] dt-bindings: pinctrl: airoha: an7583: add missed features
` [PATCH v9 32/36] pinctrl: airoha: add support of en7523 SoC
` [PATCH v9 33/36] pinctrl: airoha: try to find chip scu node by phandle first
` [PATCH v9 34/36] dt-bindings: pinctrl: airoha: add support of en7523 pin controller
` [PATCH v9 35/36] pinctrl: airoha: add support of an7563 SoC
` [PATCH v9 36/36] dt-bindings: pinctrl: airoha: add support of an7563 pin controller

[PATCH v2 00/10] Support ROHM BD73800
 2026-08-04 16:56 UTC  (14+ messages)
` [PATCH v2 01/10] dt-bindings: mfd: common ROHM PMIC properties
` [PATCH v2 02/10] dt-bindings: rohm,bd*: Ref common ROHM bindings
` [PATCH v2 03/10] dt-bindings: regulator: ROHM BD73800 regulators
` [PATCH v2 04/10] dt-bindings: mfd: ROHM BD73800 PMIC
` [PATCH v2 05/10] mfd: Support for ROHM BD73800 PMIC core
` [PATCH v2 06/10] rtc: bd70528: Support RTC on ROHM BD73800
` [PATCH v2 07/10] regulator: bd71828: Support "
` [PATCH v2 08/10] clk: bd718x7: "
` [PATCH v2 09/10] gpio: bd73800: Support ROHM BD73800 PMIC GPIOs
` [PATCH v2 10/10] MAINTAINERS: Add ROHM BD73800 PMIC files

[PATCH] gpio: mvebu: convert to noirq suspend/resume to prevent interrupt storm on resume
 2026-08-04 15:15 UTC  (2+ messages)

[PATCH v8 00/35] pinctrl: airoha: split on shared and SoC drivers, add more SoCs
 2026-08-04 14:57 UTC  (5+ messages)
` [PATCH v8 30/35] dt-bindings: pinctrl: airoha: an7583: add olt function/group

[PATCH v5 0/6] Add Samsung Galaxy S4 support
 2026-08-04 14:24 UTC  (8+ messages)
` [PATCH v5 1/6] dt-bindings: arm: qcom: Add Samsung Galaxy S4
` [PATCH v5 2/6] pinctrl: qcom: Register functions before enabling pinctrl
` [PATCH v5 3/6] ARM: dts: qcom: apq8064: Fix USB controller clocks
` [PATCH v5 4/6] mfd: qcom-pm8xxx: register PM8921 USB ID extcon
` [PATCH v5 5/6] extcon: qcom-spmi-misc: match PM8xxx USB ID platform device
` [PATCH v5 6/6] ARM: dts: qcom: Add Samsung Galaxy S4

[PATCH] pinctrl: stm32: use a raw spinlock regmap to program the EXTI mux
 2026-08-04 14:14 UTC  (3+ messages)
` [PATCH v2] pinctrl: stm32: program the EXTI mux from .alloc instead of .activate
` [PATCH v3] "

[PATCH RFC v5 0/7] mfd: ls2kbmc: multiple fixes for this driver
 2026-08-04 13:56 UTC  (13+ messages)
` [PATCH RFC v5 1/7] mfd: ls2kbmc: Make a copy when parsing mode string
` [PATCH RFC v5 2/7] mfd: ls2kbmc: Sanity check for the connected pci port
` [PATCH RFC v5 3/7] mfd: ls2kbmc: Redraw using exported functions
` [PATCH RFC v5 4/7] mfd: ls2kbmc: Cancel the work queue on removal
` [PATCH RFC v5 5/7] ipmi: ls2k: Relax the dependency to its mfd driver
` [PATCH RFC v5 6/7] mfd: ls2kbmc: Able to be compiled as a module
` [PATCH RFC v5 7/7] mfd: ls2kbmc: Capture the reset event of BMC through GPIO

[PATCH] gpio: ml-ioh: use raw_spinlock_t for the register lock
 2026-08-04  9:59 UTC  (4+ messages)
  ` [PATCH] gpio: ml-ioh: share the register lock across channels

[PATCH v14 00/22] media: i2c: add Maxim GMSL2/3 serializer and deserializer drivers
 2026-08-04  8:50 UTC  (23+ messages)
` [PATCH v14 01/22] media: mc: Add INTERNAL pad flag
` [PATCH v14 02/22] dt-bindings: media: i2c: max96717: add support for I2C ATR
` [PATCH v14 03/22] dt-bindings: media: i2c: max96717: add support for pinctrl/pinconf
` [PATCH v14 04/22] dt-bindings: media: i2c: max96717: add support for MAX9295A
` [PATCH v14 05/22] dt-bindings: media: i2c: max96717: add support for MAX96793
` [PATCH v14 06/22] dt-bindings: media: i2c: max96712: use pattern properties for ports
` [PATCH v14 07/22] dt-bindings: media: i2c: max96712: add support for I2C ATR
` [PATCH v14 08/22] dt-bindings: media: i2c: max96712: add support for POC supplies
` [PATCH v14 09/22] dt-bindings: media: i2c: max96712: add support for MAX96724F/R
` [PATCH v14 10/22] dt-bindings: media: i2c: max96712: add control-channel-port property
` [PATCH v14 11/22] dt-bindings: media: i2c: max96714: add support for MAX96714R
` [PATCH v14 12/22] dt-bindings: media: i2c: add MAX9296A, MAX96716A, MAX96792A
` [PATCH v14 13/22] media: i2c: add Maxim GMSL2/3 serializer and deserializer framework
` [PATCH v14 14/22] media: i2c: add Maxim GMSL2/3 serializer framework
` [PATCH v14 15/22] media: i2c: add Maxim GMSL2/3 deserializer framework
` [PATCH v14 16/22] media: i2c: maxim-serdes: add MAX96717 driver
` [PATCH v14 17/22] media: i2c: maxim-serdes: add MAX96724 driver
` [PATCH v14 18/22] media: i2c: maxim-serdes: add MAX9296A driver
` [PATCH v14 19/22] arm64: defconfig: disable deprecated MAX96712 driver
` [PATCH v14 20/22] staging: media: remove "
` [PATCH v14 21/22] media: i2c: remove MAX96717 driver
` [PATCH v14 22/22] media: i2c: remove MAX96714 driver

[PATCH v2 0/9] Initial Apple Silicon M4 device trees and dt-bindings
 2026-08-04  7:50 UTC  (3+ messages)
` [PATCH v2 5/9] dt-bindings: pinctrl: apple,pinctrl: Add t8132 compatible

[PATCH] pinctrl: sx150x: allow build when I2C is a module
 2026-08-04  7:44 UTC  (2+ messages)

[PATCH v3 0/4] pinctrl: Add support for the Rockchip RV1106
 2026-08-04  6:51 UTC  (3+ messages)
` [PATCH v3 2/4] dt-bindings: gpio: rockchip,gpio-bank: Add rockchip,grf property

[PATCH] pinctrl: Use IRQ trigger mask helpers
 2026-08-04  4:21 UTC  (2+ messages)

[PATCHv2 0/8] gpio: move ppc4xx driver to drivers/gpio and modernize
 2026-08-03 22:35 UTC  (9+ messages)
` [PATCHv2 1/8] gpio: move ppc4xx gpio driver from arch/powerpc to drivers/gpio
` [PATCHv2 2/8] gpio: ppc44x: update all 4xx to 44x
` [PATCHv2 3/8] gpio: ppc44x: Use module platform driver helper for GPIO
` [PATCHv2 4/8] gpio: ppc44x: Use platform resource helper for GPIO MMIO
` [PATCHv2 5/8] gpio: ppc44x: Convert GPIO to generic MMIO
` [PATCHv2 6/8] gpio: ppc44x: drop PPC-specific IO helpers
` [PATCHv2 7/8] gpio: ppc44x: fix undefined behavior in GPIO_MASK2 macro
` [PATCHv2 8/8] gpio: ppc44x: use dev_name() for chip label

[PATCH] dt-bindings: Correct white-space style
 2026-08-03 22:29 UTC  (3+ messages)

[PATCH v5 1/2] dt-bindings: pinctrl: microchip,pic32mzda-pinctrl: Convert to DT schema
 2026-08-03 22:24 UTC  (2+ messages)

[PATCH v2] dt-bindings: pinctrl: ti,dra7-iodelay: Convert to DT schema
 2026-08-03 21:01 UTC  (2+ messages)

[PATCH 0/2] pinctrl: rockchip: Two fixes for latent driver bugs
 2026-08-03 14:10 UTC  (3+ messages)
` [PATCH 1/2] pinctrl: rockchip: Reset the pin count when recalculating SoC data
` [PATCH 2/2] pinctrl: rockchip: Restrict the RV1103B 2-bit drive type to bank 2

[PATCH] soc: fsl: qe: implement get_direction()
 2026-08-03 13:05 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox