From: "Edgecombe, Rick P" <rick.p.edgecombe@intel.com>
To: "keescook@chromium.org" <keescook@chromium.org>,
"Weiny, Ira" <ira.weiny@intel.com>
Cc: "hpa@zytor.com" <hpa@zytor.com>,
"Williams, Dan J" <dan.j.williams@intel.com>,
"Shankar, Ravi V" <ravi.v.shankar@intel.com>,
"Yu, Fenghua" <fenghua.yu@intel.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"dave.hansen@linux.intel.com" <dave.hansen@linux.intel.com>,
"linux-hardening@vger.kernel.org"
<linux-hardening@vger.kernel.org>
Subject: Re: [PATCH V10 14/44] mm/pkeys: Introduce pks_set_readwrite()
Date: Tue, 10 May 2022 22:26:43 +0000 [thread overview]
Message-ID: <76ee55622592d531c82cb42b96d4bb27deb26287.camel@intel.com> (raw)
In-Reply-To: <202205101504.5B5C693F7C@keescook>
On Tue, 2022-05-10 at 15:08 -0700, Kees Cook wrote:
> > Kees would you prefer pks_set_nowrite() as a name?
>
> I think nowrite is the better name (in the sense that "read-only" can
> sometimes imply non-executable).
I agree with this here. Read-only is a bad name for not writable.
Especially if you try talking about "execute-only" memory which is
"read-only" (not writable) and "not readable". Very confusing.
>
> > >
> > > With these changes it should be possible to protect the kernel's
> > > page
> > > table entries from "stray" writes. :)
> >
> > Yes, Rick has done some great work in that area.
>
> Oh! I would _love_ to see this series. I was trying to scope the work
> yesterday but gave up after I couldn't figure out the qemu PKS trick.
> :)
I would still like to get back to it, but other work has bumped it for
now.
v1:
https://lore.kernel.org/lkml/20210505003032.489164-1-rick.p.edgecombe@intel.com/#r
v2:
https://lore.kernel.org/lkml/20210830235927.6443-1-rick.p.edgecombe@intel.com/#r
Mostly it fit together pretty easily, but there was memory overhead
required to protect the page tables that map the direct map fully
(unless a better solution can be found).
next prev parent reply other threads:[~2022-05-10 22:26 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20220419170649.1022246-1-ira.weiny@intel.com>
[not found] ` <20220419170649.1022246-15-ira.weiny@intel.com>
2022-05-09 21:38 ` [PATCH V10 14/44] mm/pkeys: Introduce pks_set_readwrite() Kees Cook
2022-05-10 21:33 ` Ira Weiny
2022-05-10 22:08 ` Kees Cook
2022-05-10 22:26 ` Edgecombe, Rick P [this message]
2022-05-11 3:15 ` Kees Cook
2022-05-11 17:59 ` Ira Weiny
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=76ee55622592d531c82cb42b96d4bb27deb26287.camel@intel.com \
--to=rick.p.edgecombe@intel.com \
--cc=dan.j.williams@intel.com \
--cc=dave.hansen@linux.intel.com \
--cc=fenghua.yu@intel.com \
--cc=hpa@zytor.com \
--cc=ira.weiny@intel.com \
--cc=keescook@chromium.org \
--cc=linux-hardening@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=ravi.v.shankar@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox