From: Gwan-gyeong Mun <gwan-gyeong.mun@intel.com>
To: Kees Cook <keescook@chromium.org>
Cc: Andrzej Hajda <andrzej.hajda@intel.com>,
Andi Shyti <andi.shyti@linux.intel.com>,
<thomas.hellstrom@linux.intel.com>, <jani.nikula@intel.com>,
<intel-gfx@lists.freedesktop.org>, <linux-kernel@vger.kernel.org>,
<dri-devel@lists.freedesktop.org>, <chris@chris-wilson.co.uk>,
<airlied@linux.ie>, <linux-hardening@vger.kernel.org>,
<matthew.auld@intel.com>, <mchehab@kernel.org>,
<nirmoy.das@intel.com>,
Mauro Carvalho Chehab <mauro.chehab@linux.intel.com>
Subject: Re: [PATCH v7 1/8] overflow: Move and add few utility macros into overflow
Date: Tue, 23 Aug 2022 11:30:54 +0900 [thread overview]
Message-ID: <9c9d4c86-d77c-adc0-5dc0-d1821a6a3723@intel.com> (raw)
In-Reply-To: <202208221301.366A33DACA@keescook>
On 8/23/22 5:12 AM, Kees Cook wrote:
> On Tue, Aug 23, 2022 at 04:32:10AM +0900, Gwan-gyeong Mun wrote:
>> On 8/22/22 11:05 PM, Andrzej Hajda wrote:
>>> On 18.08.2022 02:12, Kees Cook wrote:
>>>> On Thu, Aug 18, 2022 at 01:07:29AM +0200, Andi Shyti wrote:
>>>>> [...]
>>>>>> +#define safe_conversion(ptr, value) ({ \
>>>>>> + typeof(value) __v = (value); \
>>>>>> + typeof(ptr) __ptr = (ptr); \
>>>>>> + overflows_type(__v, *__ptr) ? 0 : ((*__ptr =
>>>>>> (typeof(*__ptr))__v), 1); \
>>>>>> +})
>>>>
>>>> I try to avoid "safe" as an adjective for interface names, since it
>>>> doesn't really answer "safe from what?" This looks more like "assign, but
>>>> zero when out of bounds". And it can be built from existing macros here:
>>>>
>>>> if (check_add_overflow(0, value, ptr))
>>>> *ptr = 0;
>>>>
>>>> I actually want to push back on this a bit, because there can still be
>>>> logic bugs built around this kind of primitive. Shouldn't out-of-bounds
>>>> assignments be seen as a direct failure? I would think this would be
>>>> sufficient:
>>>>
>>>> #define check_assign(value, ptr) check_add_overflow(0, value, ptr)
>>>>
>>>> And callers would do:
>>>>
>>>> if (check_assign(value, &var))
>>>> return -EINVAL;
>>>>
>> Yes, I also like check_assign() you suggested more than safe_conversion.
>> As shown below, it would be more readable to return true when assign
>> succeeds and false when it fails. What do you think?
>
> No, this inverts the style of all the other check_*() functions, so it
> should remain "non-zero is failure".
>
Hi Kees,
Yes, I will not invert this part as you commented.
>> /**
>> * check_assign - perform a type conversion (cast) of an source value into
>> * a new variable, checking that the destination is large enough to hold the
>> * source value.
>> *
>> * @value: Source value
>> * @ptr: Destination pointer address, If the pointer type is not used, a
>> warning message is output during build.
>> *
>> * Returns:
>> * If the value would overflow the destination, it returns false. If not
>> return true.
>> */
>> #define check_assign(value, ptr) __must_check_overflow(({ \
>> typecheck_pointer(ptr); \
>> !__builtin_add_overflow(0, value, ptr); \
>> }))
>
> Please don't use the __builtin*s, instead stick to the check_* family,
> as they correctly wrap the builtins and perform type checking, etc. As
> mentioned, check_assign() should just be:
>
> #define check_assign(value, ptr) check_add_overflow(0, value, ptr)
>
> I don't think any of the other code is needed? What's the use-case for
> the other stuff? i.e. Why does anything need overflows_type()?
>
And, the reason for using the __builtin_add_overflow() built-in function
directly instead of using the check_add_overflow() function is ,
#define check_add_overflow(a, b, d) __must_check_overflow(({ \
typeof(a) __a = (a); \
typeof(b) __b = (b); \
typeof(d) __d = (d); \
(void) (&__a == &__b); \
(void) (&__a == __d); \
__builtin_add_overflow(__a, __b, __d); \
}))
In this part of the implementation of check_add_overflow()
(void) (&__a == &__b);
(void) (&__a == __d);
When comparing the pointer types of a, b, and d, if the pointer types of
source and ptr in check_assign() are different, a warning may occur when
building, I used the __builtin_add_overflow() built-in function directly.
Br,
G.G.
> -Kees
>
prev parent reply other threads:[~2022-08-23 2:31 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20220816093525.184940-1-gwan-gyeong.mun@intel.com>
[not found] ` <20220816093525.184940-2-gwan-gyeong.mun@intel.com>
2022-08-17 23:07 ` [PATCH v7 1/8] overflow: Move and add few utility macros into overflow Andi Shyti
2022-08-18 0:12 ` Kees Cook
2022-08-22 11:02 ` Jani Nikula
2022-08-22 14:05 ` Andrzej Hajda
2022-08-22 14:26 ` [Intel-gfx] " Andrzej Hajda
2022-08-22 19:32 ` Gwan-gyeong Mun
2022-08-22 20:12 ` Kees Cook
2022-08-23 2:30 ` Gwan-gyeong Mun [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=9c9d4c86-d77c-adc0-5dc0-d1821a6a3723@intel.com \
--to=gwan-gyeong.mun@intel.com \
--cc=airlied@linux.ie \
--cc=andi.shyti@linux.intel.com \
--cc=andrzej.hajda@intel.com \
--cc=chris@chris-wilson.co.uk \
--cc=dri-devel@lists.freedesktop.org \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jani.nikula@intel.com \
--cc=keescook@chromium.org \
--cc=linux-hardening@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=matthew.auld@intel.com \
--cc=mauro.chehab@linux.intel.com \
--cc=mchehab@kernel.org \
--cc=nirmoy.das@intel.com \
--cc=thomas.hellstrom@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox