messages from 2021-10-20 17:36:02 to 2021-11-02 18:21:30 UTC [more...]
[PATCH v5 00/15] x86: Add support for Clang CFI
2021-11-02 18:18 UTC (53+ messages)
` [PATCH] static_call,x86: Robustify trampoline patching
[PATCH] [RFC/RFT] AARCH64: Add gcc Shadow Call Stack support
2021-11-02 16:16 UTC (4+ messages)
[PATCH] [RFC][PR102768] aarch64: Add compiler support for Shadow Call Stack
2021-11-02 16:24 UTC (3+ messages)
[PATCH][next] powerpc/vas: Fix potential NULL pointer dereference
2021-11-02 10:11 UTC (7+ messages)
[PATCH] afs: Prefer struct_size over open coded arithmetic
2021-11-02 9:44 UTC (4+ messages)
[GIT PULL] overflow updates for v5.16-rc1
2021-11-02 0:51 UTC (2+ messages)
[GIT PULL] Various hardening fixes and cleanups for 5.16-rc1
2021-11-02 0:51 UTC (2+ messages)
[GIT PULL] fallthrough fixes for Clang for 5.16-rc1
2021-11-02 0:51 UTC (2+ messages)
[GIT PULL] hardening updates for v5.16-rc1
2021-11-02 0:50 UTC (2+ messages)
selftests: seccomp_bpf failure on 5.15
2021-11-01 22:28 UTC (7+ messages)
` [PATCH] signal: Add SA_IMMUTABLE to ensure forced siganls do not get changed
[PATCH] drm/i915: Prefer struct_size over open coded arithmetic
2021-10-30 7:51 UTC (9+ messages)
[PATCH] x86/unwind/orc: Handle kretprobes_trampoline
2021-10-29 18:19 UTC (7+ messages)
[PATCH v3][next] virt: acrn: Prefer array_size and struct_size over open coded arithmetic
2021-10-29 17:27 UTC
[PATCH] nvmet: prefer flex_array_size and struct_size over open coded arithmetic
2021-10-29 17:04 UTC (6+ messages)
[PATCH v2][next] sysctl: Avoid open coded arithmetic in memory allocator functions
2021-10-29 16:57 UTC (7+ messages)
[PATCH 1/2] kasan: test: use underlying string helpers
2021-10-28 20:42 UTC (5+ messages)
[PATCH][next] nouveau/svm: Use kvcalloc() instead of kvzalloc()
2021-10-28 17:38 UTC (4+ messages)
[PATCH v4 0/1] implement TLS register based stack canary for ARM
2021-10-28 11:27 UTC (2+ messages)
` [PATCH v4 1/1] [ARM] Add support for TLS register based stack protector canary access
[PATCH] gcc-plugins: use swap() to make code cleaner
2021-10-28 0:35 UTC
[PATCH v2 0/2] Introduce the pkill_on_warn parameter
2021-10-27 23:32 UTC (3+ messages)
` [PATCH v2 1/2] bug: do refactoring allowing to add a warning handling action
` [PATCH v2 2/2] sysctl: introduce kernel.pkill_on_warn
[PATCH][next] iommu/dma: Use kvcalloc() instead of kvzalloc()
2021-10-27 8:05 UTC (4+ messages)
[PATCH 0/4] x86: Various clean-ups in support of FGKASLR
2021-10-27 6:57 UTC (3+ messages)
[PATCH] ARM: stackprotector: prefer compiler for TLS based per-task protector
2021-10-26 17:17 UTC (3+ messages)
[PATCH v3 0/1] implement TLS register based stack canary for ARM
2021-10-26 17:13 UTC (3+ messages)
` [PATCH v3 1/1] [ARM] Add support for TLS register based stack protector canary access
[PATCH v3] docs: deprecated.rst: Clarify open-coded arithmetic with literals
2021-10-26 17:05 UTC (4+ messages)
[PATCH v2] fortify: Avoid shadowing previous locals
2021-10-25 22:42 UTC (2+ messages)
[PATCH v2][next] virt: acrn: Prefer array_size and struct_size over open coded arithmetic
2021-10-25 22:22 UTC (2+ messages)
[PATCH] fortify: Avoid shadowing previous locals
2021-10-25 20:49 UTC (4+ messages)
[PATCH] dmaengine: milbeaut-hdmac: Prefer kcalloc over open coded arithmetic
2021-10-25 6:42 UTC (2+ messages)
[PATCH] nvmet: prefer struct_size over open coded arithmetic
2021-10-23 20:14 UTC (4+ messages)
[PATCH] sysctl: Avoid open coded arithmetic in memory allocator functions
2021-10-23 10:31 UTC (3+ messages)
[PATCH 0/2] lkdtm/bugs: Check that a per-task stack canary exists
2021-10-22 22:38 UTC (3+ messages)
` [PATCH 1/2] selftests/lkdtm: Add way to repeat a test
` [PATCH 2/2] lkdtm/bugs: Check that a per-task stack canary exists
[PATCH] Introduce the pkill_on_warn boot parameter
2021-10-22 17:30 UTC (10+ messages)
[RFC PATCH v2 0/1] implement TLS register based stack canary for ARM
2021-10-22 12:42 UTC (3+ messages)
` [RFC PATCH v2 1/1] [ARM] Add support for TLS register based stack protector canary access
[PATCH] mm/secretmem: Avoid letting secretmem_users drop to zero
2021-10-22 7:09 UTC (7+ messages)
[PATCH] selftests: proc: Make sure wchan works when it exists
2021-10-22 3:35 UTC (8+ messages)
[PATCH][net-next] netfilter: ebtables: use array_size() helper in copy_{from,to}_user()
2021-10-21 18:16 UTC (3+ messages)
[PATCH][next] ice: use devm_kcalloc() instead of devm_kzalloc()
2021-10-21 17:35 UTC (3+ messages)
[RFC PATCH 0/1] implement TLS register based stack canary for ARM
2021-10-21 16:46 UTC (4+ messages)
` [RFC PATCH 1/1] [ARM] Add support for TLS register based stack protector canary access
An analysis of current and potential security mitigations based on a TIOCSPGRP exploit
2021-10-21 16:07 UTC (2+ messages)
[PATCH V1] gcc-plugins: remove duplicate include in gcc-common.h
2021-10-21 15:13 UTC (2+ messages)
[PATCH] [PATCH V5]ARM64: SCS: Add gcc plugin to support Shadow Call Stack
2021-10-21 14:49 UTC (3+ messages)
[PATCH] compiler-gcc.h: Define __SANITIZE_ADDRESS__ under hwaddress sanitizer
2021-10-21 13:50 UTC (8+ messages)
[PATCH 0/2] gcc-plugins: Explicitly document purpose and deprecation schedule
2021-10-21 10:28 UTC (13+ messages)
` [PATCH 1/2] "
` [PATCH 2/2] gcc-plugins: Remove cyc_complexity
[PATCH AUTOSEL 4.19 01/10] gcc-plugins/structleak: add makefile var for disabling structleak
2021-10-21 0:22 UTC
[PATCH AUTOSEL 5.4 01/11] gcc-plugins/structleak: add makefile var for disabling structleak
2021-10-21 0:22 UTC
[PATCH AUTOSEL 5.10 01/14] gcc-plugins/structleak: add makefile var for disabling structleak
2021-10-21 0:21 UTC
[PATCH AUTOSEL 5.14 03/26] gcc-plugins/structleak: add makefile var for disabling structleak
2021-10-21 0:20 UTC
[PATCH] dmaengine: pxa_dma: Prefer struct_size over open coded arithmetic
2021-10-20 23:32 UTC (3+ messages)
[PATCH] KVM: PPC: Replace zero-length array with flexible array member
2021-10-20 23:28 UTC (3+ messages)
[PATCH] aio: Prefer struct_size over open coded arithmetic
2021-10-20 23:23 UTC (3+ messages)
[PATCH v2] writeback: prefer struct_size over open coded arithmetic
2021-10-20 23:19 UTC (3+ messages)
patchwork triage process
2021-10-20 22:26 UTC
[PATCH] kasan: test: Consolidate workarounds for unwanted __alloc_size() protection
2021-10-20 21:17 UTC (3+ messages)
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox