Linux Hardening
 help / color / mirror / Atom feed
 messages from 2024-07-01 19:13:05 to 2024-07-12 09:00:21 UTC [more...]

[PATCH] x86/syscall: Avoid memcpy() for ia32 syscall_get_arguments()
 2024-07-12  9:00 UTC  (8+ messages)

[PATCH v2 0/2] efi: Replace efi_memory_attributes_table_t 0-sized array with flexible array
 2024-07-12  8:08 UTC  (4+ messages)
` [PATCH v2 1/2] efi: Rename efi_early_memdesc_ptr() to efi_memdesc_ptr()
` [PATCH v2 2/2] efi: Replace efi_memory_attributes_table_t 0-sized array with flexible array

[PATCH v4 00/11] Add per-core RAPL energy counter support for AMD CPUs
 2024-07-12  6:15 UTC  (24+ messages)
` [PATCH v4 01/11] x86/topology: Introduce topology_logical_core_id()
` [PATCH v4 02/11] perf/x86/rapl: Fix the energy-pkg event for AMD CPUs
` [PATCH v4 03/11] perf/x86/rapl: Rename rapl_pmu variables
` [PATCH v4 04/11] perf/x86/rapl: Make rapl_model struct global
` [PATCH v4 05/11] perf/x86/rapl: Move cpumask variable to rapl_pmus struct
` [PATCH v4 06/11] perf/x86/rapl: Add wrapper for online/offline functions
` [PATCH v4 07/11] perf/x86/rapl: Add an argument to the cleanup and init functions
` [PATCH v4 08/11] perf/x86/rapl: Modify the generic variable names to *_pkg*
` [PATCH v4 09/11] perf/x86/rapl: Remove the global variable rapl_msrs
` [PATCH v4 10/11] perf/x86/rapl: Add per-core energy counter support for AMD CPUs
` [PATCH v4 11/11] perf/x86/rapl: Remove the unused function cpu_to_rapl_pmu

[PATCH net-next v3] netdevice: define and allocate &net_device _properly_
 2024-07-12  1:20 UTC  (5+ messages)

[PATCH 0/2] scsi: aacraid: struct sgmap: Replace 1-element arrays with flexible arrays
 2024-07-11 21:57 UTC  (3+ messages)
` [PATCH 1/2] scsi: aacraid: Rearrange order of struct aac_srb_unit
` [PATCH 2/2] scsi: aacraid: struct {user,}sgmap{,64,raw}: Replace 1-element arrays with flexible arrays

[PATCH v4] x86/traps: Enable UBSAN traps on x86
 2024-07-11 18:49 UTC  (5+ messages)

[PATCH] scsi: ipr: Replace 1-element arrays with flexible arrays
 2024-07-11 18:33 UTC  (2+ messages)

[PATCH 0/6] scsi: message: fusion: Replace 1-element arrays with flexible arrays
 2024-07-11 18:19 UTC  (13+ messages)
` [PATCH 1/6] scsi: message: fusion: struct _RAID_VOL0_SETTINGS: Replace 1-element array with flexible array
` [PATCH 2/6] scsi: message: fusion: struct _CONFIG_PAGE_SAS_IO_UNIT_0: "
` [PATCH 3/6] scsi: message: fusion: struct _CONFIG_PAGE_RAID_PHYS_DISK_1: "
` [PATCH 4/6] scsi: message: fusion: struct _CONFIG_PAGE_IOC_2: "
` [PATCH 5/6] scsi: message: fusion: struct _CONFIG_PAGE_IOC_3: "
` [PATCH 6/6] scsi: message: fusion: struct _CONFIG_PAGE_IOC_4: "

[PATCH] scsi: megaraid_sas: struct MR_HOST_DEVICE_LIST: Replace 1-element array with flexible array
 2024-07-11 18:11 UTC  (3+ messages)

[PATCH] mm/kmemleak: Replace strncpy() with strscpy()
 2024-07-11 18:08 UTC  (2+ messages)

[PATCH] scsi: aacraid: union aac_init: Replace 1-element array with flexible array
 2024-07-11 18:04 UTC  (2+ messages)

[PATCH] scsi: aacraid: struct aac_ciss_phys_luns_resp: Replace 1-element array with flexible array
 2024-07-11 18:01 UTC  (2+ messages)

[PATCH] net/ipv4: Replace tcp_ca_get_name_by_key()'s strncpy() with strscpy()
 2024-07-11 17:38 UTC  (2+ messages)

[PATCH] tsacct: Replace strncpy() with strscpy()
 2024-07-11 17:13 UTC 

[PATCH] kunit: executor: Simplify string allocation handling
 2024-07-11 16:54 UTC  (3+ messages)

[PATCH v2] kunit: executor: Simplify string allocation handling
 2024-07-11 16:54 UTC 

[PATCH] scsi: megaraid_sas: struct MR_LD_VF_MAP: Replace 1-element arrays with flexible arrays
 2024-07-11 16:27 UTC  (2+ messages)

[PATCH 0/4] scsi: mpi3mr: Replace 1-element arrays with flexible arrays
 2024-07-11 16:25 UTC  (9+ messages)
` [PATCH 1/4] scsi: mpi3mr: struct mpi3_event_data_sas_topology_change_list: Replace 1-element array with flexible array
` [PATCH 2/4] scsi: mpi3mr: struct mpi3_event_data_pcie_topology_change_list: "
` [PATCH 3/4] scsi: mpi3mr: struct mpi3_sas_io_unit_page0: "
` [PATCH 4/4] scsi: mpi3mr: struct mpi3_sas_io_unit_page1: "

[PATCH] fs/affs: struct slink_front: Replace 1-element array with flexible array
 2024-07-11 16:05 UTC  (4+ messages)

[PATCH net-next v2] netdevice: define and allocate &net_device _properly_
 2024-07-11 15:41 UTC  (12+ messages)

[PATCH 0/2] media: venus: hfi_cmds: struct hfi_session_release_buffer_pkt
 2024-07-11 12:19 UTC  (7+ messages)
` [PATCH 1/2] media: venus: hfi_cmds: struct hfi_session_release_buffer_pkt: Replace 1-element array with flexible array
` [PATCH 2/2] media: venus: hfi_cmds: struct hfi_session_release_buffer_pkt: Add __counted_by annotation

[PATCH] efi: Replace efi_memory_attributes_table_t 0-sized array with flexible array
 2024-07-11  6:05 UTC  (4+ messages)

[PATCH] ext4: Use memtostr_pad() for s_volume_name
 2024-07-11  2:35 UTC  (2+ messages)

[PATCH] fs/affs: struct affs_head: Replace 1-element array with flexible array
 2024-07-10 23:26 UTC  (2+ messages)

[PATCH] fs/affs: struct affs_data_head: Replace 1-element array with flexible array
 2024-07-10 23:25 UTC  (2+ messages)

[PATCH] virt: vbox: struct vmmdev_hgcm_pagelist: Replace 1-element array with flexible array
 2024-07-10 23:21 UTC  (2+ messages)

[PATCH AUTOSEL 6.1 07/29] efi: pstore: Return proper errors on UEFI failures
 2024-07-10  9:59 UTC  (2+ messages)

[RFC][PATCH 0/4] slab: Allow for type introspection during allocation
 2024-07-10  4:42 UTC  (16+ messages)
` [RFC][PATCH 1/4] compiler_types: Add integral/pointer type helper macros
` [RFC][PATCH 2/4] slab: Detect negative size values and saturate
` [RFC][PATCH 3/4] slab: Allow for type introspection during allocation
` [RFC][PATCH 4/4] pstore: Replace classic kmalloc code pattern with typed argument

[PATCH] usb: gadget: Use u16 types for 16-bit fields
 2024-07-09 15:49 UTC 

[PATCH 6.1 042/102] cdrom: rearrange last_media_change check to avoid unintentional overflow
 2024-07-09 11:10 UTC 

[PATCH 6.9 078/197] cdrom: rearrange last_media_change check to avoid unintentional overflow
 2024-07-09 11:08 UTC 

[PATCH 6.6 056/139] cdrom: rearrange last_media_change check to avoid unintentional overflow
 2024-07-09 11:09 UTC 

[PATCH] Revert "bpf: Take return from set_memory_rox() into account with bpf_jit_binary_lock_ro()" for linux-6.6.37
 2024-07-09 10:03 UTC  (9+ messages)

[PATCH v3 00/10] Add per-core RAPL energy counter support for AMD CPUs
 2024-07-08  1:56 UTC  (16+ messages)
` [PATCH v3 02/10] perf/x86/rapl: Fix the energy-pkg event "
` [PATCH v3 05/10] perf/x86/rapl: Move cpumask variable to rapl_pmus struct
` [PATCH v3 08/10] perf/x86/rapl: Modify the generic variable names to *_pkg*

[PATCH v6] arm64: dts: qcom: msm8939-longcheer-l9100: Add rear flash
 2024-07-07 20:31 UTC 

[PROBLEM linux-next] include/linux/fortify-string.h:580:25: error: call to ‘__read_overflow2_field’ declared with attribute warning: detected read beyond size of field
 2024-07-07 15:22 UTC  (2+ messages)

[PATCH] interconnect: qcom: Fix DT backwards compatibility for QoS
 2024-07-06 12:31 UTC  (3+ messages)

[PATCH v2 0/2] USB: serial: garmin_gps: annotate struct garmin_packet with __counted_by
 2024-07-05 12:04 UTC  (2+ messages)

moved Wiki to github!
 2024-07-04 23:36 UTC 

[PATCH] randomize_kstack: Remove non-functional per-arch entropy filtering
 2024-07-04 13:10 UTC  (2+ messages)

[PATCH v2] printk: Add a short description string to kmsg_dump()
 2024-07-03 16:40 UTC  (7+ messages)

[PATCH 5.15 283/356] bpf: Take return from set_memory_ro() into account with bpf_prog_lock_ro()
 2024-07-03 10:40 UTC 

[RFC PATCH v2] ptp: Add vDSO-style vmclock support
 2024-07-03  8:00 UTC  (4+ messages)

[PATCH] gcc-plugins: Remove duplicate included header file stringpool.h
 2024-07-02 21:17 UTC  (2+ messages)

[PATCH] randomize_kstack: Improve stack alignment codegen
 2024-07-02 21:16 UTC 

[PATCH v6 0/6] slab: Introduce dedicated bucket allocator
 2024-07-02 20:12 UTC  (7+ messages)
` [PATCH v6 4/6] mm/slab: Introduce kmem_buckets_create() and family
` [PATCH v6 6/6] mm/util: Use dedicated slab buckets for memdup_user()

[PATCH v5 0/4] Add support for QoS configuration
 2024-07-02 18:01 UTC  (5+ messages)
` [PATCH v5 2/4] interconnect: qcom: sc7280: enable "

[PATCH 6.1 036/128] bpf: Take return from set_memory_ro() into account with bpf_prog_lock_ro()
 2024-07-02 17:03 UTC 

[PATCH 6.6 051/163] bpf: Take return from set_memory_ro() into account with bpf_prog_lock_ro()
 2024-07-02 17:02 UTC  (2+ messages)
` [PATCH 6.6 052/163] bpf: Take return from set_memory_rox() into account with bpf_jit_binary_lock_ro()

[PATCH 6.9 065/222] bpf: Take return from set_memory_ro() into account with bpf_prog_lock_ro()
 2024-07-02 17:01 UTC  (2+ messages)
` [PATCH 6.9 066/222] bpf: Take return from set_memory_rox() into account with bpf_jit_binary_lock_ro()

[PATCH v2] kunit/usercopy: Disable testing on !CONFIG_MMU
 2024-07-02 16:18 UTC  (6+ messages)

[PATCH] kunit/usercopy: Add missing MODULE_DESCRIPTION()
 2024-07-02  4:09 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox