messages from 2026-04-02 13:08:01 to 2026-07-20 22:01:16 UTC [more...]
[patch 00/18] entry: Consolidate and rework syscall entry handling
2026-07-20 22:01 UTC (101+ messages)
` [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
` [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
` [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
` [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
` [patch 05/18] powerpc/syscall: "
` [patch 06/18] riscv/syscall: "
` [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
` [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
` [patch 09/18] entry: Remove syscall_enter_from_user_mode()
` [patch 10/18] entry: Use syscall number instead of rereading it
` [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
` [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
` [patch 13/18] entry: Make trace_syscall_enter() return type bool
` [patch 14/18] entry: Make return type of syscall_trace_enter() bool
` [patch 15/18] x86/entry: Make syscall functions static
` [patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
` [patch 17/18] x86/entry: Simplify the syscall number logic
` [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
[PATCH] hexagon: remove code to handle nonexistent CONFIG_PAGE_SIZE_1MB
2026-07-01 17:06 UTC (3+ messages)
[linux-next:master] BUILD REGRESSION 550604d6c9b9efc8d068aff94dc301694a7afdee
2026-05-22 0:33 UTC
[PATCH] Generate <asm/asm-offsets.h> and remove identical copies in all architectures
2026-05-19 1:18 UTC
[PATCH v3 0/4] arch, mm: consolidate empty_zero_page
2026-04-30 3:25 UTC (2+ messages)
[RFC PATCH v1 0/9] uaccess: Convert small fixed size copy_{to/from}_user() to scoped user access
2026-04-29 11:26 UTC (30+ messages)
` [RFC PATCH v1 1/9] uaccess: Split check_zeroed_user() out of usercopy.c
` [RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
` [RFC PATCH v1 3/9] x86/umip: Be stricter in fixup_umip_exception()
` [RFC PATCH v1 4/9] uaccess: Introduce copy_{to/from}_user_partial()
` [RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
` [RFC PATCH v1 6/9] uaccess: Change copy_{to/from}_user to return -EFAULT
` [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
` [RFC PATCH v1 8/9] arm64: "
` [RFC PATCH v1 9/9] uaccess: Convert small fixed size copy_{to/from}_user() to scoped user access
[PATCH AUTOSEL 7.0-5.10] hexagon: uapi: Fix structure alignment attribute
2026-04-20 13:19 UTC
[GIT PULL] Kbuild and Kconfig changes for v7.1
2026-04-14 16:46 UTC (2+ messages)
[PATCH v5 3/8] hexagon: Replace __ASSEMBLY__ with __ASSEMBLER__ in uapi headers
2026-04-09 9:47 UTC (2+ messages)
` [PATCH v5 4/8] hexagon: Replace __ASSEMBLY__ with __ASSEMBLER__ in non-uapi headers
[PATCH v2] cmpxchg: allow const-qualified old value in cmpxchg()
2026-04-03 1:19 UTC
[PATCH] cmpxchg: allow const-qualified old value in cmpxchg()
2026-04-02 13:07 UTC (3+ messages)
page: | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox