From: Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>
To: Andy Shevchenko <andy.shevchenko@gmail.com>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
"Rafael J. Wysocki" <rafael@kernel.org>,
Stuart Yoder <stuyoder@gmail.com>,
"K. Y. Srinivasan" <kys@microsoft.com>,
Haiyang Zhang <haiyangz@microsoft.com>,
Stephen Hemminger <sthemmin@microsoft.com>,
Wei Liu <wei.liu@kernel.org>, Dexuan Cui <decui@microsoft.com>,
Bjorn Helgaas <bhelgaas@google.com>,
Bjorn Andersson <bjorn.andersson@linaro.org>,
Mathieu Poirier <mathieu.poirier@linaro.org>,
Vineeth Vijayan <vneethv@linux.ibm.com>,
Peter Oberparleiter <oberpar@linux.ibm.com>,
Heiko Carstens <hca@linux.ibm.com>,
Vasily Gorbik <gor@linux.ibm.com>,
Alexander Gordeev <agordeev@linux.ibm.com>,
Christian Borntraeger <borntraeger@linux.ibm.com>,
Sven Schnelle <svens@linux.ibm.com>,
Andy Gross <agross@kernel.org>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
linux-clk <linux-clk@vger.kernel.org>,
NXP Linux Team <linux-imx@nxp.com>,
linux-arm Mailing List <linux-arm-kernel@lists.infradead.org>,
Linux on Hyper-V List <linux-hyperv@vger.kernel.org>,
linux-pci <linux-pci@vger.kernel.org>,
linux-remoteproc@vger.kernel.org, linux-s390@vger.kernel.org,
linux-arm-msm@vger.kernel.org,
ALSA Development Mailing List <alsa-devel@alsa-project.org>,
linux-spi <linux-spi@vger.kernel.org>,
virtualization@lists.linux-foundation.org,
Linus Torvalds <torvalds@linux-foundation.org>,
Rasmus Villemoes <linux@rasmusvillemoes.dk>
Subject: Re: [PATCH v6 01/12] driver: platform: Add helper for safer setting of driver_override
Date: Mon, 4 Apr 2022 11:34:52 +0200 [thread overview]
Message-ID: <2976f4f9-4fda-c04f-45cf-351518f88ec0@linaro.org> (raw)
In-Reply-To: <CAHp75Vczm9f9Bx_w4nW31cnBgwEzPiN-Eqn-7DKZuB+Hew0F=Q@mail.gmail.com>
On 04/04/2022 11:16, Andy Shevchenko wrote:
> On Sun, Apr 3, 2022 at 9:38 PM Krzysztof Kozlowski
> <krzysztof.kozlowski@linaro.org> wrote:
>>
>> Several core drivers and buses expect that driver_override is a
>> dynamically allocated memory thus later they can kfree() it.
>>
>> However such assumption is not documented, there were in the past and
>> there are already users setting it to a string literal. This leads to
>> kfree() of static memory during device release (e.g. in error paths or
>> during unbind):
>>
>> kernel BUG at ../mm/slub.c:3960!
>> Internal error: Oops - BUG: 0 [#1] PREEMPT SMP ARM
>> ...
>> (kfree) from [<c058da50>] (platform_device_release+0x88/0xb4)
>> (platform_device_release) from [<c0585be0>] (device_release+0x2c/0x90)
>> (device_release) from [<c0a69050>] (kobject_put+0xec/0x20c)
>> (kobject_put) from [<c0f2f120>] (exynos5_clk_probe+0x154/0x18c)
>> (exynos5_clk_probe) from [<c058de70>] (platform_drv_probe+0x6c/0xa4)
>> (platform_drv_probe) from [<c058b7ac>] (really_probe+0x280/0x414)
>> (really_probe) from [<c058baf4>] (driver_probe_device+0x78/0x1c4)
>> (driver_probe_device) from [<c0589854>] (bus_for_each_drv+0x74/0xb8)
>> (bus_for_each_drv) from [<c058b48c>] (__device_attach+0xd4/0x16c)
>> (__device_attach) from [<c058a638>] (bus_probe_device+0x88/0x90)
>> (bus_probe_device) from [<c05871fc>] (device_add+0x3dc/0x62c)
>> (device_add) from [<c075ff10>] (of_platform_device_create_pdata+0x94/0xbc)
>> (of_platform_device_create_pdata) from [<c07600ec>] (of_platform_bus_create+0x1a8/0x4fc)
>> (of_platform_bus_create) from [<c0760150>] (of_platform_bus_create+0x20c/0x4fc)
>> (of_platform_bus_create) from [<c07605f0>] (of_platform_populate+0x84/0x118)
>> (of_platform_populate) from [<c0f3c964>] (of_platform_default_populate_init+0xa0/0xb8)
>> (of_platform_default_populate_init) from [<c01031f8>] (do_one_initcall+0x8c/0x404)
>>
>> Provide a helper which clearly documents the usage of driver_override.
>> This will allow later to reuse the helper and reduce the amount of
>> duplicated code.
>>
>> Convert the platform driver to use a new helper and make the
>> driver_override field const char (it is not modified by the core).
>
> ...
>
>> +int driver_set_override(struct device *dev, const char **override,
>> + const char *s, size_t len)
>> +{
>> + const char *new, *old;
>> + char *cp;
>
>> + if (!override || !s)
>> + return -EINVAL;
>
> Still not sure if we should distinguish (s == NULL && len == 0) from
> (s != NULL && len == 0).
> Supplying the latter seems confusing (yes, I see that in the old code). Perhaps
> !s test, in case you want to leave it, should be also commented.
The old semantics were focused on sysfs usage, so clearing is by passing
an empty string. In the case of sysfs empty string is actually "\n". I
intend to keep the semantics also for the in-kernel usage and in such
case empty string can be also "".
If I understand your comment correctly, you propose to change it to NULL
for in-kernel usage, but that would change the semantics.
> Another approach is to split above to two checks and move !s after !len.
I don't follow why... The !override and !s are invalid uses. !len is a
valid user for internal callers, just like "\n" is for sysfs.
>
>> + /*
>> + * The stored value will be used in sysfs show callback (sysfs_emit()),
>> + * which has a length limit of PAGE_SIZE and adds a trailing newline.
>> + * Thus we can store one character less to avoid truncation during sysfs
>> + * show.
>> + */
>> + if (len >= (PAGE_SIZE - 1))
>> + return -EINVAL;
>
> Perhaps explain the case in the comment here?
You mean the case we discuss here (to clear override with "")? Sure.
>
>> + if (!len) {
>> + device_lock(dev);
>> + old = *override;
>> + *override = NULL;
>
>> + device_unlock(dev);
>> + goto out_free;
>
> You may deduplicate this one, by
>
> goto out_unlock_free;
>
> But I understand your intention to keep lock-unlock in one place, so
> perhaps dropping that label would be even better in this case and
> keeping it
Yes, exactly.
>
> kfree(old);
> return 0;
>
> here instead of goto.
Slightly more code, but indeed maybe easier to follow. I'll do like this.
Best regards,
Krzysztof
next prev parent reply other threads:[~2022-04-04 9:35 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-04-03 18:37 [PATCH v6 00/12] Fix broken usage of driver_override (and kfree of static memory) Krzysztof Kozlowski
2022-04-03 18:37 ` [PATCH v6 01/12] driver: platform: Add helper for safer setting of driver_override Krzysztof Kozlowski
2022-04-04 9:16 ` Andy Shevchenko
2022-04-04 9:34 ` Krzysztof Kozlowski [this message]
2022-04-04 10:14 ` Andy Shevchenko
2022-04-03 18:37 ` [PATCH v6 02/12] amba: Use driver_set_override() instead of open-coding Krzysztof Kozlowski
2022-04-03 18:37 ` [PATCH v6 03/12] fsl-mc: " Krzysztof Kozlowski
2022-04-03 18:37 ` [PATCH v6 04/12] hv: " Krzysztof Kozlowski
2022-04-03 18:37 ` [PATCH v6 05/12] PCI: " Krzysztof Kozlowski
2022-04-03 18:37 ` [PATCH v6 06/12] s390/cio: " Krzysztof Kozlowski
2022-04-03 18:37 ` [PATCH v6 07/12] spi: Use helper for safer setting of driver_override Krzysztof Kozlowski
2022-04-03 18:37 ` [PATCH v6 08/12] vdpa: " Krzysztof Kozlowski
2022-04-03 18:37 ` [PATCH v6 09/12] clk: imx: scu: Fix kfree() of static memory on setting driver_override Krzysztof Kozlowski
2022-04-03 18:37 ` [PATCH v6 10/12] slimbus: qcom-ngd: " Krzysztof Kozlowski
2022-04-03 18:37 ` [PATCH v6 11/12] rpmsg: Constify local variable in field store macro Krzysztof Kozlowski
2022-04-03 18:37 ` [PATCH v6 12/12] rpmsg: Fix kfree() of static memory on setting driver_override Krzysztof Kozlowski
2022-04-12 14:10 ` Biju Das
2022-04-13 8:40 ` Krzysztof Kozlowski
2022-04-13 8:47 ` Biju Das
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2976f4f9-4fda-c04f-45cf-351518f88ec0@linaro.org \
--to=krzysztof.kozlowski@linaro.org \
--cc=agordeev@linux.ibm.com \
--cc=agross@kernel.org \
--cc=alsa-devel@alsa-project.org \
--cc=andy.shevchenko@gmail.com \
--cc=bhelgaas@google.com \
--cc=bjorn.andersson@linaro.org \
--cc=borntraeger@linux.ibm.com \
--cc=decui@microsoft.com \
--cc=gor@linux.ibm.com \
--cc=gregkh@linuxfoundation.org \
--cc=haiyangz@microsoft.com \
--cc=hca@linux.ibm.com \
--cc=kys@microsoft.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-clk@vger.kernel.org \
--cc=linux-hyperv@vger.kernel.org \
--cc=linux-imx@nxp.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=linux-remoteproc@vger.kernel.org \
--cc=linux-s390@vger.kernel.org \
--cc=linux-spi@vger.kernel.org \
--cc=linux@rasmusvillemoes.dk \
--cc=mathieu.poirier@linaro.org \
--cc=oberpar@linux.ibm.com \
--cc=rafael@kernel.org \
--cc=sthemmin@microsoft.com \
--cc=stuyoder@gmail.com \
--cc=svens@linux.ibm.com \
--cc=torvalds@linux-foundation.org \
--cc=virtualization@lists.linux-foundation.org \
--cc=vneethv@linux.ibm.com \
--cc=wei.liu@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox