Linux ATA/IDE development
 help / color / mirror / Atom feed
From: Alan Cox <alan@lxorguk.ukuu.org.uk>
To: Tejun Heo <htejun@gmail.com>
Cc: jgarzik@pobox.com, axboe@suse.de, albertcc@tw.ibm.com,
	forrest.zhao@intel.com, efalk@google.com,
	linux-ide@vger.kernel.org
Subject: Re: [PATCH 3/6] sata_sil: new interrupt handler
Date: Thu, 11 May 2006 16:40:44 +0100	[thread overview]
Message-ID: <1147362044.26130.39.camel@localhost.localdomain> (raw)
In-Reply-To: <11473604982155-git-send-email-htejun@gmail.com>

On Gwe, 2006-05-12 at 00:14 +0900, Tejun Heo wrote:
> The DMA complete bit of these controllers reflects ATA IRQ status
> while no DMA command is in progress.  So, we can tell whether the
> controller is raising an interrupt or not in deterministic manner.
> This patch gives sata_sil its own interrupt handler which behaves much
> better than the original one in terms of error detection and handling.
> This change is also necessary for later hotplug support.
> 

Is it not possible to avoid duplicating so much code. If the
sil_host_intr and a few other _intr routines end up with their own
host_intr functions closely based on the core one and intimate state
machine knowledge then fixes are going to get missed in one or the other
over time 


  reply	other threads:[~2006-05-11 15:29 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-05-11 15:14 [PATCHSET 07/11] prep LLDDs for hotplug support, take 1 (REPOST) Tejun Heo
2006-05-11 15:14 ` [PATCH 3/6] sata_sil: new interrupt handler Tejun Heo
2006-05-11 15:40   ` Alan Cox [this message]
2006-05-11 16:16     ` Tejun Heo
2006-05-11 15:14 ` [PATCH 4/6] sata_sil24: rename PORT_PRB to PORT_LRAM and add PORT_LRAM_SLOT_SZ Tejun Heo
2006-05-11 15:14 ` [PATCH 2/6] sata_sil: add new constants in preparation for new interrupt handler Tejun Heo
2006-05-11 15:14 ` [PATCH 1/6] libata: export ata_hsm_move() Tejun Heo
2006-05-11 15:14 ` [PATCH 5/6] sata_sil24: use sata_phy_debounce() in sil24_hardreset() Tejun Heo
2006-05-11 15:14 ` [PATCH 6/6] sata_sil24: kill ops->tf_read() and use ata_std_noop_check_status() Tejun Heo
  -- strict thread matches above, loose matches on Subject: below --
2006-05-19 15:38 [PATCHSET 02/03] prep LLDDs for hotplug support, take 2 Tejun Heo
2006-05-19 15:38 ` [PATCH 3/6] sata_sil: new interrupt handler Tejun Heo
2006-05-19 15:46   ` Jeff Garzik
2006-05-23 14:50     ` Tejun Heo
2006-05-23 22:04       ` Jeff Garzik
2006-05-23 22:07         ` Tejun Heo
2006-05-11 15:11 [PATCHSET 07/11] prep LLDDs for hotplug support, take 1 Tejun Heo
2006-05-11 15:11 ` [PATCH 3/6] sata_sil: new interrupt handler Tejun Heo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1147362044.26130.39.camel@localhost.localdomain \
    --to=alan@lxorguk.ukuu.org.uk \
    --cc=albertcc@tw.ibm.com \
    --cc=axboe@suse.de \
    --cc=efalk@google.com \
    --cc=forrest.zhao@intel.com \
    --cc=htejun@gmail.com \
    --cc=jgarzik@pobox.com \
    --cc=linux-ide@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox