From mboxrd@z Thu Jan 1 00:00:00 1970 From: Tejun Heo Subject: Re: [PATCH v5 1/3] libata, libsas: kill pm_result and related cleanup Date: Mon, 10 Mar 2014 16:29:47 -0400 Message-ID: <20140310202947.GG25290@htj.dyndns.org> References: <20140305201443.20088.85361.stgit@viggo.jf.intel.com> <20140305201730.20088.42218.stgit@viggo.jf.intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Return-path: Received: from mail-qc0-f173.google.com ([209.85.216.173]:47624 "EHLO mail-qc0-f173.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753229AbaCJU3v (ORCPT ); Mon, 10 Mar 2014 16:29:51 -0400 Content-Disposition: inline In-Reply-To: <20140305201730.20088.42218.stgit@viggo.jf.intel.com> Sender: linux-ide-owner@vger.kernel.org List-Id: linux-ide@vger.kernel.org To: Dan Williams Cc: JBottomley@Parallels.com, Phillip Susi , Todd Brandt , Alan Stern , linux-scsi@vger.kernel.org, linux-ide@vger.kernel.org Hello, On Wed, Mar 05, 2014 at 12:17:30PM -0800, Dan Williams wrote: > +#define ata_port_resume_sync(ap, msg) ata_port_resume_common((ap), (msg), false) > +#define queue_ata_port_resume(ap, msg) ata_port_resume_common((ap), (msg), true) Let's please use proper static functions. The compiler can deal with inlining. Also, maybe ata_port_resume() and ata_port_resume_async() are better names for the wrappers? Other than that, libata part looks good to me. Thanks. -- tejun