From mboxrd@z Thu Jan 1 00:00:00 1970 From: Segher Boessenkool Subject: Re: [PATCH 2/2] [POWERPC] MPC8349E-mITX: use platform IDE driver for CF interface Date: Wed, 1 Aug 2007 00:36:14 +0200 Message-ID: References: <20070725165318.5331.23795.stgit@localhost.localdomain> <20070725165326.5331.19920.stgit@localhost.localdomain> <46A78322.3080607@ru.mvista.com> <46A78E3F.1030904@ru.mvista.com> Mime-Version: 1.0 (Apple Message framework v623) Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: In-Reply-To: <46A78E3F.1030904@ru.mvista.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: linuxppc-dev-bounces+glppd-linuxppc64-dev=m.gmane.org@ozlabs.org Errors-To: linuxppc-dev-bounces+glppd-linuxppc64-dev=m.gmane.org@ozlabs.org To: Sergei Shtylyov Cc: linux-ide@vger.kernel.org, linuxppc-dev@ozlabs.org, linux-kernel@vger.kernel.org List-Id: linux-ide@vger.kernel.org >>> + ide@f0000000 { >>> + compatible = "mmio-ide"; >>> + device_type = "ide"; > >> Why not "ata"? The hardware is called (E)IDE, the protocol is called ATA. Or that's what I was told -- I think there's some historic revisionism involved, too. > Also, what mmio-ide in the compat properly means in the context of > ide_platform which is able to handle both port and memory mapped IDE. > I think > we must get rid with this crap, and since this IDE register mapping is > pretty > much board specific, call it something like "mpc8349emitx-ide" instead. "mmio-ide" simply is not specific enough. The device_type should go, too. If this IDE interface is board-specific, thee "compatible" property should include the board vendor name and board name. Oh, that's what "emitx" tries to do -- it could be a bit clearer perhaps ;-) Segher