From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from sauhun.de ([88.99.104.3]:48592 "EHLO pokefinder.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932870AbeFRLyx (ORCPT ); Mon, 18 Jun 2018 07:54:53 -0400 Date: Mon, 18 Jun 2018 20:54:46 +0900 From: Wolfram Sang To: Peter Rosin Cc: linux-kernel@vger.kernel.org, Peter Huewe , Jarkko Sakkinen , Jason Gunthorpe , Arnd Bergmann , Greg Kroah-Hartman , Brian Norris , Gregory Fong , Florian Fainelli , bcm-kernel-feedback-list@broadcom.com, Sekhar Nori , Kevin Hilman , Haavard Skinnemoen , Kukjin Kim , Krzysztof Kozlowski , Orson Zhai , Baolin Wang , Chunyan Zhang , Laxman Dewangan , Thierry Reding , Jonathan Hunter , Guenter Roeck , Crt Mori , Jonathan Cameron , Hartmut Knaack , Lars-Peter Clausen , Peter Meerwald-Stadler , Dmitry Torokhov , Antti Palosaari , Mauro Carvalho Chehab , Michael Krufky , Lee Jones , linux-integrity@vger.kernel.org, linux-i2c@vger.kernel.org, linux-arm-kernel@lists.infradead.org, linux-samsung-soc@vger.kernel.org, linux-tegra@vger.kernel.org, linux-iio@vger.kernel.org, linux-input@vger.kernel.org, linux-media@vger.kernel.org Subject: Re: [PATCH 01/11] i2c: add helpers for locking the I2C segment Message-ID: <20180618115444.pgjmfntp767zuvmw@ninjato> References: <20180615101506.8012-1-peda@axentia.se> <20180615101506.8012-2-peda@axentia.se> <20180618110502.cb5s24srp4frahm6@ninjato> MIME-Version: 1.0 Content-Type: multipart/signed; micalg=pgp-sha256; protocol="application/pgp-signature"; boundary="odyilowjkqhfymya" In-Reply-To: Sender: linux-iio-owner@vger.kernel.org List-Id: linux-iio@vger.kernel.org --odyilowjkqhfymya Content-Type: text/plain; charset=us-ascii Content-Disposition: inline Content-Transfer-Encoding: quoted-printable > > I wonder if i2c_lock_segment() and i2c_lock_root_adapter() are really > > more readable and convenient than i2c_lock_bus() with the flag. I think > > the flags have speaking names, too. > >=20 > > Is that an idea to remove these functions altogether and start using > > i2c_lock_bus()? >=20 > That would be fine with me. I don't have a strong opinion and agree that > both are readable enough... >=20 > It would make for a reduction of the number of lines so that's nice, but > the macro in drivers/i2c/busses/i2c-gpio.c (patch 11) would not fit in > the current \-width (or whatever you'd call that line of backslashes to > the right in a multi-line macro). >=20 > Does anyone have a strong opinion? I have a strong opinion on making i2c.h less bloated. And yes, less number of lines is nice, too. I think that surely pays off the whitespace exception. Thanks! --odyilowjkqhfymya Content-Type: application/pgp-signature; name="signature.asc" -----BEGIN PGP SIGNATURE----- iQIzBAABCAAdFiEEOZGx6rniZ1Gk92RdFA3kzBSgKbYFAlsnnXsACgkQFA3kzBSg KbanHg//QoW7vYFlzaQmn4GWdT8DHxpMggaefmiIzNdCezeBGZf+7umVKJ9JwScH L7tMU76PFrWS8PRJv678TUzIgCamMUepR8AX99kR79q2VKTucHnprWc68WEelO71 j5C9y/Vc7Oa+AnD6DlnV5JySSjcHTNH1beivLlpU/AATcT1qJf6acYkJfV8h4JCP F+wOu6gt2SjsjPY/Naj8NiCXzW1n1be46vOKuwvTcxEcIvs1qSkoMr52S34y/VUP DuXFqwsySm0Yb/Z+lF7nOKwEgJ8PV2Y5IPvsnK+KAt86d5X4ivnLgr5Lw6DCGShX VhUGaYI9amhtSVT77mpiz+TvUoi3vvUccVKvVUMicGFvNG0b+45wHQwJiGRYxuzn 57/Fdm+7Dr5/IhqP0HRNc7rWorrT2NcDCJp+Pea5xcSXpsKkoMdLaCW994T1aT0g 78utxNnqS21O3GCdITN/IO4xbCN1dNX9+x/6sl5Ks9xO0WA3Fvl1fOlslvVknSAp 4cJRMWOlxqK6NCU4dHy762yptyVrpzp/01jcofLJhpkLRxQjXSiJpk/C6BxZsipa a1uyKean7DC8imJX2StUVaKCA9ava33fJau+HBC3TPLXzh54mU8FI+FZTrxB89Aj g+8WH14/n0PrTsvFDkLcgGRVY4uQwPkWkM3HYkauUmyyPFs+wYE= =CA/X -----END PGP SIGNATURE----- --odyilowjkqhfymya--