From: Jonathan Cameron <jic23@kernel.org>
To: Lothar Rubusch <l.rubusch@gmail.com>
Cc: lars@metafoo.de, Michael.Hennerich@analog.com,
linux-iio@vger.kernel.org, linux-kernel@vger.kernel.org,
eraretuya@gmail.com
Subject: Re: [PATCH v5 10/11] iio: accel: adxl345: add coupling detection for activity/inactivity
Date: Mon, 31 Mar 2025 11:52:03 +0100 [thread overview]
Message-ID: <20250331115203.578c69eb@jic23-huawei> (raw)
In-Reply-To: <20250318230843.76068-11-l.rubusch@gmail.com>
On Tue, 18 Mar 2025 23:08:42 +0000
Lothar Rubusch <l.rubusch@gmail.com> wrote:
> Add coupling activity/inactivity detection by the AC/DC bit. This is an
> addititional enhancement for the detection of activity states and
> completes the activity / inactivity feature of the ADXL345.
>
> Signed-off-by: Lothar Rubusch <l.rubusch@gmail.com>
> ---
> @@ -300,6 +319,69 @@ static int adxl345_set_measure_en(struct adxl345_state *st, bool en)
>
> /* act/inact */
>
> +static int adxl345_is_act_inact_ac(struct adxl345_state *st,
> + enum adxl345_activity_type type, bool *ac)
> +{
> + unsigned int regval;
> + int ret;
> +
> + ret = regmap_read(st->regmap, ADXL345_REG_ACT_INACT_CTRL, ®val);
> + if (ret)
> + return ret;
> +
> + if (type == ADXL345_ACTIVITY)
> + *ac = (FIELD_GET(ADXL345_REG_ACT_ACDC_MSK, regval) > 0);
> + else
> + *ac = (FIELD_GET(ADXL345_REG_INACT_ACDC_MSK, regval) > 0);
The > 0 doesn't add anything so I'd drop those.
Get used to non 0 integer == true for booleans takes some time but
is commonly assumed in kernel code (it is true in C in general but
some coding styles don't assume it!)
> +
> + return 0;
> +}
> static int adxl345_read_avail(struct iio_dev *indio_dev,
> @@ -919,6 +1050,8 @@ static int adxl345_read_event_config(struct iio_dev *indio_dev,
> {
> struct adxl345_state *st = iio_priv(indio_dev);
> bool int_en;
> + bool act_ac;
> + bool inact_ac;
Could stick those 3 bools on one line without loosing readability I think.
Save a tiny bit of scrolling ;)
or push them down to context where they are used.
> int ret;
>
> switch (type) {
> @@ -963,6 +1096,21 @@ static int adxl345_read_event_config(struct iio_dev *indio_dev,
> if (ret)
> return ret;
> return int_en;
> + case IIO_EV_TYPE_MAG_REFERENCED:
> + switch (dir) {
> + case IIO_EV_DIR_RISING:
> + ret = adxl345_is_act_inact_ac(st, ADXL345_ACTIVITY, &act_ac);
> + if (ret)
> + return ret;
> + return act_ac;
> + case IIO_EV_DIR_FALLING:
> + ret = adxl345_is_act_inact_ac(st, ADXL345_INACTIVITY, &inact_ac);
> + if (ret)
> + return ret;
> + return inact_ac;
> + default:
> + return -EINVAL;
> + }
> default:
> return -EINVAL;
> }
> @@ -999,6 +1147,16 @@ static int adxl345_write_event_config(struct iio_dev *indio_dev,
> }
> case IIO_EV_TYPE_MAG:
> return adxl345_set_ff_en(st, state);
> + case IIO_EV_TYPE_MAG_REFERENCED:
> + switch (dir) {
> + case IIO_EV_DIR_RISING:
> + return adxl345_set_act_inact_ac(st, ADXL345_ACTIVITY, state);
> + case IIO_EV_DIR_FALLING:
> + return adxl345_set_act_inact_ac(st, ADXL345_INACTIVITY, state);
> + default:
> + return -EINVAL;
> + }
> +
> default:
> return -EINVAL;
> }
next prev parent reply other threads:[~2025-03-31 10:52 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-18 23:08 [PATCH v5 00/11] iio: accel: adxl345: add interrupt based sensor events Lothar Rubusch
2025-03-18 23:08 ` [PATCH v5 01/11] iio: accel: adxl345: introduce adxl345_push_event function Lothar Rubusch
2025-03-18 23:08 ` [PATCH v5 02/11] iio: accel: adxl345: add single tap feature Lothar Rubusch
2025-03-31 10:22 ` Jonathan Cameron
2025-03-18 23:08 ` [PATCH v5 03/11] iio: accel: adxl345: add double " Lothar Rubusch
2025-03-18 23:08 ` [PATCH v5 04/11] iio: accel: adxl345: set the tap suppress bit permanently Lothar Rubusch
2025-03-18 23:08 ` [PATCH v5 05/11] iio: accel: adxl345: add freefall feature Lothar Rubusch
2025-03-31 10:28 ` Jonathan Cameron
2025-03-31 17:23 ` Lothar Rubusch
2025-04-06 11:18 ` Jonathan Cameron
2025-04-14 14:30 ` Lothar Rubusch
2025-04-14 18:28 ` Jonathan Cameron
2025-03-18 23:08 ` [PATCH v5 06/11] iio: accel: adxl345: extend sample frequency adjustments Lothar Rubusch
2025-03-31 10:33 ` Jonathan Cameron
2025-04-14 11:41 ` Lothar Rubusch
2025-04-14 18:30 ` Jonathan Cameron
2025-03-18 23:08 ` [PATCH v5 07/11] iio: accel: adxl345: add g-range configuration Lothar Rubusch
2025-03-18 23:08 ` [PATCH v5 08/11] iio: accel: adxl345: add activity event feature Lothar Rubusch
2025-03-31 10:40 ` Jonathan Cameron
2025-04-14 11:58 ` Lothar Rubusch
2025-04-14 18:31 ` Jonathan Cameron
2025-03-18 23:08 ` [PATCH v5 09/11] iio: accel: adxl345: add inactivity feature Lothar Rubusch
2025-03-31 10:47 ` Jonathan Cameron
2025-04-14 13:19 ` Lothar Rubusch
2025-04-14 18:34 ` Jonathan Cameron
2025-03-18 23:08 ` [PATCH v5 10/11] iio: accel: adxl345: add coupling detection for activity/inactivity Lothar Rubusch
2025-03-31 10:52 ` Jonathan Cameron [this message]
2025-03-18 23:08 ` [PATCH v5 11/11] docs: iio: add documentation for adxl345 driver Lothar Rubusch
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250331115203.578c69eb@jic23-huawei \
--to=jic23@kernel.org \
--cc=Michael.Hennerich@analog.com \
--cc=eraretuya@gmail.com \
--cc=l.rubusch@gmail.com \
--cc=lars@metafoo.de \
--cc=linux-iio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox