From: Andy Shevchenko <andriy.shevchenko@intel.com>
To: Marcelo Schmitt <marcelo.schmitt@analog.com>
Cc: linux-iio@vger.kernel.org, devicetree@vger.kernel.org,
linux-kernel@vger.kernel.org, linux@analog.com, jic23@kernel.org,
nuno.sa@analog.com, dlechner@baylibre.com, andy@kernel.org,
Michael.Hennerich@analog.com, robh@kernel.org,
krzk+dt@kernel.org, conor+dt@kernel.org, corbet@lwn.net,
skhan@linuxfoundation.org, marcelo.schmitt1@gmail.com
Subject: Re: [PATCH v1 12/13] iio: adc: ad4134: Support high-speed data capture
Date: Thu, 3 Sep 2026 10:00:16 +0300 [thread overview]
Message-ID: <apkbAMQ0J2_wJRTv@ashevche-desk.local> (raw)
In-Reply-To: <53d79eed25795db5076d7c591f6dd8cf4feedfec.1788368334.git.marcelo.schmitt@analog.com>
On Wed, Sep 02, 2026 at 02:25:26PM -0300, Marcelo Schmitt wrote:
> Make use of SPI transfer offloading to speed up data capture, enabling data
> acquisition at faster sample rates (up to 1.496 MSPS).
...
> +static int ad4134_update_conversion_rate(struct ad4134_state *st,
> + unsigned int freq_Hz)
> +{
> + struct spi_offload_trigger_config config = st->offload_trigger_config;
> + struct pwm_waveform odr_wf = { };
> + u64 offload_period_ns;
> + u64 offload_offset_ns;
> + u64 odr_high_time_ns;
> + unsigned int count;
> + u64 target = 10;
Split assignment and move it closer to its first user.
> + int ret;
> +
> + if (!in_range(freq_Hz, AD4134_MIN_ODR_FREQ_HZ, AD4134_MAX_ODR_FREQ_HZ))
> + return -ERANGE;
> +
> + odr_wf.period_length_ns = DIV_ROUND_UP_ULL(NSEC_PER_SEC, freq_Hz);
> + /*
> + * Set the PWM duty cycle to keep ODR high for at least minimum required
> + * time. If the rounded PWM's value is less than the minimum required,
> + * increase the target value by 10 and attempt to round the waveform
> + * again, until the minimum (or try count limit) is reached.
> + */
> + odr_high_time_ns = div64_ul(6ULL * NSEC_PER_SEC, st->sys_clk_hz);
target = 0;
> + count = 100;
> + do {
target += 10; /* Increment by PWM duty cycle period */
> + odr_wf.duty_length_ns = target;
> + ret = pwm_round_waveform_might_sleep(st->odr_pwm, &odr_wf);
> + if (ret)
> + return ret;
> + target += 10; /* Increment by PWM duty cycle period */
In the above way I think it clarifies the initial setting to 10.
Shouldn't be target named as target_ns? Can we use odr_wf.duty_length_ns
directly?
> + } while (count-- && odr_wf.duty_length_ns < odr_high_time_ns);
> +
> + /* Check the minimum ODR high time is met */
> + if (odr_wf.duty_length_ns < odr_high_time_ns)
> + return -EDOM;
> +
> + if (odr_wf.period_length_ns < 2 * odr_high_time_ns)
> + return -EDOM;
> +
> + /*
> + * Configure SPI offload PWM trigger.
> + * For gated DCLK, the minimum required time between ODR rising edge
> + * and DCLK rising edge is the sum of ODR high time and ODR falling
> + * edge to DCLK rising edge time. Delay the offload trigger for at least
> + * that amount of time so the ADC sample data will be available when the
> + * SPI transfer begin.
> + *
> + * Use the same period as ODR PWM to avoid timing issues.
> + * Convert back from period to frequency for the SPI offload API.
> + */
> + offload_period_ns = odr_wf.period_length_ns;
> + config.periodic.frequency_hz = DIV_ROUND_UP_ULL(HZ_PER_GHZ, offload_period_ns);
> + offload_offset_ns = odr_high_time_ns + AD4134_DCLK_RISING_OFFSET_NS;
> + count = 100;
> + do {
> + config.periodic.offset_ns = offload_offset_ns;
> + ret = spi_offload_trigger_validate(st->offload_trigger, &config);
> + if (ret)
> + return ret;
> +
> + offload_offset_ns += 10;
Does this need the similar comment as per above?
> + } while (count-- && config.periodic.offset_ns < odr_high_time_ns +
> + AD4134_DCLK_RISING_OFFSET_NS);
> +
> + /* Check the minimum ODR to DCLK delay is met */
> + if (config.periodic.offset_ns < odr_high_time_ns + AD4134_DCLK_RISING_OFFSET_NS)
> + return -EDOM;
> +
> + /* Check the PWM periods remain the same */
> + offload_period_ns = DIV_ROUND_UP_ULL(HZ_PER_GHZ, config.periodic.frequency_hz);
> + if (odr_wf.period_length_ns != offload_period_ns)
> + return -EDOM;
> +
> + ret = pwm_set_waveform_might_sleep(st->odr_pwm, &odr_wf, false);
> + if (ret)
> + return ret;
> +
> + st->offload_trigger_config = config;
> + st->odr_wf = odr_wf;
> + st->odr_hz = DIV_ROUND_UP_ULL(NSEC_PER_SEC, odr_wf.period_length_ns);
> +
> + return 0;
> +}
...
> +static int ad4134_offload_buffer_postenable(struct iio_dev *indio_dev)
> +{
> + struct ad4134_state *st = iio_priv(indio_dev);
> + int ret, ret2;
These ret2:s in the cases of _set_register_() can be named accordingly.
> + if (st->spi_mode == AD4134_SPI_MODE_4_WIRE) {
> + ret = ad4134_set_sample_access(st);
> + if (ret)
> + return ret;
> + }
> +
> + ad4134_prepare_offload_msg(indio_dev);
> + st->msg.offload = st->offload;
> + ret = spi_optimize_message(st->spi, &st->msg);
> + if (ret)
> + goto out_set_register_input;
> +
> + ret = spi_offload_trigger_enable(st->offload, st->offload_trigger,
> + &st->offload_trigger_config);
> + if (ret)
> + goto out_unoptimize;
> +
> + return 0;
> +
> +out_unoptimize:
> + spi_unoptimize_message(&st->msg);
> +
> +out_set_register_input:
> + ret2 = ad4134_set_register_access(st);
> + if (ret2)
> + dev_err(&st->spi->dev, "reg input select error: %d\n", ret2);
> +
> + return ret;
> +}
...
> +/* The chip converts and outputs all 4 channels on each sample request */
> +static const unsigned long ad4134_scan_masks[] = {
> + GENMASK(3, 0),
IIRC Jonathan wants to see this as BIT(x) | BIT(y) | ... to clarify that each
bit is semantically independent.
> + 0
> +};
--
With Best Regards,
Andy Shevchenko
next prev parent reply other threads:[~2026-09-03 7:00 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-02 17:21 [PATCH v1 00/13] iio: adc: ad4134: Enable greater sample rate data capture Marcelo Schmitt
2026-09-02 17:21 ` [PATCH v1 01/13] iio: Fix typo in vendor name Marcelo Schmitt
2026-09-03 6:22 ` Andy Shevchenko
2026-09-02 17:21 ` [PATCH v1 02/13] iio: adc: ad4134: Drop import to empty name space Marcelo Schmitt
2026-09-02 17:22 ` [PATCH v1 03/13] iio: adc: ad4134: Update include list to comply with IWYU principles Marcelo Schmitt
2026-09-03 6:26 ` Andy Shevchenko
2026-09-02 17:22 ` [PATCH v1 04/13] iio: adc: ad4134: Serialize single-read operations Marcelo Schmitt
2026-09-03 6:27 ` Andy Shevchenko
2026-09-02 17:23 ` [PATCH v1 05/13] iio: adc: ad4134: Run shorter transfers when CRC is disabled Marcelo Schmitt
2026-09-02 17:23 ` [PATCH v1 06/13] iio: adc: ad4134: Add support for digital filter type selection Marcelo Schmitt
2026-09-03 6:31 ` Andy Shevchenko
2026-09-02 17:23 ` [PATCH v1 07/13] iio: adc: ad4134: Support buffered data read Marcelo Schmitt
2026-09-02 17:24 ` [PATCH v1 08/13] dt-bindings: iio: adc: adi,ad4134: Document SPI connection mode Marcelo Schmitt
2026-09-03 18:14 ` Conor Dooley
2026-09-02 17:24 ` [PATCH v1 09/13] iio: adc: ad4134: Support SPI 4-wire mode Marcelo Schmitt
2026-09-03 6:39 ` Andy Shevchenko
2026-09-02 17:24 ` [PATCH v1 10/13] dt-bindings: iio: adc: adi,ad4134: Document PWM usage Marcelo Schmitt
2026-09-02 17:25 ` [PATCH v1 11/13] dt-bindings: iio: adc: adi,ad4134: Add high data throughput example Marcelo Schmitt
2026-09-02 17:25 ` [PATCH v1 12/13] iio: adc: ad4134: Support high-speed data capture Marcelo Schmitt
2026-09-03 7:00 ` Andy Shevchenko [this message]
2026-09-02 17:25 ` [PATCH v1 13/13] Docs: iio: Add AD4134 Marcelo Schmitt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=apkbAMQ0J2_wJRTv@ashevche-desk.local \
--to=andriy.shevchenko@intel.com \
--cc=Michael.Hennerich@analog.com \
--cc=andy@kernel.org \
--cc=conor+dt@kernel.org \
--cc=corbet@lwn.net \
--cc=devicetree@vger.kernel.org \
--cc=dlechner@baylibre.com \
--cc=jic23@kernel.org \
--cc=krzk+dt@kernel.org \
--cc=linux-iio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@analog.com \
--cc=marcelo.schmitt1@gmail.com \
--cc=marcelo.schmitt@analog.com \
--cc=nuno.sa@analog.com \
--cc=robh@kernel.org \
--cc=skhan@linuxfoundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox