From: Sanjay Chitroda <sanjayembeddedse@gmail.com>
To: Andy Shevchenko <andriy.shevchenko@intel.com>
Cc: "Jiri Kosina" <jikos@kernel.org>,
"Jonathan Cameron" <jic23@kernel.org>,
"Srinivas Pandruvada" <srinivas.pandruvada@linux.intel.com>,
"David Lechner" <dlechner@baylibre.com>,
"Nuno Sá" <nuno.sa@analog.com>,
"Andy Shevchenko" <andy@kernel.org>,
linux-input@vger.kernel.org, linux-iio@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 02/10] iio: gyro: hid-sensor-gyro-3d: use local struct device
Date: Mon, 20 Jul 2026 22:20:28 +0530 [thread overview]
Message-ID: <1E009860-0A0F-4F8D-8017-CE5739F22144@gmail.com> (raw)
In-Reply-To: <al4MeTgAWWkJsb1T@ashevche-desk.local>
On 20 July 2026 5:24:33 pm IST, Andy Shevchenko <andriy.shevchenko@intel.com> wrote:
>On Mon, Jul 20, 2026 at 03:10:14PM +0530, Sanjay Chitroda via B4 Relay wrote:
>
>> Introduce a local struct device pointer derived from &pdev->dev.
>> This avoids repeated &pdev->dev usage and improves readability.
>
>...
>
>> if (ret) {
>> - dev_err(&pdev->dev, "failed to setup common attributes\n");
>> + dev_err(dev, "failed to setup common attributes\n");
>> return ret;
>
>Nope, First one (to eliminate a lot of churn) should be to convert this and
>similar to use
>
> return dev_err_probe(...);
>
Hi Andy,
Thank you for your input.
I'm planning to have a incremental series: first introduce a local "dev" pointer, then convert the resource management to "devm_*", and finally replace the remaining error reporting with "dev_err_probe()".
This keeps each series focused and avoids introducing intermediate patterns such as:
ret = dev_err_probe(dev, ret, ...);
goto error;
Once the cleanup paths are removed, those sites naturally become:
return dev_err_probe(dev, ret, ...);
Does this approach sound reasonable?
>> }
>>
>> - indio_dev->channels = devm_kmemdup(&pdev->dev, gyro_3d_channels,
>> + indio_dev->channels = devm_kmemdup(dev, gyro_3d_channels,
>> sizeof(gyro_3d_channels), GFP_KERNEL);
>> if (!indio_dev->channels) {
>> - dev_err(&pdev->dev, "failed to duplicate channels\n");
>> + dev_err(dev, "failed to duplicate channels\n");
>
>And this kind of messages are dead code and must be just removed completely.
>
>> return -ENOMEM;
>> }
>
>...
>
>Please, revisit the whole series.
Yep, understood.
I'll revisit series, drop dead code and send v2.
Thanks, Sanjay
>
next prev parent reply other threads:[~2026-07-20 16:50 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-20 9:40 [PATCH 00/10] HID: iio: use local struct device Sanjay Chitroda via B4 Relay
2026-07-20 9:40 ` [PATCH 01/10] iio: humidity: hid-sensor-humidity: " Sanjay Chitroda via B4 Relay
2026-07-20 9:49 ` sashiko-bot
2026-07-20 9:40 ` [PATCH 02/10] iio: gyro: hid-sensor-gyro-3d: " Sanjay Chitroda via B4 Relay
2026-07-20 11:54 ` Andy Shevchenko
2026-07-20 16:50 ` Sanjay Chitroda [this message]
2026-07-20 19:35 ` Andy Shevchenko
2026-07-20 9:40 ` [PATCH 03/10] iio: accel: hid-sensor-accel-3d: " Sanjay Chitroda via B4 Relay
2026-07-20 9:40 ` [PATCH 04/10] iio: light: hid-sensor-als: " Sanjay Chitroda via B4 Relay
2026-07-20 9:40 ` [PATCH 05/10] iio: light: hid-sensor-prox: " Sanjay Chitroda via B4 Relay
2026-07-20 9:40 ` [PATCH 06/10] iio: magnetometer: hid-sensor-magn-3d: " Sanjay Chitroda via B4 Relay
2026-07-20 9:40 ` [PATCH 07/10] iio: orientation: hid-sensor-incl-3d: " Sanjay Chitroda via B4 Relay
2026-07-20 9:40 ` [PATCH 08/10] iio: orientation: hid-sensor-rotation: " Sanjay Chitroda via B4 Relay
2026-07-20 9:40 ` [PATCH 09/10] iio: position: hid-sensor-custom-intel-hinge: " Sanjay Chitroda via B4 Relay
2026-07-20 9:59 ` sashiko-bot
2026-07-20 9:40 ` [PATCH 10/10] iio: pressure: hid-sensor-press: " Sanjay Chitroda via B4 Relay
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1E009860-0A0F-4F8D-8017-CE5739F22144@gmail.com \
--to=sanjayembeddedse@gmail.com \
--cc=andriy.shevchenko@intel.com \
--cc=andy@kernel.org \
--cc=dlechner@baylibre.com \
--cc=jic23@kernel.org \
--cc=jikos@kernel.org \
--cc=linux-iio@vger.kernel.org \
--cc=linux-input@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=nuno.sa@analog.com \
--cc=srinivas.pandruvada@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox