From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
To: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Cc: Andy Shevchenko <andy.shevchenko@gmail.com>,
Alasdair Kergon <agk@redhat.com>,
Mike Snitzer <snitzer@redhat.com>,
device-mapper development <dm-devel@redhat.com>,
Shaohua Li <shli@kernel.org>,
linux-raid@vger.kernel.org,
linux-input <linux-input@vger.kernel.org>,
Andrew Morton <akpm@linux-foundation.org>,
Yury Norov <ynorov@caviumnetworks.com>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
Mika Westerberg <mika.westerberg@linux.intel.com>,
Joe Perches <joe@perches.com>
Subject: Re: [PATCH v4 0/5] bitmap: Introduce alloc/free helpers
Date: Wed, 1 Aug 2018 18:03:25 -0700 [thread overview]
Message-ID: <20180802010325.GB184797@dtor-ws> (raw)
In-Reply-To: <2310fa540b9e5db3b94f4917ecae76dce2a2ca65.camel@linux.intel.com>
On Tue, Jul 24, 2018 at 02:35:53PM +0300, Andy Shevchenko wrote:
> On Thu, 2018-07-05 at 00:30 +0300, Andy Shevchenko wrote:
> > On Sat, Jun 30, 2018 at 11:17 PM, Andy Shevchenko
> > <andriy.shevchenko@linux.intel.com> wrote:
> > > A lot of code is using allocation of bitmaps using BITS_PER_LONG()
> > > macro and
> > > sizeof(unsigned long) operator. The readability suffers because of
> > > this.
> > >
> > > The series introduces three helpers, i.e. bitmap_alloc(),
> > > bitmap_zalloc() and
> > > bitmap_free(), to make it more cleaner.
> > >
> >
> > Dmitry, it seems we are all set now and if you have no objections
> > against this version, it would be nice to see it in your tree followed
> > by upstream.
>
> Gentle ping!
I put the first 3 patches into an immutable branch off 4.17:
git://git.kernel.org/pub/scm/linux/kernel/git/dtor/input.git ib/4.17-bitmap
and queued it and the other 2 patches for the next merge window.
Thanks.
--
Dmitry
next prev parent reply other threads:[~2018-08-02 1:03 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-06-30 20:17 [PATCH v4 0/5] bitmap: Introduce alloc/free helpers Andy Shevchenko
2018-06-30 20:17 ` [PATCH v4 1/5] dm: Avoid namespace collision with bitmap API Andy Shevchenko
2018-07-02 19:11 ` Mike Snitzer
2018-06-30 20:17 ` [PATCH v4 2/5] md: " Andy Shevchenko
2018-07-02 16:57 ` Shaohua Li
2018-06-30 20:17 ` [PATCH v4 3/5] bitmap: Add bitmap_alloc(), bitmap_zalloc() and bitmap_free() Andy Shevchenko
2020-01-28 11:38 ` Naresh Kamboju
2020-01-28 11:44 ` Greg Kroah-Hartman
2018-06-30 20:17 ` [PATCH v4 4/5] Input: gpio-keys - Switch to bitmap_zalloc() Andy Shevchenko
2018-06-30 20:17 ` [PATCH v4 5/5] Input: evdev - Switch to bitmap API Andy Shevchenko
2018-07-04 21:30 ` [PATCH v4 0/5] bitmap: Introduce alloc/free helpers Andy Shevchenko
2018-07-24 11:35 ` Andy Shevchenko
2018-08-02 1:03 ` Dmitry Torokhov [this message]
2018-08-02 12:07 ` Andy Shevchenko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180802010325.GB184797@dtor-ws \
--to=dmitry.torokhov@gmail.com \
--cc=agk@redhat.com \
--cc=akpm@linux-foundation.org \
--cc=andriy.shevchenko@linux.intel.com \
--cc=andy.shevchenko@gmail.com \
--cc=dm-devel@redhat.com \
--cc=joe@perches.com \
--cc=linux-input@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-raid@vger.kernel.org \
--cc=mika.westerberg@linux.intel.com \
--cc=shli@kernel.org \
--cc=snitzer@redhat.com \
--cc=ynorov@caviumnetworks.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox