From: Jiri Kosina <jkosina@suse.cz>
To: Stefan Achatz <erazor_de@users.sourceforge.net>
Cc: Rob Landley <rob@landley.net>,
linux-input@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 3/4] HID: roccat: Renamed roccat_common functions to roccat_common2
Date: Fri, 8 Jun 2012 10:29:24 +0200 (CEST) [thread overview]
Message-ID: <alpine.LNX.2.00.1206081029180.12208@pobox.suse.cz> (raw)
In-Reply-To: <1337546704.19878.32.camel@neuromancer.tessier-ashpool>
On Sun, 20 May 2012, Stefan Achatz wrote:
> Did this to illustrate my understanding of the firmware generations:
> Valo and Kone were 1st generation
> Arvo was externaly developed and lies in the middle
> All others until now are considered 2nd generation
>
> Signed-off-by: Stefan Achatz <erazor_de@users.sourceforge.net>
> ---
> drivers/hid/hid-roccat-arvo.c | 16 ++++++++--------
> drivers/hid/hid-roccat-common.c | 34 +++++++++++++++++-----------------
> drivers/hid/hid-roccat-common.h | 10 +++++-----
> drivers/hid/hid-roccat-isku.c | 6 +++---
> drivers/hid/hid-roccat-koneplus.c | 24 ++++++++++++------------
> drivers/hid/hid-roccat-kovaplus.c | 20 ++++++++++----------
> drivers/hid/hid-roccat-pyra.c | 20 ++++++++++----------
> drivers/hid/hid-roccat-savu.c | 4 ++--
> 8 files changed, 67 insertions(+), 67 deletions(-)
>
> diff --git a/drivers/hid/hid-roccat-arvo.c b/drivers/hid/hid-roccat-arvo.c
> index 093bfad..327f9b8 100644
> --- a/drivers/hid/hid-roccat-arvo.c
> +++ b/drivers/hid/hid-roccat-arvo.c
> @@ -39,7 +39,7 @@ static ssize_t arvo_sysfs_show_mode_key(struct device *dev,
> int retval;
>
> mutex_lock(&arvo->arvo_lock);
> - retval = roccat_common_receive(usb_dev, ARVO_COMMAND_MODE_KEY,
> + retval = roccat_common2_receive(usb_dev, ARVO_COMMAND_MODE_KEY,
Could you please give it some more descriptive name, that will clearly
illustrate that the differentiating factor is the firmware
version/generation?
Thanks,
--
Jiri Kosina
SUSE Labs
prev parent reply other threads:[~2012-06-08 8:29 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-05-20 20:45 [PATCH 3/4] HID: roccat: Renamed roccat_common functions to roccat_common2 Stefan Achatz
2012-06-08 8:29 ` Jiri Kosina [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.LNX.2.00.1206081029180.12208@pobox.suse.cz \
--to=jkosina@suse.cz \
--cc=erazor_de@users.sourceforge.net \
--cc=linux-input@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rob@landley.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox