From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from sauhun.de ([88.99.104.3]:48592 "EHLO pokefinder.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932870AbeFRLyx (ORCPT ); Mon, 18 Jun 2018 07:54:53 -0400 Date: Mon, 18 Jun 2018 20:54:46 +0900 From: Wolfram Sang To: Peter Rosin Cc: linux-kernel@vger.kernel.org, Peter Huewe , Jarkko Sakkinen , Jason Gunthorpe , Arnd Bergmann , Greg Kroah-Hartman , Brian Norris , Gregory Fong , Florian Fainelli , bcm-kernel-feedback-list@broadcom.com, Sekhar Nori , Kevin Hilman , Haavard Skinnemoen , Kukjin Kim , Krzysztof Kozlowski , Orson Zhai , Baolin Wang , Chunyan Zhang , Laxman Dewangan , Thierry Reding , Jonathan Hunter , Guenter Roeck , Crt Mori , Jonathan Cameron , Hartmut Knaack , Lars-Peter Clausen , Peter Meerwald-Stadler , Dmitry Torokhov , Antti Palosaari , Mauro Carvalho Chehab , Michael Krufky , Lee Jones , linux-integrity@vger.kernel.org, linux-i2c@vger.kernel.org, linux-arm-kernel@lists.infradead.org, linux-samsung-soc@vger.kernel.org, linux-tegra@vger.kernel.org, linux-iio@vger.kernel.org, linux-input@vger.kernel.org, linux-media@vger.kernel.org Subject: Re: [PATCH 01/11] i2c: add helpers for locking the I2C segment Message-ID: <20180618115444.pgjmfntp767zuvmw@ninjato> References: <20180615101506.8012-1-peda@axentia.se> <20180615101506.8012-2-peda@axentia.se> <20180618110502.cb5s24srp4frahm6@ninjato> MIME-Version: 1.0 Content-Type: multipart/signed; micalg=pgp-sha256; protocol="application/pgp-signature"; boundary="odyilowjkqhfymya" In-Reply-To: Sender: linux-integrity-owner@vger.kernel.org List-ID: > > I wonder if i2c_lock_segment() and i2c_lock_root_adapter() are really > > more readable and convenient than i2c_lock_bus() with the flag. I think > > the flags have speaking names, too. > > > > Is that an idea to remove these functions altogether and start using > > i2c_lock_bus()? > > That would be fine with me. I don't have a strong opinion and agree that > both are readable enough... > > It would make for a reduction of the number of lines so that's nice, but > the macro in drivers/i2c/busses/i2c-gpio.c (patch 11) would not fit in > the current \-width (or whatever you'd call that line of backslashes to > the right in a multi-line macro). > > Does anyone have a strong opinion? I have a strong opinion on making i2c.h less bloated. And yes, less number of lines is nice, too. I think that surely pays off the whitespace exception. Thanks! [ Part 2, Application/PGP-SIGNATURE (Name: "signature.asc") 849 bytes. ] [ Unable to print this part. ]