Linux Integrity Measurement development
 help / color / mirror / Atom feed
From: Vlastimil Babka <vbabka@suse.cz>
To: Lorenzo Stoakes <lorenzo.stoakes@oracle.com>,
	Paul Moore <paul@paul-moore.com>
Cc: linux-security-module@vger.kernel.org,
	linux-integrity@vger.kernel.org, selinux@vger.kernel.org,
	john.johansen@canonical.com, zohar@linux.ibm.com,
	roberto.sassu@huawei.com, wufan@kernel.org, mic@digikod.net,
	gnoack@google.com, kees@kernel.org, mortonm@chromium.org,
	casey@schaufler-ca.com, penguin-kernel@i-love.sakura.ne.jp,
	nicolas.bouchinet@oss.cyber.gouv.fr, xiujianfeng@huawei.com,
	linux-mm <linux-mm@kvack.org>,
	David Hildenbrand <david@redhat.com>,
	"Liam R. Howlett" <Liam.Howlett@oracle.com>,
	Mike Rapoport <rppt@kernel.org>,
	Suren Baghdasaryan <surenb@google.com>,
	Michal Hocko <mhocko@suse.com>,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v5 10/11] lsm: consolidate all of the LSM framework initcalls
Date: Thu, 29 Jan 2026 18:02:00 +0100	[thread overview]
Message-ID: <74286aca-a565-489f-ad2c-886c650ea2bc@suse.cz> (raw)
In-Reply-To: <14638978-b133-457a-ae9c-31ba54e3964c@lucifer.local>

On 1/29/26 17:48, Lorenzo Stoakes wrote:
> On Thu, Jan 29, 2026 at 04:31:16PM +0000, Lorenzo Stoakes wrote:
> 
> Sorry to clarify here I meant to say - if I set CONFIG_SECURITY but _not_
> CONFIG_SECURITY_SELINUX the tunable does in fact still appear (and afaict
> still work...)
> 
> So LSM_MMAP_MIN_ADDR is really weird to require SECURITY_SELINUX, perhaps a
> historic artifact where we wanted a different default or something like
> this?
> 
> I know that we use that in preference to CONFIG_DEFAULT_MMAP_MIN_ADDR if
> specified.
> 
> The description really probably needs updating.
> 
> The key config here we should be looking at is DEFAULT_MMAP_MIN_ADDR which
> emphatically does _not_ require CONFIG_SECURITY and also in its description
> explicitly mentions the tunable:
> 
> 	  This value can be changed after boot using the
> 	  /proc/sys/vm/mmap_min_addr tunable.
> 
> The mmap_min_addr global value exposed in min_addr.c is referenced in
> several places in mm and other parts of the kernel - fs/exec.c,
> fs/userlandfd.c, kernel/sys.c, mm/mmap.c, mm/vma.c.
> 
> So this now silently going to zero everywhere and ignoring
> CONFIG_DEFAULT_MMAP_MIN_ADDR is surely a userspace-breaking regression and
> needs fixing in rc8?
> 
> Which means that... people can now mmap() at NULL everywhere despite setting
> CONFIG_DEFAULT_MMAP_MIN_ADDR > 0? :)
> 
> That seems like a _really bad idea_ (TM).
> 
> So this is emphatically not a report of a trivial self test break, but
> rather of something more serious AFAICT.
> 
> So yeah I think this has to be reverted/fixed.
Agreed, the mmap_min_addr should stay visible and applied unconditionally.
AFAICS the only relation to SECURITY/LSM is whether CONFIG_LSM_MMAP_MIN_ADDR
is used as an additional lower limit to both CONFIG_DEFAULT_MMAP_MIN_ADDR
and the sysctl-written value?

  reply	other threads:[~2026-01-29 17:02 UTC|newest]

Thread overview: 43+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-10-17 20:24 [PATCH v5 0/34] Rework the LSM initialization Paul Moore
2025-10-17 20:24 ` [PATCH v5 01/34] lsm: split the notifier code out into lsm_notifier.c Paul Moore
2025-10-17 20:24 ` [PATCH v5 02/34] lsm: split the init code out into lsm_init.c Paul Moore
2025-10-17 20:24 ` [PATCH v5 03/34] lsm: consolidate lsm_allowed() and prepare_lsm() into lsm_prepare() Paul Moore
2025-10-17 20:24 ` [PATCH v5 04/34] lsm: introduce looping macros for the initialization code Paul Moore
2025-10-17 20:24 ` [PATCH v5 05/34] lsm: integrate report_lsm_order() code into caller Paul Moore
2025-10-17 20:24 ` [PATCH v5 06/34] lsm: integrate lsm_early_cred() and lsm_early_task() " Paul Moore
2025-10-17 20:24 ` [PATCH v5 07/34] lsm: rename ordered_lsm_init() to lsm_init_ordered() Paul Moore
2025-10-17 20:24 ` [PATCH v5 08/34] lsm: replace the name field with a pointer to the lsm_id struct Paul Moore
2025-10-17 20:24 ` [PATCH v5 09/34] lsm: rename the lsm order variables for consistency Paul Moore
2025-10-17 20:24 ` [PATCH v5 10/34] lsm: rework lsm_active_cnt and lsm_idlist[] Paul Moore
2025-10-17 20:24 ` [PATCH v5 11/34] lsm: get rid of the lsm_names list and do some cleanup Paul Moore
2025-10-17 20:24 ` [PATCH v5 12/34] lsm: rework the LSM enable/disable setter/getter functions Paul Moore
2025-10-17 20:24 ` [PATCH v5 13/34] lsm: rename exists_ordered_lsm() to lsm_order_exists() Paul Moore
2025-10-17 20:24 ` [PATCH v5 14/34] lsm: rename/rework append_ordered_lsm() into lsm_order_append() Paul Moore
2025-10-17 20:24 ` [PATCH v5 15/34] lsm: rename/rework ordered_lsm_parse() to lsm_order_parse() Paul Moore
2025-10-17 20:24 ` [PATCH v5 16/34] lsm: cleanup the LSM blob size code Paul Moore
2025-10-17 20:24 ` [PATCH v5 17/34] lsm: cleanup initialize_lsm() and rename to lsm_init_single() Paul Moore
2025-10-17 20:24 ` [PATCH v5 18/34] lsm: fold lsm_init_ordered() into security_init() Paul Moore
2025-10-17 20:24 ` [PATCH v5 19/34] lsm: add/tweak function header comment blocks in lsm_init.c Paul Moore
2025-10-17 20:24 ` [PATCH v5 20/34] lsm: cleanup the debug and console output " Paul Moore
2025-10-17 20:24 ` [PATCH v5 21/34] lsm: output available LSMs when debugging Paul Moore
2025-10-17 20:24 ` [PATCH v5 22/34] lsm: group lsm_order_parse() with the other lsm_order_*() functions Paul Moore
2025-10-17 20:48 ` [PATCH v5 01/11] loadpin: move initcalls to the LSM framework Paul Moore
2025-10-17 20:48   ` [PATCH v5 02/11] ipe: " Paul Moore
2025-10-17 20:48   ` [PATCH v5 03/11] smack: " Paul Moore
2025-10-17 20:48   ` [PATCH v5 04/11] tomoyo: " Paul Moore
2025-10-17 20:48   ` [PATCH v5 05/11] safesetid: " Paul Moore
2025-10-17 20:48   ` [PATCH v5 06/11] apparmor: " Paul Moore
2025-10-17 20:48   ` [PATCH v5 07/11] lockdown: " Paul Moore
2025-10-17 20:48   ` [PATCH v5 08/11] ima,evm: " Paul Moore
2025-10-17 20:48   ` [PATCH v5 09/11] selinux: " Paul Moore
2025-10-17 20:48   ` [PATCH v5 10/11] lsm: consolidate all of the LSM framework initcalls Paul Moore
2026-01-29 16:31     ` Lorenzo Stoakes
2026-01-29 16:48       ` Lorenzo Stoakes
2026-01-29 17:02         ` Vlastimil Babka [this message]
2026-01-29 17:09           ` Lorenzo Stoakes
2026-01-29 18:31             ` Paul Moore
2026-01-29 18:58               ` Lorenzo Stoakes
2026-01-29 23:06                 ` Paul Moore
2025-10-17 20:48   ` [PATCH v5 11/11] lsm: add a LSM_STARTED_ALL notification event Paul Moore
2025-10-17 20:59 ` [PATCH v5 0/34] Rework the LSM initialization Paul Moore
2025-10-22 23:34 ` Paul Moore

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=74286aca-a565-489f-ad2c-886c650ea2bc@suse.cz \
    --to=vbabka@suse.cz \
    --cc=Liam.Howlett@oracle.com \
    --cc=casey@schaufler-ca.com \
    --cc=david@redhat.com \
    --cc=gnoack@google.com \
    --cc=john.johansen@canonical.com \
    --cc=kees@kernel.org \
    --cc=linux-integrity@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-security-module@vger.kernel.org \
    --cc=lorenzo.stoakes@oracle.com \
    --cc=mhocko@suse.com \
    --cc=mic@digikod.net \
    --cc=mortonm@chromium.org \
    --cc=nicolas.bouchinet@oss.cyber.gouv.fr \
    --cc=paul@paul-moore.com \
    --cc=penguin-kernel@i-love.sakura.ne.jp \
    --cc=roberto.sassu@huawei.com \
    --cc=rppt@kernel.org \
    --cc=selinux@vger.kernel.org \
    --cc=surenb@google.com \
    --cc=wufan@kernel.org \
    --cc=xiujianfeng@huawei.com \
    --cc=zohar@linux.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox