Linux IOMMU Development
 help / color / mirror / Atom feed
From: Jason Gunthorpe <jgg@nvidia.com>
To: "Tian, Kevin" <kevin.tian@intel.com>
Cc: Xu Yilun <yilun.xu@linux.intel.com>,
	"will@kernel.org" <will@kernel.org>,
	"aneesh.kumar@kernel.org" <aneesh.kumar@kernel.org>,
	"iommu@lists.linux.dev" <iommu@lists.linux.dev>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"joro@8bytes.org" <joro@8bytes.org>,
	"robin.murphy@arm.com" <robin.murphy@arm.com>,
	"shuah@kernel.org" <shuah@kernel.org>,
	"nicolinc@nvidia.com" <nicolinc@nvidia.com>,
	"aik@amd.com" <aik@amd.com>,
	"Williams, Dan J" <dan.j.williams@intel.com>,
	"baolu.lu@linux.intel.com" <baolu.lu@linux.intel.com>,
	"Xu, Yilun" <yilun.xu@intel.com>
Subject: Re: [PATCH v4 3/7] iommufd: Add a pre_destroy() op for objects
Date: Thu, 10 Jul 2025 14:15:15 -0300	[thread overview]
Message-ID: <20250710171515.GS1599700@nvidia.com> (raw)
In-Reply-To: <BN9PR11MB5276CA77E378CB3173CA76888C48A@BN9PR11MB5276.namprd11.prod.outlook.com>

On Thu, Jul 10, 2025 at 07:40:58AM +0000, Tian, Kevin wrote:
> > From: Xu Yilun <yilun.xu@linux.intel.com>
> > Sent: Wednesday, July 9, 2025 12:03 PM
> > 
> > Add a pre_destroy() op which gives objects a chance to clear their
> > short term users references before destruction. This op is intended for
> > external driver created objects (e.g. idev) which does deterministic
> > destruction.
> > 
> > In order to manage the lifecycle of interrelated objects as well as the
> > deterministic destruction (e.g. vdev can't outlive idev, and idev
> > destruction can't fail), short term users references are allowed to
> > live out of an ioctl execution. An immediate use case is, vdev holds
> > idev's short term user reference until vdev destruction completes, idev
> > leverages existing wait_shortterm mechanism to ensure it is destroyed
> > after vdev.
> > 
> > This extended usage makes the referenced object unable to just wait for
> > its reference gone. It needs to actively trigger the reference removal,
> > as well as prevent new references before wait. Should implement these
> > work in pre_destroy().
> > 
> > Suggested-by: Jason Gunthorpe <jgg@nvidia.com>
> > Signed-off-by: Xu Yilun <yilun.xu@linux.intel.com>
> 
> Reviewed-by: Kevin Tian <kevin.tian@intel.com>
> 
> btw is it clearer to rename 'shortterm_users' as 'wait_cnt', as the
> meaning now is beyond shortterm and is really about the need of
> waiting?

Probably so, as a followup change would be fine if we don't need a v5

/*
 * Destroy will sleep and wait for wait_cnt to go to zero. This
 * allows concurrent users of the ID to reliably avoid causing a
 * spurious destroy failure. Incrementing this count should either be
 * short lived or be revoked and blocked during pre_destroy
 */
refcount_t wait_cnt;

?

Jason

  reply	other threads:[~2025-07-10 17:15 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-07-09  4:02 [PATCH v4 0/7] iommufd: Destroy vdevice on device unbind Xu Yilun
2025-07-09  4:02 ` [PATCH v4 1/7] iommufd/viommu: Roll back to use iommufd_object_alloc() for vdevice Xu Yilun
2025-07-10  7:32   ` Tian, Kevin
2025-07-10 18:26   ` Nicolin Chen
2025-07-11 17:42   ` Jason Gunthorpe
2025-07-09  4:02 ` [PATCH v4 2/7] iommufd: Add iommufd_object_tombstone_user() helper Xu Yilun
2025-07-10  7:35   ` Tian, Kevin
2025-07-10 19:08   ` Nicolin Chen
2025-07-11 15:02     ` Xu Yilun
2025-07-11 19:39       ` Nicolin Chen
2025-07-11 21:33       ` Jason Gunthorpe
2025-07-11 22:04         ` Nicolin Chen
2025-07-11 17:44   ` Jason Gunthorpe
2025-07-09  4:02 ` [PATCH v4 3/7] iommufd: Add a pre_destroy() op for objects Xu Yilun
2025-07-10  7:40   ` Tian, Kevin
2025-07-10 17:15     ` Jason Gunthorpe [this message]
2025-07-11  3:16       ` Tian, Kevin
2025-07-11  9:38         ` Xu Yilun
2025-07-11 22:09   ` Nicolin Chen
2025-07-09  4:02 ` [PATCH v4 4/7] iommufd: Destroy vdevice on idevice destroy Xu Yilun
2025-07-10  8:03   ` Tian, Kevin
2025-07-12  2:22   ` Nicolin Chen
2025-07-12 17:47     ` Xu Yilun
2025-07-14 16:40       ` Xu Yilun
2025-07-14 16:53         ` Jason Gunthorpe
2025-07-14 17:34           ` Nicolin Chen
2025-07-14 18:03             ` Xu Yilun
2025-07-12  2:26   ` Nicolin Chen
2025-07-09  4:02 ` [PATCH v4 5/7] iommufd/vdevice: Remove struct device reference from struct vdevice Xu Yilun
2025-07-10  8:04   ` Tian, Kevin
2025-07-12  2:27   ` Nicolin Chen
2025-07-09  4:02 ` [PATCH v4 6/7] iommufd/selftest: Explicitly skip tests for inapplicable variant Xu Yilun
2025-07-10  8:06   ` Tian, Kevin
2025-07-12  2:39   ` Nicolin Chen
2025-07-09  4:02 ` [PATCH v4 7/7] iommufd/selftest: Add coverage for vdevice tombstone Xu Yilun
2025-07-10  8:10   ` Tian, Kevin
2025-07-10  9:25     ` Xu Yilun
2025-07-11  3:12       ` Tian, Kevin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250710171515.GS1599700@nvidia.com \
    --to=jgg@nvidia.com \
    --cc=aik@amd.com \
    --cc=aneesh.kumar@kernel.org \
    --cc=baolu.lu@linux.intel.com \
    --cc=dan.j.williams@intel.com \
    --cc=iommu@lists.linux.dev \
    --cc=joro@8bytes.org \
    --cc=kevin.tian@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=nicolinc@nvidia.com \
    --cc=robin.murphy@arm.com \
    --cc=shuah@kernel.org \
    --cc=will@kernel.org \
    --cc=yilun.xu@intel.com \
    --cc=yilun.xu@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox