From: "Suthikulpanit, Suravee" <suravee.suthikulpanit@amd.com>
To: Nicolin Chen <nicolinc@nvidia.com>
Cc: jgg@nvidia.com, linux-kernel@vger.kernel.org,
robin.murphy@arm.com, will@kernel.org, joro@8bytes.org,
kevin.tian@intel.com, jsnitsel@redhat.com, vasant.hegde@amd.com,
iommu@lists.linux.dev, santosh.shukla@amd.com,
sairaj.arunkodilkar@amd.com, jon.grimm@amd.com,
prashanthpra@google.com, wvw@google.com, wnliu@google.com,
gptran@google.com, kpsingh@google.com, joao.m.martins@oracle.com,
alejandro.j.jimenez@oracle.com
Subject: Re: [PATCH v5 05/14] iommu/amd: Introduce helper function amd_iommu_update_dte()
Date: Thu, 15 Jan 2026 16:20:08 +0700 [thread overview]
Message-ID: <8ab60419-5fbc-418e-a059-e28e6c0682b0@amd.com> (raw)
In-Reply-To: <aRYvFmHdUImiU0zA@Asurada-Nvidia>
On 11/14/2025 2:18 AM, Nicolin Chen wrote:
> On Wed, Nov 12, 2025 at 06:24:57PM +0000, Suravee Suthikulpanit wrote:
>> +void amd_iommu_update_dte(struct amd_iommu *iommu,
>> + struct iommu_dev_data *dev_data,
>> + struct dev_table_entry *new)
>> +{
>> + update_dte256(iommu, dev_data, new);
>> + clone_aliases(iommu, dev_data->dev);
>> + device_flush_dte(dev_data);
>> + iommu_completion_wait(iommu);
>> +}
>> +
>> static void get_dte256(struct amd_iommu *iommu, struct iommu_dev_data *dev_data,
>> struct dev_table_entry *dte)
>> {
>> @@ -2088,7 +2104,7 @@ static void set_dte_entry(struct amd_iommu *iommu,
>>
>> set_dte_gcr3_table(iommu, dev_data, &new);
>>
>> - update_dte256(iommu, dev_data, &new);
>> + amd_iommu_update_dte(iommu, dev_data, &new);
>>
>> /*
>> * A kdump kernel might be replacing a domain ID that was copied from
>> @@ -2108,7 +2124,7 @@ static void clear_dte_entry(struct amd_iommu *iommu, struct iommu_dev_data *dev_
>> struct dev_table_entry new = {};
>>
>> amd_iommu_make_clear_dte(dev_data, &new);
>> - update_dte256(iommu, dev_data, &new);
>> + amd_iommu_update_dte(iommu, dev_data, &new);
>> }
>>
>> /* Update and flush DTE for the given device */
>> @@ -2120,10 +2136,6 @@ static void dev_update_dte(struct iommu_dev_data *dev_data, bool set)
>> set_dte_entry(iommu, dev_data, 0, 0);
>> else
>> clear_dte_entry(iommu, dev_data);
>
> I found these two are somewhat unnecessary.
>
> set_dte_entry()
> {
> u32 old_domid;
>
> make_clear_dte(dev_data, dte, &new);
> ....
> amd_iommu_update_dte(iommu, dev_data, &new);
> if (old_domid)
> amd_iommu_flush_tlb_domid(iommu, old_domid);
> }
>
> clear_dte_entry()
> {
> make_clear_dte(dev_data, dte, &new);
> amd_iommu_update_dte(iommu, dev_data, &new);
> }
>
> And given that dev_update_dte() now are just calling these them
> without any other thing to do. Why not just unwrap them:
>
> dev_update_dte(struct iommu_dev_data *dev_data, bool set)
> {
> u32 old_domid = 0;
>
> make_clear_dte(dev_data, dte, &new);
> if (!set)
> goto update_dte;
> ....
> update_dte:
> amd_iommu_update_dte(iommu, dev_data, &new);
> if (old_domid)
> amd_iommu_flush_tlb_domid(iommu, old_domid);
> }
>
> ?
Currently, set_dte_entry() is called from multiple call-path. Therefore,
I would like to keep this way to simplify the code reuse. The
clear_dte_entry() is called only from one place, but I feel that having
a separate function is simpler to read.
Thanks,
Suravee
next prev parent reply other threads:[~2026-01-15 9:20 UTC|newest]
Thread overview: 39+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-11-12 18:24 [PATCH v5 00/14] iommu/amd: Introduce Nested Translation support Suravee Suthikulpanit
2025-11-12 18:24 ` [PATCH v5 01/14] iommu/amd: Rename DEV_DOMID_MASK to DTE_DOMID_MASK Suravee Suthikulpanit
2025-11-12 18:24 ` [PATCH v5 02/14] iommu/amd: Make amd_iommu_pdom_id_alloc() non-static Suravee Suthikulpanit
2025-11-12 18:24 ` [PATCH v5 03/14] iommu/amd: Make amd_iommu_pdom_id_free() non-static Suravee Suthikulpanit
2025-11-12 18:24 ` [PATCH v5 04/14] iommu/amd: Make amd_iommu_make_clear_dte() non-static inline Suravee Suthikulpanit
2025-11-18 23:44 ` Jason Gunthorpe
2025-11-12 18:24 ` [PATCH v5 05/14] iommu/amd: Introduce helper function amd_iommu_update_dte() Suravee Suthikulpanit
2025-11-13 19:18 ` Nicolin Chen
2026-01-15 9:20 ` Suthikulpanit, Suravee [this message]
2025-11-18 23:50 ` Jason Gunthorpe
2025-11-12 18:24 ` [PATCH v5 06/14] iommufd: Introduce data struct for AMD nested domain allocation Suravee Suthikulpanit
2025-11-12 18:24 ` [PATCH v5 07/14] iommu/amd: Always enable GCR3TRPMode when supported Suravee Suthikulpanit
2025-11-13 19:19 ` Nicolin Chen
2025-11-12 18:25 ` [PATCH v5 08/14] iommu/amd: Add support for nest parent domain allocation Suravee Suthikulpanit
2025-11-12 18:25 ` [PATCH v5 09/14] iommu/amd: Introduce struct amd_iommu_viommu Suravee Suthikulpanit
2025-11-13 19:21 ` Nicolin Chen
2025-11-12 18:25 ` [PATCH v5 10/14] iommu/amd: Add support for nested domain allocation Suravee Suthikulpanit
2025-11-12 18:25 ` [PATCH v5 11/14] iommu/amd: Introduce gDomID-to-hDomID Mapping and handle parent domain invalidation Suravee Suthikulpanit
2025-11-13 20:36 ` Nicolin Chen
2025-11-19 0:02 ` Jason Gunthorpe
2026-01-15 9:25 ` Suthikulpanit, Suravee
2026-01-15 9:21 ` Suthikulpanit, Suravee
2025-11-19 0:11 ` Jason Gunthorpe
2025-11-19 1:10 ` Nicolin Chen
2025-11-12 18:25 ` [PATCH v5 12/14] iommu/amd: Refactor persistent DTE bits programming into amd_iommu_make_clear_dte() Suravee Suthikulpanit
2025-11-13 20:42 ` Nicolin Chen
2025-11-12 18:25 ` [PATCH v5 13/14] iommu/amd: Refactor logic to program the host page table in DTE Suravee Suthikulpanit
2025-11-13 21:19 ` Nicolin Chen
2025-11-13 21:29 ` Nicolin Chen
2025-11-19 0:21 ` Jason Gunthorpe
2025-11-19 0:20 ` Jason Gunthorpe
2026-01-15 9:24 ` Suthikulpanit, Suravee
2025-11-19 0:18 ` Jason Gunthorpe
2025-11-12 18:25 ` [PATCH v5 14/14] iommu/amd: Add support for nested domain attach/detach Suravee Suthikulpanit
2025-11-13 21:34 ` Nicolin Chen
2025-11-19 0:28 ` Jason Gunthorpe
2025-11-13 21:52 ` [PATCH v5 00/14] iommu/amd: Introduce Nested Translation support Nicolin Chen
2025-11-17 17:54 ` Jason Gunthorpe
2026-01-15 9:18 ` Suthikulpanit, Suravee
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=8ab60419-5fbc-418e-a059-e28e6c0682b0@amd.com \
--to=suravee.suthikulpanit@amd.com \
--cc=alejandro.j.jimenez@oracle.com \
--cc=gptran@google.com \
--cc=iommu@lists.linux.dev \
--cc=jgg@nvidia.com \
--cc=joao.m.martins@oracle.com \
--cc=jon.grimm@amd.com \
--cc=joro@8bytes.org \
--cc=jsnitsel@redhat.com \
--cc=kevin.tian@intel.com \
--cc=kpsingh@google.com \
--cc=linux-kernel@vger.kernel.org \
--cc=nicolinc@nvidia.com \
--cc=prashanthpra@google.com \
--cc=robin.murphy@arm.com \
--cc=sairaj.arunkodilkar@amd.com \
--cc=santosh.shukla@amd.com \
--cc=vasant.hegde@amd.com \
--cc=will@kernel.org \
--cc=wnliu@google.com \
--cc=wvw@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox