Linux IOMMU Development
 help / color / mirror / Atom feed
 messages from 2017-12-29 08:18:27 to 2018-01-10 15:22:15 UTC [more...]

consolidate direct dma mapping V3
 2018-01-10 15:22 UTC  (43+ messages)
` [PATCH 02/33] hexagon: remove unused flush_write_buffers definition
` [PATCH 05/33] arc: remove CONFIG_ARC_PLAT_NEEDS_PHYS_TO_DMA
` [PATCH 06/33] m32r: remove the unused dma_capable helper
` [PATCH 09/33] dma-mapping: take dma_pfn_offset into account in dma_max_pfn
` [PATCH 12/33] dma-mapping: move dma_mark_clean to dma-direct.h
` [PATCH 13/33] hexagon: use the generic dma_capable helper
  ` [PATCH 01/33] alpha: mark jensen as broken
  ` [PATCH 03/33] m32r: remove unused flush_write_buffers definition
  ` [PATCH 04/33] powerpc: "
  ` [PATCH 07/33] riscv: remove the unused dma_capable helper
  ` [PATCH 08/33] s390: "
  ` [PATCH 10/33] arm64: don't override dma_max_pfn
  ` [PATCH 11/33] dma-mapping: move swiotlb arch helpers to a new header
  ` [PATCH 14/33] powerpc: rename dma_direct_ to dma_nommu_
  ` [PATCH 15/33] microblaze: rename dma_direct to dma_nommu
  ` [PATCH 16/33] microblaze: remove dma_nommu_dma_supported
  ` [PATCH 18/33] s390: move s390_pci_dma_ops to asm/pci_dma.h
  ` [PATCH 19/33] dma-mapping: warn when there is no coherent_dma_mask
  ` [PATCH 20/33] dma-mapping: clear harmful GFP_* flags in common code
  ` [PATCH 27/33] dma-direct: use node local allocations for coherent memory
` [PATCH 17/33] microblaze: remove the dead !NOT_COHERENT_CACHE dma code
` [PATCH 21/33] dma-mapping: add an arch_dma_supported hook
` [PATCH 22/33] dma-mapping: provide a generic asm/dma-mapping.h
` [PATCH 23/33] dma-direct: rename dma_noop to dma_direct
` [PATCH 24/33] dma-direct: use phys_to_dma
` [PATCH 25/33] dma-direct: add dma address sanity checks
` [PATCH 26/33] dma-direct: add support for CMA allocation
` [PATCH 28/33] dma-direct: add support for allocation from ZONE_DMA and ZONE_DMA32
` [PATCH 29/33] dma-direct: retry allocations using GFP_DMA for small masks
` [PATCH 30/33] dma-direct: make dma_direct_{alloc,free} available to other implementations
` [PATCH 31/33] dma-direct: reject too small dma masks
` [PATCH 32/33] cris: use dma-direct
` [PATCH 33/33] h8300: "

[PATCH v6 0/5] Add Intel IOMMU debugfs support
 2018-01-10 13:46 UTC  (11+ messages)
  ` [PATCH v6 1/5] iommu/vt-d: Add debugfs support for Intel IOMMU internals
  ` [PATCH v6 2/5] iommu/vt-d: Add debugfs support to show context internals
  ` [PATCH v6 3/5] iommu/vt-d: Add debugfs support to show register contents
  ` [PATCH v6 4/5] iommu/vt-d: Add debugfs support to show Pasid table contents
  ` [PATCH v6 5/5] iommu/vt-d: Add debugfs support for Interrupt remapping

consolidate swiotlb dma_map implementations
 2018-01-10 13:16 UTC  (29+ messages)
` [PATCH 01/22] swiotlb: suppress warning when __GFP_NOWARN is set
` [PATCH 02/22] arm64: rename swiotlb_dma_ops
` [PATCH 03/22] ia64: "
` [PATCH 04/22] powerpc: "
` [PATCH 05/22] x86: "
` [PATCH 06/22] swiotlb: rename swiotlb_free to swiotlb_exit
` [PATCH 07/22] swiotlb: add common swiotlb_map_ops
` [PATCH 08/22] swiotlb: wire up ->dma_supported in swiotlb_dma_ops
` [PATCH 09/22] swiotlb: refactor coherent buffer freeing
` [PATCH 10/22] swiotlb: refactor coherent buffer allocation
` [PATCH 11/22] swiotlb: remove various exports
` [PATCH 12/22] ia64: replace ZONE_DMA with ZONE_DMA32
` [PATCH 13/22] ia64: use generic swiotlb_ops
` [PATCH 14/22] ia64: clean up swiotlb support
` [PATCH 15/22] ia64: remove an ifdef around the content of pci-dma.c
` [PATCH 16/22] unicore32: use generic swiotlb_ops
` [PATCH 17/22] tile: replace ZONE_DMA with ZONE_DMA32
` [PATCH 18/22] tile: use generic swiotlb_ops
` [PATCH 19/22] mips/netlogic: remove swiotlb support
` [PATCH 20/22] mips: use swiotlb_{alloc,free}
` [PATCH 21/22] arm64: replace ZONE_DMA with ZONE_DMA32
` [PATCH 22/22] arm64: use swiotlb_alloc and swiotlb_free

[PATCH v3 00/16] [PATCH v3 00/16] IOMMU driver support for SVM virtualization
 2018-01-10 12:39 UTC  (9+ messages)
` [PATCH v3 03/16] iommu: introduce iommu invalidate API function
` [PATCH v3 08/16] iommu: introduce device fault data
` [PATCH v3 10/16] iommu: introduce device fault report API

[PATCH v2] iommu/exynos: Don't unconditionally steal bus ops
 2018-01-10  6:27 UTC  (2+ messages)

[PATCH] iommu/vt-d: use domain instead of cache fetching
 2018-01-10  5:51 UTC 

[PATCH] iommu: Check the result of iommu_group_get() for NULL
 2018-01-09 17:15 UTC  (2+ messages)

[PATCH v2 1/3] iommu/msm: Claim bus ops on probe
 2018-01-09 16:17 UTC  (3+ messages)
` [PATCH v2 2/3] iommu/ipmmu-vmsa: Remove redundant of_iommu_init_fn hook
  ` [PATCH v2 3/3] iommu: Clean up of_iommu_init_fn

consolidate direct dma mapping and swiotlb support
 2018-01-09 15:55 UTC  (82+ messages)
` [PATCH 02/67] alpha: mark jensen as broken
` [PATCH 05/67] dma-mapping: replace PCI_DMA_BUS_IS_PHYS with a flag in struct dma_map_ops
` [PATCH 06/67] hexagon: remove unused flush_write_buffers definition
` [PATCH 09/67] arc: remove CONFIG_ARC_PLAT_NEEDS_PHYS_TO_DMA
` [PATCH 16/67] powerpc: rename dma_direct_ to dma_nommu_
` [PATCH 17/67] microblaze: rename dma_direct to dma_microblaze
` [PATCH 22/67] dma-mapping: clear harmful GFP_* flags in common code
` [PATCH 24/67] dma-mapping: provide a generic asm/dma-mapping.h
` [PATCH 28/67] dma-direct: add support for CMA allocation
` [PATCH 29/67] dma-direct: use node local allocations for coherent memory
` [PATCH 30/67] dma-direct: retry allocations using GFP_DMA for small masks
` [PATCH 31/67] dma-direct: make dma_direct_{alloc,free} available to other implementations
  ` [PATCH 31/67] dma-direct: make dma_direct_{alloc, free} "
` [PATCH 32/67] dma-direct: add support for allocation from ZONE_DMA and ZONE_DMA32
` [PATCH 33/67] dma-direct: reject too small dma masks
` [PATCH 34/67] cris: use dma-direct
` [PATCH 35/67] h8300: "
` [PATCH 36/67] x86: remove dma_alloc_coherent_mask
` [PATCH 37/67] x86: use dma-direct
` [PATCH 38/67] x86/amd_gart: clean up gart_alloc_coherent
` [PATCH 39/67] iommu/amd_iommu: use dma_direct_* helpers for the direct mapping case
` [PATCH 40/67] iommu/intel-iommu: "
` [PATCH 41/67] x86: remove dma_alloc_coherent_gfp_flags
` [PATCH 42/67] arm64: rename swiotlb_dma_ops
` [PATCH 43/67] ia64: "
` [PATCH 44/67] powerpc: "
` [PATCH 45/67] swiotlb: rename swiotlb_free to swiotlb_exit
` [PATCH 46/67] swiotlb: lift x86 swiotlb_dma_ops to common code
` [PATCH 47/67] swiotlb: wire up ->dma_supported in swiotlb_dma_ops
` [PATCH 48/67] swiotlb: rely on dev->coherent_dma_mask
` [PATCH 49/67] swiotlb: refactor coherent buffer freeing
` [PATCH 50/67] swiotlb: refactor coherent buffer allocation
` [PATCH 51/67] set_memory.h: provide set_memory_{en,de}crypted stubs
` [PATCH 52/67] dma-direct: handle the memory encryption bit in common code
` [PATCH 53/67] swiotlb: remove swiotlb_set_mem_attributes
` [PATCH 54/67] x86: remove sta2x11_dma_ops
` [PATCH 55/67] ia64: replace ZONE_DMA with ZONE_DMA32
` [PATCH 56/67] ia64: use generic swiotlb_ops
` [PATCH 57/67] ia64: clean up swiotlb support
` [PATCH 58/67] ia64: remove an ifdef around the content of pci-dma.c
` [PATCH 60/67] tile: replace ZONE_DMA with ZONE_DMA32
` [PATCH 61/67] tile: use generic swiotlb_ops
` [PATCH 62/67] mips/netlogic: remove swiotlb support
` [PATCH 63/67] mips: use swiotlb_{alloc,free}
` [PATCH 64/67] arm64: replace ZONE_DMA with ZONE_DMA32
` [PATCH 65/67] arm64: use swiotlb_alloc and swiotlb_free
  ` [PATCH 23/67] dma-mapping: add an arch_dma_supported hook
  ` [PATCH 25/67] dma-direct: rename dma_noop to dma_direct
  ` [PATCH 26/67] dma-direct: use phys_to_dma
  ` [PATCH 27/67] dma-direct: add dma address sanity checks
  ` [PATCH 59/67] unicore32: use generic swiotlb_ops
  ` [PATCH 66/67] swiotlb: remove swiotlb_{alloc,free}_coherent
` [PATCH 67/67] swiotlb: remove various exports

[PATCH] iommu/exynos: Don't unconditionally steal bus ops
 2018-01-09 11:58 UTC  (3+ messages)

[PATCH v5 0/6] iommu/arm-smmu: Add runtime pm/sleep support
 2018-01-09 11:49 UTC  (9+ messages)
  ` [PATCH v5 1/6] base: power: runtime: Export pm_runtime_get/put_suppliers
  ` [PATCH v5 2/6] iommu/arm-smmu: Add pm_runtime/sleep ops
  ` [PATCH v5 3/6] iommu/arm-smmu: Invoke pm_runtime during probe, add/remove device
  ` [PATCH v5 5/6] iommu/arm-smmu: Add support for qcom,smmu-v2 variant
  ` [PATCH v5 6/6] drm/msm: iommu: Replace runtime calls with runtime suppliers
` [PATCH v5 4/6] iommu/arm-smmu: Add the device_link between masters and smmu

[PATCH 1/2] iommu/msm: Claim bus ops on probe
 2018-01-09  6:19 UTC  (4+ messages)
  ` [PATCH 2/2] iommu: Clean up of_iommu_init_fn

[RFC PATCH v2 0/2] Reduce IOTLB flush when pass-through dGPU devices
 2018-01-08 21:07 UTC  (4+ messages)
` [RFC PATCH v2 1/2] vfio/type1: Adopt fast IOTLB flush interface when unmap IOVAs

[PATCH] iommu/of: Only do IOMMU lookup for available ones
 2018-01-08 11:45 UTC  (2+ messages)

[GIT PULL] IOMMU fixes for v4.15-rc7
 2018-01-05 22:09 UTC 

[GIT PULL] iommu/arm-smmu: Fixes for 4.15
 2018-01-05 12:10 UTC 

[PATCH V4 11/26] iommu/amd: deprecate pci_get_bus_and_slot()
 2018-01-04 17:25 UTC  (5+ messages)

[PATCH v5 0/5] Add Intel IOMMU debugfs support
 2018-01-02 21:01 UTC  (4+ messages)
` [PATCH v5 2/5] iommu/vt-d: Add debugfs support to show context internals

[PATCH] iommu/arm-smmu-v3: Cope with duplicated Stream IDs
 2018-01-02 18:42 UTC  (4+ messages)

[PATCH] iommu/omap: Fix debugfs_create_*() usage
 2018-01-02 15:29 UTC 

[PATCH] iommu: Place spaces after if for coding style
 2017-12-29 18:36 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox