messages from 2025-03-19 19:52:28 to 2025-03-21 19:40:23 UTC [more...]
[PATCH v14 00/11] rust: add dma coherent allocator abstraction
2025-03-21 19:40 UTC (4+ messages)
` [PATCH v14 02/11] "
[PATCH v11 00/18] iommufd support pasid attach/replace
2025-03-21 19:24 UTC (21+ messages)
` [PATCH v11 01/18] iommu: Require passing new handles to APIs supporting handle
` [PATCH v11 02/18] iommu: Introduce a replace API for device pasid
` [PATCH v11 03/18] iommufd: Pass @pasid through the device attach/replace path
` [PATCH v11 04/18] iommufd/device: Only add reserved_iova in non-pasid path
` [PATCH v11 05/18] iommufd/device: Replace idev->igroup with local variable
` [PATCH v11 06/18] iommufd/device: Add helper to detect the first attach of a group
` [PATCH v11 07/18] iommufd/device: Wrap igroup->hwpt and igroup->device_list into attach struct
` [PATCH v11 08/18] iommufd/device: Replace device_list with device_array
` [PATCH v11 09/18] iommufd/device: Add pasid_attach array to track per-PASID attach
` [PATCH v11 10/18] iommufd: Enforce PASID-compatible domain in PASID path
` [PATCH v11 11/18] iommufd: Support pasid attach/replace
` [PATCH v11 12/18] iommufd: Enforce PASID-compatible domain for RID
` [PATCH v11 13/18] iommu/vt-d: Add IOMMU_HWPT_ALLOC_PASID support
` [PATCH v11 14/18] iommufd: Allow allocating PASID-compatible domain
` [PATCH v11 15/18] iommufd/selftest: Add set_dev_pasid in mock iommu
` [PATCH v11 16/18] iommufd/selftest: Add a helper to get test device
` [PATCH v11 17/18] iommufd/selftest: Add test ops to test pasid attach/detach
` [PATCH v11 18/18] iommufd/selftest: Add coverage for iommufd "
[PATCH v13 0/7] rust: add dma coherent allocator abstraction
2025-03-21 19:16 UTC (6+ messages)
` [PATCH v13 2/7] "
[RFC PATCH 0/5] iommu/arm-smmu-v3: Implement Runtime/System Sleep ops
2025-03-21 17:35 UTC (35+ messages)
` [RFC PATCH 1/5] iommu/arm-smmu-v3: Refactor arm_smmu_setup_irqs
` [RFC PATCH 2/5] iommu/arm-smmu-v3: Add a helper to wait till cmdq drains
` [RFC PATCH 3/5] iommu/arm-smmu-v3: Implement pm_runtime & system sleep ops
` [RFC PATCH 4/5] iommu/arm-smmu-v3: Enable pm_runtime and setup devlinks
` [RFC PATCH 5/5] iommu/arm-smmu-v3: Invoke pm_runtime before hw access
[PATCH v10 00/18] iommufd support pasid attach/replace
2025-03-21 17:25 UTC (78+ messages)
` [PATCH v10 01/18] iommu: Require passing new handles to APIs supporting handle
` [PATCH v10 02/18] iommu: Introduce a replace API for device pasid
` [PATCH v10 03/18] iommufd: Pass @pasid through the device attach/replace path
` [PATCH v10 04/18] iommufd/device: Only add reserved_iova in non-pasid path
` [PATCH v10 05/18] iommufd/device: Replace idev->igroup with local variable
` [PATCH v10 06/18] iommufd/device: Add helper to detect the first attach of a group
` [PATCH v10 07/18] iommufd/device: Wrap igroup->hwpt and igroup->device_list into attach struct
` [PATCH v10 08/18] iommufd/device: Replace device_list with device_array
` [PATCH v10 09/18] iommufd/device: Add pasid_attach array to track per-PASID attach
` [PATCH v10 10/18] iommufd: Enforce PASID-compatible domain in PASID path
` [PATCH v10 11/18] iommufd: Support pasid attach/replace
` [PATCH v10 12/18] iommufd: Enforce PASID-compatible domain for RID
` [PATCH v10 13/18] iommu/vt-d: Add IOMMU_HWPT_ALLOC_PASID support
` [PATCH v10 14/18] iommufd: Allow allocating PASID-compatible domain
` [PATCH v10 15/18] iommufd/selftest: Add set_dev_pasid in mock iommu
` [PATCH v10 16/18] iommufd/selftest: Add a helper to get test device
` [PATCH v10 17/18] iommufd/selftest: Add test ops to test pasid attach/detach
` [PATCH v10 18/18] iommufd/selftest: Add coverage for iommufd "
[PATCH v2 0/4] iommu: Fix the longstanding probe issues
2025-03-21 16:48 UTC (11+ messages)
` [PATCH v2 4/4] iommu: Get DT/ACPI parsing into the proper probe path
[RFC 0/3] Guaranteed CMA
2025-03-21 16:14 UTC (10+ messages)
` [RFC 1/3] mm: implement cleancache
` [RFC 2/3] mm: introduce GCMA
` [RFC 3/3] mm: integrate GCMA with CMA using dt-bindings
[PATCH v7 00/17] Provide a new two step DMA mapping API
2025-03-21 16:05 UTC (11+ messages)
[PATCH] iommu: Split out and tidy up Arm Kconfig
2025-03-21 11:35 UTC (3+ messages)
[PATCH] iommu/virtio: Make instance lookup robust
2025-03-21 10:10 UTC (2+ messages)
[PATCH v15 00/11] rust: add dma coherent allocator abstraction
2025-03-21 6:56 UTC (6+ messages)
` [PATCH v15 02/11] "
[PATCHv2 0/6] make vendor specific subdirectory inclusion conditional
2025-03-21 2:14 UTC (13+ messages)
` [PATCH 1/6] iommu: remove duplicate selection of DMAR_TABLE
` [PATCH 2/6] iommu: make inclusion of intel directory conditional
` [PATCH 3/6] iommu: make inclusion of amd "
` [PATCH 4/6] iommu: make inclusion of riscv "
` [PATCH 5/6] iommu: make inclusion of arm/arm-smmu-v3 "
` [PATCH 6/6] iommu: make inclusion of iommufd "
[GIT PULL] dma-mapping fix for Linux 6.14
2025-03-20 23:59 UTC (2+ messages)
[PATCH v4 0/3] iommu: Clean up cookie and sw_msi in struct iommu_domain
2025-03-20 23:16 UTC (2+ messages)
[PATCH] iommu: Avoid introducing more races
2025-03-20 19:42 UTC (2+ messages)
[PATCH v4 0/3] Initial BBML2 support for contpte_convert()
2025-03-20 17:13 UTC (9+ messages)
` [PATCH v4 1/3] arm64: Add BBM Level 2 cpu feature
[PATCH] iommu/ipmmu-vmsa: Register in a sensible order
2025-03-20 14:41 UTC
[PATCH net-next 3/3] page_pool: Track DMA-mapped pages and unmap them when destroying the pool
2025-03-20 14:37 UTC (10+ messages)
[PATCH v2] PCI: Declare quirk_huawei_pcie_sva() as pci_fixup_header
2025-03-20 14:07 UTC (3+ messages)
` [PATCH v3] "
[RFC PATCH v3 0/5] iommu/arm-smmu-v3: Use pinned KVM VMID for stage 2
2025-03-20 12:27 UTC (9+ messages)
` [RFC PATCH v3 2/5] iommufd/device: Associate a kvm pointer to iommufd_device
` [RFC PATCH v3 3/5] iommu/arm-smmu-v3-iommufd: Pass in kvm pointer to viommu_alloc
` [RFC PATCH v3 4/5] iommu/arm-smmu-v3-iommufd: Use KVM VMID for s2 stage
[PATCH 0/3] Add mt8196 SMI support
2025-03-20 12:11 UTC (5+ messages)
` [PATCH 1/3] dt-bindings: memory: mediatek: Add mt8196 support
` [PATCH 2/3] memory: mtk-smi: Add a flag skip_rpm
` [PATCH 3/3] memory: mtk-smi: mt8196: Add smi support
[PATCH 0/2] iommu/amd: two tiny cleanups
2025-03-20 8:53 UTC (4+ messages)
` [PATCH 2/2] iommu/amd: Return a literal in init_gcr3_table()
[PATCH 0/4] make vendor specific subdirectory inclusion conditional
2025-03-20 8:15 UTC (5+ messages)
` [PATCH 4/4] iommu: make inclusion of riscv directory conditional
[PATCH 0/3] [PULL REQUEST] iommu/vt-d: Fixes for v6.15-rc1
2025-03-20 8:04 UTC (2+ messages)
[PATCH 0/3] Rockchip IOMMU fixes
2025-03-20 7:58 UTC (2+ messages)
[PATCH] iommu/amd: Add Secure ATS support
2025-03-19 19:52 UTC (11+ messages)
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox