messages from 2025-03-20 17:51:13 to 2025-03-26 20:13:05 UTC [more...]
[PATCH 0/3] Additional fixes for dma coherent allocator
2025-03-26 20:11 UTC (2+ messages)
` [PATCH 1/3] rust: dma: be consistent in using the `coherent` nomenclature
[RFC PATCH 0/5] iommu/arm-smmu-v3: Implement Runtime/System Sleep ops
2025-03-26 20:10 UTC (39+ messages)
` [RFC PATCH 1/5] iommu/arm-smmu-v3: Refactor arm_smmu_setup_irqs
` [RFC PATCH 2/5] iommu/arm-smmu-v3: Add a helper to wait till cmdq drains
` [RFC PATCH 3/5] iommu/arm-smmu-v3: Implement pm_runtime & system sleep ops
` [RFC PATCH 4/5] iommu/arm-smmu-v3: Enable pm_runtime and setup devlinks
` [RFC PATCH 5/5] iommu/arm-smmu-v3: Invoke pm_runtime before hw access
Unpatched return thunk in use. This should not happen!
2025-03-26 16:25 UTC
[git pull] IOMMU Updates for Linux v6.15
2025-03-26 14:56 UTC
Regression on linux-next (next-20250321)
2025-03-26 8:31 UTC (4+ messages)
[RFC PATCH v2 05/22] crypto: ccp: Enable SEV-TIO feature in the PSP when supported
2025-03-26 4:26 UTC (3+ messages)
[PATCH] iommu: riscv: Split 8-byte accesses on 32 bit I/O bus platform
2025-03-26 3:26 UTC (3+ messages)
` [External] "
[PATCH v2 0/4] iommu: Fix the longstanding probe issues
2025-03-25 15:32 UTC (14+ messages)
` [PATCH v2 4/4] iommu: Get DT/ACPI parsing into the proper probe path
[PATCH] iommu/ipmmu-vmsa: Register in a sensible order
2025-03-25 15:26 UTC (2+ messages)
[PATCH v7 00/17] Provide a new two step DMA mapping API
2025-03-25 14:41 UTC (14+ messages)
[PATCH 0/2] Two fixes to vevent path
2025-03-25 13:35 UTC (6+ messages)
` [PATCH 1/2] iommufd: Initialize the flags of vevent in iommufd_viommu_report_event()
` [PATCH 2/2] iommufd: Balance veventq->num_events inc/dec
[PATCH v11 00/18] iommufd support pasid attach/replace
2025-03-25 13:24 UTC (22+ messages)
` [PATCH v11 01/18] iommu: Require passing new handles to APIs supporting handle
` [PATCH v11 02/18] iommu: Introduce a replace API for device pasid
` [PATCH v11 03/18] iommufd: Pass @pasid through the device attach/replace path
` [PATCH v11 04/18] iommufd/device: Only add reserved_iova in non-pasid path
` [PATCH v11 05/18] iommufd/device: Replace idev->igroup with local variable
` [PATCH v11 06/18] iommufd/device: Add helper to detect the first attach of a group
` [PATCH v11 07/18] iommufd/device: Wrap igroup->hwpt and igroup->device_list into attach struct
` [PATCH v11 08/18] iommufd/device: Replace device_list with device_array
` [PATCH v11 09/18] iommufd/device: Add pasid_attach array to track per-PASID attach
` [PATCH v11 10/18] iommufd: Enforce PASID-compatible domain in PASID path
` [PATCH v11 11/18] iommufd: Support pasid attach/replace
` [PATCH v11 12/18] iommufd: Enforce PASID-compatible domain for RID
` [PATCH v11 13/18] iommu/vt-d: Add IOMMU_HWPT_ALLOC_PASID support
` [PATCH v11 14/18] iommufd: Allow allocating PASID-compatible domain
` [PATCH v11 15/18] iommufd/selftest: Add set_dev_pasid in mock iommu
` [PATCH v11 16/18] iommufd/selftest: Add a helper to get test device
` [PATCH v11 17/18] iommufd/selftest: Add test ops to test pasid attach/detach
` [PATCH v11 18/18] iommufd/selftest: Add coverage for iommufd "
[PATCH v5 0/3] iommu: Clean up cookie and sw_msi in struct iommu_domain
2025-03-25 13:21 UTC (7+ messages)
` [PATCH v5 1/3] iommu: Sort out domain user data
` [PATCH v5 2/3] iommufd: Move iommufd_sw_msi and related functions to driver.c
` [PATCH v5 3/3] iommu: Drop sw_msi from iommu_domain
[PATCH v5 0/3] Initial BBML2 support for contpte_convert()
2025-03-25 11:06 UTC (5+ messages)
` [PATCH v5 1/3] arm64: Add BBM Level 2 cpu feature
` [PATCH v5 2/3] iommu/arm: Add BBM Level 2 smmu feature
` [PATCH v5 3/3] arm64/mm: Elide tlbi in contpte_convert() under BBML2
[PATCH] iommu/amd: Fix potential buffer overflow in parse_ivrs_acpihid
2025-03-25 9:22 UTC
[PATCH v4 0/3] iommu: Clean up cookie and sw_msi in struct iommu_domain
2025-03-24 22:45 UTC (13+ messages)
` [PATCH v4 3/3] iommu: Drop sw_msi from iommu_domain
[PATCH 1/2] iommufd: import IOMMUFD_INTERNAL namespace
2025-03-24 22:37 UTC (4+ messages)
` [PATCH 2/2] iommufd_driver: make IOMMUFD_DRIVER_CORE a 'bool' symbol
[PATCH] dt-bindings: iommu: Correct indentation and style in DTS example
2025-03-24 20:28 UTC (4+ messages)
NFS Server Issues with RDMA in Kernel 6.13.6
2025-03-24 18:35 UTC (2+ messages)
[PATCH] iommu/rockchip: Add flush_iotlb_all ops
2025-03-24 14:32 UTC (3+ messages)
[RFC PATCH v2 09/22] crypto/ccp: Implement SEV TIO firmware interface
2025-03-23 11:35 UTC (2+ messages)
[PATCH 1/1] Kernel:dma: fixed whitespace error
2025-03-23 8:46 UTC
[PATCH v15 00/11] rust: add dma coherent allocator abstraction
2025-03-22 22:58 UTC (7+ messages)
` [PATCH v15 02/11] "
Regression on drm-tip
2025-03-22 20:59 UTC (9+ messages)
[PATCH 0/3] Add mt8196 SMI support
2025-03-21 21:50 UTC (3+ messages)
` [PATCH 1/3] dt-bindings: memory: mediatek: Add mt8196 support
[PATCH] iommu/vt-d: Wire up irq_ack() to irq_move_irq() for posted MSIs
2025-03-21 20:43 UTC (2+ messages)
[PATCH v14 00/11] rust: add dma coherent allocator abstraction
2025-03-21 20:35 UTC (5+ messages)
` [PATCH v14 02/11] "
[PATCH v13 0/7] rust: add dma coherent allocator abstraction
2025-03-21 19:16 UTC (6+ messages)
` [PATCH v13 2/7] "
[PATCH v10 00/18] iommufd support pasid attach/replace
2025-03-21 17:25 UTC (70+ messages)
` [PATCH v10 01/18] iommu: Require passing new handles to APIs supporting handle
` [PATCH v10 02/18] iommu: Introduce a replace API for device pasid
` [PATCH v10 03/18] iommufd: Pass @pasid through the device attach/replace path
` [PATCH v10 04/18] iommufd/device: Only add reserved_iova in non-pasid path
` [PATCH v10 05/18] iommufd/device: Replace idev->igroup with local variable
` [PATCH v10 06/18] iommufd/device: Add helper to detect the first attach of a group
` [PATCH v10 07/18] iommufd/device: Wrap igroup->hwpt and igroup->device_list into attach struct
` [PATCH v10 08/18] iommufd/device: Replace device_list with device_array
` [PATCH v10 09/18] iommufd/device: Add pasid_attach array to track per-PASID attach
` [PATCH v10 11/18] iommufd: Support pasid attach/replace
` [PATCH v10 12/18] iommufd: Enforce PASID-compatible domain for RID
` [PATCH v10 14/18] iommufd: Allow allocating PASID-compatible domain
` [PATCH v10 15/18] iommufd/selftest: Add set_dev_pasid in mock iommu
` [PATCH v10 17/18] iommufd/selftest: Add test ops to test pasid attach/detach
` [PATCH v10 18/18] iommufd/selftest: Add coverage for iommufd "
[RFC 0/3] Guaranteed CMA
2025-03-21 16:14 UTC (10+ messages)
` [RFC 1/3] mm: implement cleancache
` [RFC 2/3] mm: introduce GCMA
` [RFC 3/3] mm: integrate GCMA with CMA using dt-bindings
[PATCH] iommu: Split out and tidy up Arm Kconfig
2025-03-21 11:35 UTC (3+ messages)
[PATCH] iommu/virtio: Make instance lookup robust
2025-03-21 10:10 UTC (2+ messages)
[PATCHv2 0/6] make vendor specific subdirectory inclusion conditional
2025-03-21 2:14 UTC (13+ messages)
` [PATCH 1/6] iommu: remove duplicate selection of DMAR_TABLE
` [PATCH 2/6] iommu: make inclusion of intel directory conditional
` [PATCH 3/6] iommu: make inclusion of amd "
` [PATCH 4/6] iommu: make inclusion of riscv "
` [PATCH 5/6] iommu: make inclusion of arm/arm-smmu-v3 "
` [PATCH 6/6] iommu: make inclusion of iommufd "
[GIT PULL] dma-mapping fix for Linux 6.14
2025-03-20 23:59 UTC (2+ messages)
[PATCH] iommu: Avoid introducing more races
2025-03-20 19:42 UTC (2+ messages)
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox