Linux IOMMU Development
 help / color / mirror / Atom feed
 messages from 2025-08-03 20:40:07 to 2025-08-12 12:37:14 UTC [more...]

[PATCH v3 00/29] KVM: arm64: SMMUv3 driver for pKVM
 2025-08-12 12:37 UTC  (16+ messages)
` [PATCH v3 29/29] iommu/arm-smmu-v3-kvm: Add IOMMU ops

[PATCH v2] dma/pool: Ensure DMA_DIRECT_REMAP allocations are decrypted
 2025-08-12 10:25 UTC  (2+ messages)

[PATCH RESEND] iommu/amd: Avoid stack buffer overflow from kernel cmdline
 2025-08-12  6:41 UTC  (2+ messages)

[PATCH v3 1/1] iommu/sva: Invalidate KVA range on kernel TLB flush
 2025-08-12  1:17 UTC  (21+ messages)

[PATCH v2 0/4] Retire SDM845-cheza devboards
 2025-08-11 23:26 UTC  (2+ messages)

[PATCH v3 0/5] Disable ATS via iommu during PCI resets
 2025-08-11 22:59 UTC  (6+ messages)
` [PATCH v3 1/5] iommu: Lock group->mutex in iommu_deferred_attach
` [PATCH v3 2/5] iommu: Pass in gdev to __iommu_device_set_domain
` [PATCH v3 3/5] iommu: Add iommu_get_domain_for_dev_locked() helper
` [PATCH v3 4/5] iommu: Introduce iommu_dev_reset_prepare() and iommu_dev_reset_done()
` [PATCH v3 5/5] pci: Suspend iommu function prior to resetting a device

[PATCH v3 0/3] arm-smmu: select suitable MSI IOVA
 2025-08-11 22:34 UTC  (9+ messages)
` [PATCH v3 1/3] arm-smmu: move MSI_IOVA macro definitions
` [PATCH v3 2/3] iommu/of: fix device tree configuration for PCI devices
` [PATCH v3 3/3] arm-smmu: select suitable MSI IOVA

[PATCH 1/9] iommu/pages: Add support for a incoherent IOMMU page walker
 2025-08-11 21:21 UTC  (5+ messages)

[RESEND PATCH 0/2] Add encrypt/decrypt support for vmalloc regions
 2025-08-11 18:31 UTC  (12+ messages)
` [RESEND PATCH 1/2] dma/pool: Use vmap() address for memory encryption helpers on ARM64
` [RESEND PATCH 2/2] arm64: Add encrypt/decrypt support for vmalloc regions

[PATCH v2 0/4] iommu: Fix the longstanding probe issues
 2025-08-11 17:01 UTC  (4+ messages)
` [PATCH v2 4/4] iommu: Get DT/ACPI parsing into the proper probe path

[PATCH 0/9] Add support ANS2 NVMe on Apple A11
 2025-08-11 13:51 UTC  (10+ messages)
` [PATCH 1/9] dt-bindings: mailbox: apple,mailbox: Add ASC mailboxes on Apple A11 and T2
` [PATCH 2/9] soc: apple: mailbox: Add Apple A11 and T2 mailbox support
` [PATCH 3/9] dt-bindings: iommu: apple,sart: Add Apple A11
` [PATCH 4/9] soc: apple: sart: Make allow flags SART version dependent
` [PATCH 5/9] soc: apple: sart: Add SARTv0 support
` [PATCH 6/9] dt-bindings: nvme: apple,nvme-ans: Add Apple A11
` [PATCH 7/9] nvme: apple: Add Apple A11 support
` [PATCH 8/9] arm64: dts: apple: t8015: Fix PCIE power domains dependencies
` [PATCH 9/9] arm64: dts: apple: t8015: Add NVMe nodes

[PATCH] swiotlb: Remove redundant __GFP_NOWARN
 2025-08-11 11:30 UTC  (2+ messages)

[PATCH] dma-direct: clean up the logic in __dma_direct_alloc_pages()
 2025-08-11 11:29 UTC  (2+ messages)

[PATCH v4] of: reserved_mem: Restructure call site for dma_contiguous_early_fixup()
 2025-08-11 11:07 UTC  (2+ messages)

[RFC PATCH 0/6] iommu/riscv: Add MRIF support
 2025-08-11  6:11 UTC  (7+ messages)
` [RFC PATCH 1/6] RISC-V: Add more elements to irqbypass vcpu_info
` [RFC PATCH 2/6] RISC-V: KVM: Transfer the physical address of MRIF to iommu-ir
` [RFC PATCH 3/6] RISC-V: KVM: Add a xarray to record host irq msg
` [RFC PATCH 4/6] iommu/riscv: Add irq_mask and irq_ack configure for iommu-ir
` [RFC PATCH 5/6] iommu/riscv: Add MRIF mode support
` [RFC PATCH 6/6] RISC-V: KVM: Check the MRIF in notice MSI irq handler

[PATCH 0/2] Add encrypt/decrypt support for vmalloc regions
 2025-08-11  0:23 UTC  (3+ messages)
` [PATCH 1/2] dma/pool: Use vmap() address for memory encryption helpers on ARM64
` [PATCH 2/2] arm64: Add encrypt/decrypt support for vmalloc regions

[PATCH] iommufd: viommu: free memory allocated by kvcalloc() using kvfree()
 2025-08-10 17:53 UTC  (2+ messages)

[PATCH v1 00/16] dma-mapping: migrate to physical address-based API
 2025-08-10 17:02 UTC  (36+ messages)
` [PATCH v1 01/16] dma-mapping: introduce new DMA attribute to indicate MMIO memory
` [PATCH v1 02/16] iommu/dma: handle MMIO path in dma_iova_link
` [PATCH v1 03/16] dma-debug: refactor to use physical addresses for page mapping
` [PATCH v1 04/16] dma-mapping: rename trace_dma_*map_page to trace_dma_*map_phys
` [PATCH v1 05/16] iommu/dma: rename iommu_dma_*map_page to iommu_dma_*map_phys
` [PATCH v1 06/16] iommu/dma: extend iommu_dma_*map_phys API to handle MMIO memory
` [PATCH v1 07/16] dma-mapping: convert dma_direct_*map_page to be phys_addr_t based
` [PATCH v1 08/16] kmsan: convert kmsan_handle_dma to use physical addresses
` [PATCH v1 09/16] dma-mapping: handle MMIO flow in dma_map|unmap_page
` [PATCH v1 10/16] xen: swiotlb: Open code map_resource callback
` [PATCH v1 11/16] dma-mapping: export new dma_*map_phys() interface
` [PATCH v1 12/16] mm/hmm: migrate to physical address-based DMA mapping API
` [PATCH v1 13/16] mm/hmm: properly take MMIO path
` [PATCH v1 14/16] block-dma: migrate to dma_map_phys instead of map_page
` [PATCH v1 15/16] block-dma: properly take MMIO path
` [PATCH v1 16/16] nvme-pci: unmap MMIO pages with appropriate interface

[PATCH 0/3] MT8189 IOMMU SUPPORT
 2025-08-10  7:09 UTC  (9+ messages)
` [PATCH 1/3] dt-bindings: mediatek: mt8189: Add bindings for MM & APU & INFRA IOMMU
` [PATCH 2/3] iommu/mediatek: Add a flag DL_WITH_MULTI_LARB
` [PATCH 3/3] iommu/mediatek: Add support for mt8189

[PATCH v3 0/2] rust: add initial scatterlist abstraction
 2025-08-08 20:23 UTC  (12+ messages)
` [PATCH v3 1/2] "
  ` [PATCH v3 2/2] samples: rust: add sample code for "

[PATCH v2 00/16] Fix incorrect iommu_groups with PCIe ACS
 2025-08-08  7:56 UTC  (12+ messages)

[PATCH v2 RESEND] iommu/riscv: check pte null pointer before use
 2025-08-08  7:21 UTC  (4+ messages)
` [PATCH v?] "
  `  "
    ` [v?] "

[PATCH v4] iommu/vt-d: replace snprintf with scnprintf in dmar_latency_snapshot()
 2025-08-08  5:19 UTC  (3+ messages)

[PATCH 00/22] Add support for A100/A133 display
 2025-08-07 15:29 UTC  (7+ messages)
` [PATCH 01/22] dt-bindings: iommu: sun50i: remove resets from required property
` [PATCH 07/22] dt-bindings: vendor-prefixes: Shenzhen Baijie Technology
` [PATCH 09/22] iommu: sun50i: make reset control optional

[PATCH 0/3] MT8189 IOMMU SUPPORT
 2025-08-07  9:55 UTC 

[PATCH v2] iommu/riscv: check pte null pointer before use
 2025-08-07  2:35 UTC 

[PATCH v1 00/10] vfio/pci: Allow MMIO regions to be exported through dma-buf
 2025-08-07  0:02 UTC  (19+ messages)
` [PATCH v1 01/10] PCI/P2PDMA: Remove redundant bus_offset from map state
` [PATCH v1 02/10] PCI/P2PDMA: Separate the mmap() support from the core logic
` [PATCH v1 03/10] PCI/P2PDMA: Simplify bus address mapping API
` [PATCH v1 04/10] PCI/P2PDMA: Refactor to separate core P2P functionality from memory allocation
` [PATCH v1 05/10] PCI/P2PDMA: Export pci_p2pdma_map_type() function
` [PATCH v1 06/10] types: move phys_vec definition to common header
` [PATCH v1 07/10] vfio: Export vfio device get and put registration helpers
` [PATCH v1 08/10] vfio/pci: Enable peer-to-peer DMA transactions by default
` [PATCH v1 09/10] vfio/pci: Share the core device pointer while invoking feature functions
` [PATCH v1 10/10] vfio/pci: Add dma-buf export support for MMIO regions

[PATCH v5 0/3] RISC-V: Add ACPI support for IOMMU
 2025-08-06 17:15 UTC  (2+ messages)

[PATCH rc] iommu/arm-smmu-v3: Fix smmu_domain->nr_ats_masters decrement
 2025-08-06 14:04 UTC  (2+ messages)

[PATCH] iommu/riscv: check pte null pointer before use
 2025-08-06 10:13 UTC  (3+ messages)
  `  "

[PATCH 0/8] dma-mapping: migrate to physical address-based API
 2025-08-05 15:36 UTC  (10+ messages)

[PATCH v2 15/16] PCI: Check ACS DSP/USP redirect bits in pci_enable_pasid()
 2025-08-05  4:39 UTC  (2+ messages)

[PATCH] iommufd: fix returns ENOENT in iommufd_viommu_get_vdev_id()
 2025-08-05  3:33 UTC  (5+ messages)

Live Update MC (LPC): Call for Presentations
 2025-08-04 23:09 UTC  (2+ messages)

[PATCH 2/2] dma-mapping: benchmark: Add padding to ensure uABI remained consistent
 2025-08-04 21:57 UTC  (7+ messages)

[PATCH v3] of: reserved_mem: Restructure call site for dma_contiguous_early_fixup()
 2025-08-04 19:37 UTC  (3+ messages)

[PATCH 00/11] Drop default ARCH_APPLE from Kconfig and use defconfig instead
 2025-08-03 20:40 UTC  (3+ messages)
` [PATCH 05/11] i2c: apple: Drop default ARCH_APPLE in Kconfig


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox