messages from 2025-10-04 20:02:13 to 2025-10-10 22:56:58 UTC [more...]
[PATCH v3 00/15] iommu/amd: Introduce Nested Translation support
2025-10-10 22:56 UTC (21+ messages)
` [PATCH v3 01/15] iommu/amd: Rename DEV_DOMID_MASK to DTE_DOMID_MASK
` [PATCH v3 02/15] iommu/amd: Make amd_iommu_pdom_id_alloc() non-static
` [PATCH v3 03/15] iommu/amd: Make amd_iommu_pdom_id_free() non-static
` [PATCH v3 04/15] iommu/amd: Make amd_iommu_device_flush_dte() non-static
` [PATCH v3 05/15] iommu/amd: Make amd_iommu_update_dte256() non-static
` [PATCH v3 06/15] iommu/amd: Make amd_iommu_make_clear_dte() non-static inline
` [PATCH v3 07/15] iommu/amd: Make amd_iommu_completion_wait() non-static
` [PATCH v3 08/15] iommufd: Introduce data struct for AMD nested domain allocation
` [PATCH v3 09/15] iommu/amd: Always enable GCR3TRPMode when supported
` [PATCH v3 10/15] iommu/amd: Add support for nest parent domain allocation
` [PATCH v3 11/15] iommu/amd: Add support for nested "
` [PATCH v3 12/15] iommu/amd: Validate guest DTE for nested translation
` [PATCH v3 13/15] iommu/amd: Refactor persistent DTE bits programming into amd_iommu_make_clear_dte()
` [PATCH v3 14/15] iommu/amd: Refactor logic to program the host page table in DTE
` [PATCH v3 15/15] iommu/amd: Add support for nested domain attach/detach
[RFC PATCH 0/3] Introduce iommu-map-masked for platform devices
2025-10-10 22:30 UTC (15+ messages)
[PATCH 0/8] Guaranteed CMA
2025-10-10 22:09 UTC (17+ messages)
` [PATCH 1/8] mm: implement cleancache
` [PATCH 2/8] mm/cleancache: add cleancache LRU for folio aging
` [PATCH 3/8] mm/cleancache: readahead support
` [PATCH 4/8] mm/cleancache: add sysfs interface
` [PATCH 5/8] mm/tests: add cleancache kunit test
` [PATCH 6/8] add cleancache documentation
` [PATCH 7/8] mm: introduce GCMA
` [PATCH 8/8] mm: integrate GCMA with CMA using dt-bindings
[PATCH] iommu/amd: Enable PCIe ACS only if AMD IOMMU is on
2025-10-10 19:57 UTC (2+ messages)
[PATCH 0/3] dma_mapping: Add auto cleanup support
2025-10-10 18:50 UTC (4+ messages)
` [PATCH 1/3] cleanup: Add DEFINE_GUARD_ARGS_CLASS macro for resource alloc/free functions with multiple arguments
` [PATCH 2/3] dma-mapping: Add auto cleanup support dma_map_single()
` [PATCH 3/3] i2c: lpi2c: Use auto cleanup for dma_map_single()
[PATCH v2] dma-debug: don't report false positives with DMA_BOUNCE_UNALIGNED_KMALLOC
2025-10-10 17:30 UTC
[PATCH] dma-debug: don't report false positives with DMA_BOUNCE_UNALIGNED_KMALLOC
2025-10-10 17:24 UTC (3+ messages)
[PATCH v5 0/8] Fix stale IOTLB entries for kernel address space
2025-10-10 15:47 UTC (19+ messages)
` [PATCH v5 1/8] mm: Add a ptdesc flag to mark kernel page tables
` [PATCH v5 2/8] mm: Actually mark kernel page table pages
` [PATCH v5 3/8] x86/mm: Use 'ptdesc' when freeing PMD pages
` [PATCH v5 4/8] mm: Introduce pure page table freeing function
` [PATCH v5 5/8] x86/mm: Use pagetable_free()
` [PATCH v5 6/8] mm: Introduce deferred freeing for kernel page tables
[RFC PATCH 13/15] iommufd: Persist iommu domains for live update
2025-10-10 14:24 UTC (13+ messages)
[PATCH v2 00/12] iommu/amd: Introduce Nested Translation support
2025-10-09 14:35 UTC (27+ messages)
` [PATCH v2 01/12] iommu/amd: Rename DEV_DOMID_MASK to DTE_DOMID_MASK
` [PATCH v2 03/12] iommu/amd: Make amd_iommu_pdom_id_free() non-static
` [PATCH v2 04/12] iommu/amd: Make amd_iommu_device_flush_dte() non-static
` [PATCH v2 09/12] iommu/amd: Add support for nest parent domain allocation
` [PATCH v2 10/12] iommu/amd: Add support for nested "
` [PATCH v2 11/12] iommu/amd: Add support for nested domain attach/detach
` [PATCH v2 12/12] iommu/amd: Introduce IOMMUFD vIOMMU support for AMD
[PATCH v2 00/37] mm: remove nth_page()
2025-10-09 13:05 UTC (13+ messages)
` [PATCH v2 08/37] mm/hugetlb: check for unreasonable folio sizes when registering hstate
` (bisected) "
[PATCH v5 00/15] Consolidate iommu page table implementations (AMD)
2025-10-09 11:44 UTC (7+ messages)
` [PATCH v5 04/15] iommupt: Add the AMD IOMMU v1 page table format
[PATCH v5 12/15] iommupt: Add the x86 64 bit page table format
2025-10-09 11:43 UTC (4+ messages)
[PATCH] dt-bindings: arm-smmu: Add compatible for Kaanapali SoC
2025-10-09 11:01 UTC (2+ messages)
[PATCH RFC 00/35] mm: remove nth_page()
2025-10-09 10:30 UTC (6+ messages)
` [PATCH RFC 06/35] mm/page_alloc: reject unreasonable folio/compound page sizes in alloc_contig_range_noprof()
[PATCH v2 00/14] iommu: fix device leaks
2025-10-09 10:15 UTC (19+ messages)
` [PATCH v2 01/14] iommu/apple-dart: fix device leak on of_xlate()
` [PATCH v2 02/14] iommu/qcom: "
` [PATCH v2 03/14] iommu/exynos: "
` [PATCH v2 04/14] iommu/ipmmu-vmsa: "
` [PATCH v2 05/14] iommu/mediatek: "
` [PATCH v2 06/14] iommu/mediatek: fix device leaks on probe()
` [PATCH v2 07/14] iommu/mediatek: simplify dt parsing error handling
` [PATCH v2 08/14] iommu/mediatek-v1: fix device leak on probe_device()
` [PATCH v2 09/14] iommu/mediatek-v1: fix device leaks on probe()
` [PATCH v2 10/14] iommu/mediatek-v1: add missing larb count sanity check
` [PATCH v2 11/14] iommu/omap: fix device leaks on probe_device()
` [PATCH v2 12/14] iommu/omap: simplify probe_device() error handling
` [PATCH v2 13/14] iommu/sun50i: fix device leak on of_xlate()
` [PATCH v2 14/14] iommu/tegra: fix device leak on probe_device()
[PATCH] iommu/vt-d: Fix unused invalidation hint in qi_desc_iotlb
2025-10-09 1:09 UTC
update kernel-doc for MEMBLOCK_RSRV_NOINIT (was: Re: [PATCH RFC 10/35] mm/hugetlb: cleanup hugetlb_folio_init_tail_vmemmap())
2025-10-09 1:07 UTC (2+ messages)
[PATCH v4] iommu/riscv: prevent NULL deref in iova_to_phys
2025-10-09 1:07 UTC (2+ messages)
[PATCH v6 0/3] RISC-V: Add ACPI support for IOMMU
2025-10-09 1:06 UTC (2+ messages)
[PATCH rc] iommufd: Don't overflow during division for dirty tracking
2025-10-08 21:35 UTC (3+ messages)
[syzbot] [iommu?] divide error in iova_bitmap_alloc
2025-10-08 18:10 UTC (3+ messages)
` [PATCH] iommufd: Prevent the use of nil data
[PATCH v6 00/15] Consolidate iommu page table implementations (AMD)
2025-10-08 14:37 UTC (19+ messages)
` [PATCH v6 01/15] genpt: Generic Page Table base API
` [PATCH v6 02/15] genpt: Add Documentation/ files
` [PATCH v6 03/15] iommupt: Add the basic structure of the iommu implementation
` [PATCH v6 04/15] iommupt: Add the AMD IOMMU v1 page table format
` [PATCH v6 05/15] iommupt: Add iova_to_phys op
` [PATCH v6 06/15] iommupt: Add unmap_pages op
` [PATCH v6 07/15] iommupt: Add map_pages op
` [PATCH v6 08/15] iommupt: Add read_and_clear_dirty op
` [PATCH v6 09/15] iommupt: Add a kunit test for Generic Page Table
` [PATCH v6 10/15] iommupt: Add a mock pagetable format for iommufd selftest to use
` [PATCH v6 11/15] iommufd: Change the selftest to use iommupt instead of xarray
` [PATCH v6 12/15] iommupt: Add the x86 64 bit page table format
` [PATCH v6 13/15] iommu/amd: Use the generic iommu page table
` [PATCH v6 14/15] iommu/amd: Remove AMD io_pgtable support
` [PATCH v6 15/15] iommupt: Add a kunit test for the IOMMU implementation
[PATCH v2] Fix to avoid the usage of the `res` variable uninitialized in the following macro expansions
2025-10-08 13:30 UTC (4+ messages)
[PATCH 00/17] drm/msm/adreno: Introduce Adreno 8xx family support
2025-10-08 12:01 UTC (11+ messages)
` [PATCH 01/17] soc: qcom: ubwc: Add config for Kaanapali
` [PATCH 10/17] drm/msm/a6xx: Rebase GMU register offsets
` [PATCH 12/17] drm/msm/adreno: Introduce A8x GPU Support
` [PATCH 16/17] dt-bindings: arm-smmu: Add Kaanapali GPU SMMU
` [PATCH 17/17] dt-bindings: display/msm/gmu: Add Adreno 840 GMU
[PATCH v5 07/15] iommupt: Add map_pages op
2025-10-08 9:52 UTC (4+ messages)
[PATCH v5 13/15] iommu/amd: Use the generic iommu page table
2025-10-08 9:47 UTC (2+ messages)
[GIT PULL] more dma-mapping updates for Linux 6.18
2025-10-07 20:06 UTC (2+ messages)
[PATCH 0/2] SMMU v3 CMDQ fix and improvement
2025-10-07 18:16 UTC (9+ messages)
` [PATCH 1/2] iommu/arm-smmu-v3: Fix CMDQ timeout warning
` [PATCH 2/2] iommu/arm-smmu-v3: Improve CMDQ lock fairness and efficiency
[PATCH] iommu/amd: Ensure GA log notifier callbacks finish running before module unload
2025-10-07 17:54 UTC (3+ messages)
[PATCH 00/14] iommu: fix device leaks
2025-10-07 9:41 UTC (5+ messages)
[PATCH] iommu: __iommu_attach_group: check for non-NULL blocking_domain
2025-10-07 9:38 UTC (2+ messages)
[PATCH] iommu/pages: use folio_nr_pages() instead of shift operation
2025-10-06 12:28 UTC (2+ messages)
[PATCH 0/2] amba/iommu: tegra: enable compile testing
2025-10-06 9:39 UTC (2+ messages)
[PATCH v1 0/9] Remove DMA .map_page and .unmap_page callbacks
2025-10-06 4:03 UTC (13+ messages)
` [PATCH v1 3/9] parisc: Convert DMA map_page to map_phys interface
` [PATCH v1 4/9] powerpc: Convert to physical address DMA mapping
[RFC PATCH v2 00/18] iommu/riscv: Add irqbypass support
2025-10-05 8:47 UTC (19+ messages)
` [RFC PATCH v2 05/18] iommu/riscv: Prepare to use MSI table
` [RFC PATCH v2 06/18] iommu/riscv: Implement MSI table management functions
` [RFC PATCH v2 07/18] iommu/riscv: Export phys_to_ppn and ppn_to_phys
` [RFC PATCH v2 09/18] iommu/dma: enable IOMMU_DMA for RISC-V
` [RFC PATCH v2 10/18] RISC-V: Define irqbypass vcpu_info
` [RFC PATCH v2 13/18] iommu/riscv: report iommu capabilities
` [RFC PATCH v2 14/18] RISC-V: KVM: Enable KVM_VFIO interfaces on RISC-V arch
` [RFC PATCH v2 16/18] vfio: enable IOMMU_TYPE1 for RISC-V
` [RFC PATCH v2 17/18] RISC-V: defconfig: Add VFIO modules
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox