From mboxrd@z Thu Jan 1 00:00:00 1970 From: Jean-Philippe Brucker Subject: Re: [PATCH v4 05/22] iommu: introduce iommu invalidate API function Date: Wed, 2 May 2018 10:31:50 +0100 Message-ID: References: <1523915351-54415-1-git-send-email-jacob.jun.pan@linux.intel.com> <1523915351-54415-6-git-send-email-jacob.jun.pan@linux.intel.com> <20180420181951.GA50099@ostrya.localdomain> <20180423134325.6780f6ac@jacob-builder> <72ee47c4-55fa-4ff1-d94e-cc26203e3eda@arm.com> <20180501155838.4ec3720c@jacob-builder> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: In-Reply-To: <20180501155838.4ec3720c@jacob-builder> Content-Language: en-US List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: iommu-bounces-cunTk1MwBs9QetFLy7KEm3xJsTq8ys+cHZ5vskTnxNA@public.gmane.org Errors-To: iommu-bounces-cunTk1MwBs9QetFLy7KEm3xJsTq8ys+cHZ5vskTnxNA@public.gmane.org To: Jacob Pan Cc: "Liu-U/l+663ovUtSq9BJjBFyUp/QNRX+jHPU@public.gmane.org" , "Liu, Yi L" , Raj Ashok , Greg Kroah-Hartman , Rafael Wysocki , "iommu-cunTk1MwBs9QetFLy7KEm3xJsTq8ys+cHZ5vskTnxNA@public.gmane.org" , LKML , Jean Delvare , David Woodhouse List-Id: iommu@lists.linux-foundation.org On 01/05/18 23:58, Jacob Pan wrote: >>>> Maybe this should be called "NG_PAGE_PASID", >>> Sure. I was thinking page range already implies non-global pages. >>>> and "DOMAIN_PAGE" should >>>> instead be "PAGE_PASID". If I understood their meaning correctly, >>>> it would be more consistent with the rest. >>>> >>> I am trying not to mix granu between request w/ PASID and w/o. >>> DOMAIN_PAGE meant to be for request w/o PASID. >> >> Is the distinction necessary? I understand the IOMMU side might offer >> many possibilities for invalidation, but the user probably doesn't >> need all of them. It might be easier to document, upstream and >> maintain if we only specify what's currently needed by users (what >> does QEMU VT-d use?) Others can always extend it by increasing the >> version. >> >> Do you think that this invalidation message will be used outside of >> BIND_PASID_TABLE context? I can't see an other use but who knows. At >> the moment requests w/o PASID are managed with >> VFIO_IOMMU_MAP/UNMAP_DMA, which doesn't require invalidation. And in >> a BIND_PASID_TABLE context, IOMMUs requests w/o PASID are just a >> special case using PASID 0 (for Arm and AMD) so I suppose they'll use >> the same invalidation commands as requests w/ PASID. >> > My understanding is that for GIOVA use case, VT-d vIOMMU creates > GIOVA-GPA mapping and the host shadows the 2nd level page tables to > create GIOVA-HPA mapping. So when assigned device in the guest can do > both DMA map/unmap and VFIO map/unmap, VFIO unmap is one time deal > (I guess invalidation can be captured in other code path), but guest > kernel use of DMA unmap could will trigger invalidation. QEMU needs to > trap those invalidation and passdown to physical IOMMU. So we do need > invalidation w/o PASID. Hm, isn't this all done by host userspace? Whether guest does DMA map/unmap or VFIO map/unmap, it creates/removes IOVA-GPA mappings in the vIOMMU. QEMU captures invalidation requests for these mappings from the guest, finds GPA-HVA in the shadow map and sends a VFIO map/unmap request for IOVA-HVA. Thanks, Jean