Linux kbuild/kconfig development
 help / color / mirror / Atom feed
 messages from 2025-06-13 12:52:20 to 2025-06-24 19:14:24 UTC [more...]

[PATCH v3] Kconfig: Added compare capabilities for mconf
 2025-06-24 19:14 UTC 

[PATCH] scripts: add zboot support to extract-vmlinux
 2025-06-24 17:56 UTC  (4+ messages)

[PATCH 00/66] kconfig: improve xconfig and gconfig
 2025-06-24 15:05 UTC  (67+ messages)
` [PATCH 01/66] kconfig: set MENU_CHANGED to choice when the selected member is changed
` [PATCH 02/66] kconfig: qconf: do not show checkbox icon for choice
` [PATCH 03/66] kconfig: qconf: show selected choice in the Value column
` [PATCH 04/66] kconfig: rename menu_get_parent_menu() to menu_get_menu_or_parent_menu()
` [PATCH 05/66] kconfig: re-add menu_get_parent_menu() that returns parent menu
` [PATCH 06/66] kconfig: gconf: make columns resizable
` [PATCH 07/66] kconfig: gconf: fix potential memory leak in renderer_edited()
` [PATCH 08/66] kconfig: gconf: always destroy dialog in on_window1_delete_event()
` [PATCH 09/66] kconfig: gconf: remove old #ifdef GTK_CHECK_VERSION
` [PATCH 10/66] kconfig: gconf: remove empty if-block
` [PATCH 11/66] kconfig: gconf: remove meaningless code in init_main_window()
` [PATCH 12/66] kconfig: gconf: remove unneeded gtk_tree_view_set_headers_visible() calls
` [PATCH 13/66] kconfig: gconf: remove gtk_tree_view_column_set_visible() calls
` [PATCH 14/66] kconfig: gconf: remove gtk_widget_realize() calls
` [PATCH 15/66] kconfig: gconf: remove gtk_tree_view_set_rules_hint() calls
` [PATCH 16/66] kconfig: gconf: remove unnecessary gtk_set_locale() call
` [PATCH 17/66] kconfig: gconf: remove internal-child="image" nodes from glade
` [PATCH 18/66] kconfig: gconf: remove parents[] array and indent variable
` [PATCH 19/66] kconfig: gconf: remove unnecessary NULL checks for tree1 and tree2
` [PATCH 20/66] kconfig: gconf: remove unneeded variable in on_split_clicked()
` [PATCH 21/66] kconfig: gconf: remove unneeded variables in on_treeview*_button_press_event()
` [PATCH 22/66] kconfig: gconf: remove unused 'color' variable
` [PATCH 23/66] kconfig: gconf: add static qualifiers to variables
` [PATCH 24/66] kconfig: gconf: move init_*() functions below
` [PATCH 25/66] kconfig: gconf: refactor view setting code
` [PATCH 26/66] kconfig: gconf: grey out button for current view
` [PATCH 27/66] kconfig: gconf: move the main window event handlers below
` [PATCH 28/66] kconfig: gconf: move button1 initialization below
` [PATCH 29/66] kconfig: gconf: add static qualifiers to event handlers
` [PATCH 30/66] kconfig: gconf: remove glade_xml_signal_autoconnect() call
` [PATCH 31/66] kconfig: gconf: make key_press_event work in left pane too
` [PATCH 32/66] kconfig: gconf: avoid hardcoding model2 in on_treeview2_cursor_changed()
` [PATCH 33/66] kconfig: gconf: avoid hardcoding model2 in renderer_edited()
` [PATCH 34/66] kconfig: gconf: avoid hardcoding model* in on_treeview*_button_press_event()
` [PATCH 35/66] kconfig: gconf: add on_save_clicked() event handler
` [PATCH 36/66] kconfig: gconf: use GtkFileChooser in on_load1_activate()
` [PATCH 37/66] kconfig: gconf: use GtkFileChooser in on_save_as1_activate()
` [PATCH 38/66] kconfig: gconf: use GdkPixbuf in replace_button_icon()
` [PATCH 39/66] kconfig: gconf: refactor replace_button_icon()
` [PATCH 40/66] kconfig: gconf: make introduction, about, license dialogs modal
` [PATCH 41/66] kconfig: gconf: remove global 'tree' variable
` [PATCH 42/66] kconfig: gconf: merge 'current' and 'browsed' global variables
` [PATCH 43/66] kconfig: gconf: preserve menu selection when switching view mode
` [PATCH 44/66] kconfig: gconf: use GtkTreeModelFilter to control row visibility
` [PATCH 45/66] kconfig: gconf: remove global 'model1' and 'model2' variables
` [PATCH 46/66] kconfig: gconf: remove init_tree_model()
` [PATCH 47/66] kconfig: gconf: inline fill_row() into set_node()
` [PATCH 48/66] kconfig: gconf: do not reconstruct tree store when a symbol is changed
` [PATCH 49/66] kconfig: gconf: inline display_list() into set_view_mode()
` [PATCH 50/66] kconfig: gconf: remove dead code in display_tree_part()
` [PATCH 51/66] kconfig: gconf: rename display_tree_part()
` [PATCH 52/66] kconfig: gconf: remove fixup_rootmenu()
` [PATCH 53/66] kconfig: gconf: use size_allocate event handler
` [PATCH 54/66] kconfig: gconf: replace GDK_space with GDK_KEY_space
` [PATCH 55/66] kconfig: gconf: replace GTK_STOCK_{OK,NO,CANCEL}
` [PATCH 56/66] kconfig: gconf: remove "tooltips" property from glade
` [PATCH 57/66] kconfig: gconf: replace "tooltip" property with "tooltip-text"
` [PATCH 58/66] kconfig: gconf: remove unnecessary default message in text view
` [PATCH 59/66] kconfig: gconf: use gtk_check_menu_item_get_active() accessor
` [PATCH 60/66] kconfig: gconf: use gtk_dialog_get_content_area() accessor
` [PATCH 61/66] kconfig: gconf: remove GtkHandleBox from glade
` [PATCH 62/66] kconfig: gconf: rename gconf.glade to gconf.ui
` [PATCH 63/66] kconfig: gconf: migrate to GTK 3
` [PATCH 64/66] kconfig: gconf: replace GtkVbox with GtkBox
` [PATCH 65/66] kconfig: gconf: replace GdkColor with GdkRGBA
` [PATCH 66/66] kconfig: gconf: show GTK version in About dialog

[PATCH v2 00/14] stackleak: Support Clang stack depth tracking
 2025-06-24 12:31 UTC  (6+ messages)
` [PATCH v2 09/14] mips: Handle KCOV __init vs inline mismatches
` [PATCH v2 10/14] loongarch: "

[PATCH v13 0/6] rust: extend `module!` macro with integer parameter support
 2025-06-24 11:57 UTC  (30+ messages)
` [PATCH v13 1/6] rust: str: add radix prefixed integer parsing functions
` [PATCH v13 2/6] rust: introduce module_param module
` [PATCH v13 3/6] rust: module: use a reference in macros::module::module
` [PATCH v13 4/6] rust: module: update the module macro with module parameter support
` [PATCH v13 5/6] rust: samples: add a module parameter to the rust_minimal sample

[PATCH v2] kconfig/nconf: Replace strncpy() with snprintf()
 2025-06-24 11:08 UTC  (3+ messages)

[PATCH v2] Kconfig: Added compare capabilities for mconf Ver. 2
 2025-06-24 10:33 UTC  (5+ messages)

[PATCH 1/1] kconfig: fix 'space' to (de)select options
 2025-06-24 10:03 UTC  (2+ messages)

[PATCH] gendwarfksyms: make -T symtypes output be in name order
 2025-06-23 15:22 UTC  (3+ messages)

[PATCH v4 0/7] Add generated modalias to modules.builtin.modinfo
 2025-06-23  6:15 UTC  (12+ messages)
` [PATCH v4 1/7] module: remove meaningless 'name' parameter from __MODULE_INFO()
` [PATCH v4 2/7] kbuild: always create intermediate vmlinux.unstripped
` [PATCH v4 3/7] kbuild: keep .modinfo section in vmlinux.unstripped
` [PATCH v4 4/7] kbuild: extract modules.builtin.modinfo from vmlinux.unstripped
` [PATCH v4 5/7] scsi: Always define blogic_pci_tbl structure
` [PATCH v4 6/7] modpost: Add modname to mod_device_table alias
` [PATCH v4 7/7] modpost: Create modalias for builtin modules

[PATCH v12 0/6] rust: reduce `as` casts, enable related lints
 2025-06-22 22:50 UTC  (32+ messages)
` [PATCH v12 1/6] rust: enable `clippy::ptr_as_ptr` lint
` [PATCH v12 2/6] rust: enable `clippy::ptr_cast_constness` lint
` [PATCH v12 3/6] rust: enable `clippy::as_ptr_cast_mut` lint
` [PATCH v12 4/6] rust: enable `clippy::as_underscore` lint
` [PATCH v12 5/6] rust: enable `clippy::cast_lossless` lint
` [PATCH v12 6/6] rust: enable `clippy::ref_as_ptr` lint

[PATCH v3 00/16] kunit: Introduce UAPI testing framework
 2025-06-20 13:50 UTC  (36+ messages)
` [PATCH v3 02/16] kbuild: userprogs: also inherit byte order and ABI from kernel
` [PATCH v3 04/16] kbuild: userprogs: add nolibc support
` [PATCH v3 07/16] kbuild: introduce blob framework
` [PATCH v3 08/16] kunit: tool: Add test for nested test result reporting
` [PATCH v3 09/16] kunit: tool: Don't overwrite test status based on subtest counts
` [PATCH v3 10/16] kunit: tool: Parse skipped tests from kselftest.h
` [PATCH v3 11/16] kunit: Always descend into kunit directory during build
` [PATCH v3 12/16] kunit: qemu_configs: loongarch: Enable LSX/LSAX
` [PATCH v3 13/16] kunit: Introduce UAPI testing framework
` [PATCH v3 14/16] kunit: uapi: Add example for UAPI tests
` [PATCH v3 15/16] kunit: uapi: Introduce preinit executable
` [PATCH v3 16/16] kunit: uapi: Validate usability of /proc

Building x64 kernel on i686 broken in 6.12
 2025-06-20  6:37 UTC  (2+ messages)

[PATCH] ARM: Use an absolute path to unified.h in KBUILD_AFLAGS
 2025-06-20  2:31 UTC  (2+ messages)

[PATCH v2 1/4] kbuild: move W=1 check for scripts/misc-check to top-level Makefile
 2025-06-19 16:26 UTC  (5+ messages)
` [PATCH v2 3/4] scripts/misc-check: check missing #include <linux/export.h> when W=1

[PATCH] LoongArch: Fix build warnings about export.h
 2025-06-19 12:28 UTC  (3+ messages)

[PATCH 0/3] QRTR bus and Qualcomm Sensor Manager IIO drivers
 2025-06-18 19:19 UTC  (3+ messages)
` [PATCH 3/3] iio: Add Qualcomm Sensor Manager drivers

as-instr in Kbuild broken for arch/arm
 2025-06-18  2:37 UTC  (2+ messages)

Generating .cmd files without actually building the kernel?
 2025-06-16 23:15 UTC  (3+ messages)

[PATCH v11 0/6] rust: reduce `as` casts, enable related lints
 2025-06-15 20:41 UTC  (3+ messages)

[GIT PULL] Kbuild fixes for v6.16-rc2
 2025-06-15 16:22 UTC  (2+ messages)

[PATCH] kconfig: use memcmp instead of deprecated bcmp
 2025-06-15 16:08 UTC  (6+ messages)

kconfig: include <strings.h> to fix bcmp build error on Clang
 2025-06-15 16:05 UTC  (2+ messages)

[PATCH v2] gendwarfksyms: Fix structure type overrides
 2025-06-14  0:55 UTC 

[PATCH] gendwarfksyms: Fix structure type overrides
 2025-06-14  0:53 UTC  (3+ messages)

Unable to build linux kernel 6.12.32-64 on devuan i636?
 2025-06-13 21:46 UTC 

[PATCH v2 0/5] tracepoints: Add warnings for unused tracepoints and trace events
 2025-06-13 14:42 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox