messages from 2026-08-28 06:35:05 to 2026-09-08 06:34:09 UTC [more...]
[PATCH v5 00/24] vdso: Reject absolute relocations during build
2026-09-08 6:33 UTC (24+ messages)
` [PATCH v5 01/24] elf, uapi: Add a header for relocation constants
` [PATCH v5 02/24] x86/elf, um/x86/elf: Move relocation constants to UAPI
` [PATCH v5 03/24] ARM: elf: "
` [PATCH v5 04/24] arm64: "
` [PATCH v5 05/24] powerpc/elf: "
` [PATCH v5 06/24] riscv: elf: "
` [PATCH v5 07/24] LoongArch: "
` [PATCH v5 08/24] s390/elf: "
` [PATCH v5 09/24] MIPS: ELF: "
` [PATCH v5 10/24] sparc: elf: "
` [PATCH v5 11/24] tools headers UAPI: Sync ELF headers with the kernel sources
` [PATCH v5 12/24] vdso: Add the vdsocheck tool
` [PATCH v5 13/24] x86/vdso: Enable "
` [PATCH v5 14/24] ARM: vdso: "
` [PATCH v5 15/24] arm64: "
` [PATCH v5 16/24] powerpc/elf: Add 32-bit REL16 relocation definitions
` [PATCH v5 17/24] powerpc/vdso: Enable the vdsocheck tool
` [PATCH v5 18/24] riscv: vdso: "
` [PATCH v5 19/24] LoongArch: vDSO: "
` [PATCH v5 20/24] s390/vdso: "
` [PATCH v5 21/24] MIPS: ELF: Add more PC-relative relocation definitions
` [PATCH v5 22/24] MIPS: vdso: Enable the vdsocheck tool
` [PATCH v5 23/24] sparc: "
[PATCH v2] docs: kconfig: fix shell function syntax in caveats
2026-09-07 20:52 UTC (2+ messages)
[PATCH] kconfig: reject malformed KCONFIG_PROBABILITY values
2026-09-07 19:45 UTC
[PATCH RFC 0/8] arm64: ftrace: support CALL_OPS on kernels built with kCFI
2026-09-07 19:33 UTC (16+ messages)
` [PATCH RFC 1/8] ftrace: Let ftrace_call_adjust() reject a patch site
` [PATCH RFC 2/8] scripts/sorttable: Make the arm64 before_func offset configurable
` [PATCH RFC 3/8] compiler_types: Let notrace keep the function prefix NOPs
` [PATCH RFC 4/8] arm64: ftrace: Make the CALL_OPS prefix layout configurable
` [PATCH RFC 5/8] arm64: cfi: Use CONFIG_ARM64_FUNCTION_PREFIX_NOPS for the type hash offset
` [PATCH RFC 6/8] arm64: ftrace: Support CALL_OPS on kernels built with kCFI
` [PATCH RFC 7/8] arm64: ftrace: Use five prefix NOPs on ThinLTO kernels with BTI
` [PATCH RFC 8/8] arm64: ftrace: Allow CALL_OPS on kCFI kernels built with Rust
[PATCH 1/2] scripts: add TOML config to container tool
2026-09-07 11:28 UTC (16+ messages)
` [PATCH 2/2] Documentation: dev-tools: update container.rst with config file
[PATCH RESEND v3 1/3] scripts: add TOML config to container tool
2026-09-07 11:19 UTC (5+ messages)
` [PATCH RESEND v3 2/3] Documentation: dev-tools: update container.rst with config file
` [PATCH RESEND v3 3/3] Documentation: dev-tools: refer to user ID rather than id
[PATCH v4 1/3] scripts: add TOML config to container tool
2026-09-07 11:10 UTC (3+ messages)
` [PATCH v4 2/3] Documentation: dev-tools: update container.rst with config file
` [PATCH v4 3/3] Documentation: dev-tools: refer to user ID rather than id
[PATCH v2] checkkconfigsymbols: resolve revisions before resetting the tree
2026-09-07 10:37 UTC
[PATCH v2] kconfig: preserve the final answer when input has no newline
2026-09-07 10:37 UTC
[PATCH v4 0/5] add kconfirm
2026-09-07 8:34 UTC (6+ messages)
[PATCH] kallsyms: also special-case symbols aliasing _sinittext
2026-09-07 6:12 UTC
[PATCH v8 00/43] dyndbg: fix classmaps API for DRM, query extensions, and selftests
2026-09-05 18:13 UTC (44+ messages)
` [PATCH v8 01/43] selftests/dyndbg: Add kselftest script to verify dynamic-debug
` [PATCH v8 02/43] drm: Fix incorrect ccflags-y spelling inside Makefile
` [PATCH v8 03/43] drm: fix config dependent unused variable warning
` [PATCH v8 04/43] drm: Mark CONFIG_DRM_USE_DYNAMIC_DEBUG as unBROKEN
` [PATCH v8 05/43] vmlinux.lds.h: refactor BOUNDED_SECTION_* macros into bounded_sections.lds.h
` [PATCH v8 06/43] vmlinux.lds.h: drop unused HEADERED_SECTION* macros
` [PATCH v8 07/43] vmlinux.lds.h: Fix ALIGN(8) omission causing NULL ptr on i386
` [PATCH v8 08/43] vmlinux.lds.h: remove redundant ALIGN(8) directives
` [PATCH v8 09/43] dyndbg.lds.S: fix lost dyndbg sections in modules
` [PATCH v8 10/43] dyndbg: factor ddebug_match_desc out from ddebug_change
` [PATCH v8 11/43] dyndbg: add stub macro for DECLARE_DYNDBG_CLASSMAP
` [PATCH v8 12/43] dyndbg: reword "class unknown," to "class:_UNKNOWN_"
` [PATCH v8 13/43] dyndbg-API: remove DD_CLASS_TYPE_(DISJOINT|LEVEL)_NAMES and code
` [PATCH v8 14/43] dyndbg: drop NUM_TYPE_ARGS
` [PATCH v8 15/43] dyndbg: bump num-tokens in a query-cmd from 9 to 15
` [PATCH v8 16/43] dyndbg: reduce verbose/debug clutter
` [PATCH v8 17/43] lib/parser: add match_wildcard_hyphen() for agnostic matching
` [PATCH v8 18/43] kbuild, dyndbg: clean up builtin module-name ambiguities
` [PATCH v8 19/43] dyndbg: refactor param_set_dyndbg_classes and below
` [PATCH v8 20/43] dyndbg: tighten fn-sig of ddebug_apply_class_bitmap
` [PATCH v8 21/43] dyndbg: replace classmap list with an array-slice
` [PATCH v8 22/43] dyndbg: macrofy a 2-index for-loop pattern
` [PATCH v8 23/43] dyndbg: reduce class param storage to u32
` [PATCH v8 24/43] dyndbg,module: make proper substructs in _ddebug_info
` [PATCH v8 25/43] dyndbg: move mod_name down from struct ddebug_table to _ddebug_info
` [PATCH v8 26/43] dyndbg: hoist classmap-filter-by-modname up to ddebug_add_module
` [PATCH v8 27/43] dyndbg-API: replace DECLARE_DYNDBG_CLASSMAP
` [PATCH v8 28/43] selftests/dyndbg: enable FT_classmap_inheritance
` [PATCH v8 29/43] dyndbg: detect class_id reservation conflicts
` [PATCH v8 30/43] dyndbg: check DYNAMIC_DEBUG_CLASSMAP_{DEFINE,USE_} args at compile-time
` [PATCH v8 31/43] dyndbg-test: add do_bulk testpoint, rename do_prints to do_classes
` [PATCH v8 32/43] dyndbg-API: promote DYNAMIC_DEBUG_CLASSMAP_PARAM to API
` [PATCH v8 33/43] dyndbg: control-parser: treat comma as a token separator
` [PATCH v8 34/43] selftests: enable comma-terminator tests
` [PATCH v8 35/43] dyndbg: split multi-query strings with @
` [PATCH v8 36/43] dyndbg: resolve "protection" of class'd pr_debug
` [PATCH v8 37/43] dyndbg: harden classmap and descriptor validation
` [PATCH v8 38/43] docs/dyndbg: add classmap info to howto
` [PATCH v8 39/43] dyndbg: Ignore additional arguments from pr_fmt
` [PATCH v8 40/43] dyndbg: add epilogue to dynamic_debug/control file
` [PATCH v8 41/43] dyndbg: add +c flag to count advantage of classmaps for DRM
` [PATCH v8 42/43] dyndbg: add DEBUG-biased fallback stubs for _dynamic_func_call_cls
` [PATCH v8 43/43] selftests/dynamic_debug: Prime params module with +p in FT_comma_terminators
[PATCH] docs: kconfig: fix shell function syntax in caveats
2026-09-05 15:03 UTC (2+ messages)
[PATCH 1/2] kconfig: preserve the final answer when input has no newline
2026-09-05 14:11 UTC (4+ messages)
` [PATCH 2/2] checkkconfigsymbols: resolve revisions before resetting the tree
[PATCH] kbuild: fix typo "funtions" in comment
2026-09-04 23:27 UTC (4+ messages)
[PATCH 0/4] kconfig: improve input validation for numeric options
2026-09-04 23:25 UTC (6+ messages)
` [PATCH 1/4] kconfig: promote invalid numeric reference from warning to error
` [PATCH 2/4] kconfig: check for out-of-bounds numeric constants
` [PATCH 3/4] kconfig: check for hex and int mismatches
` [PATCH 4/4] kconfig: prevent out-of-bounds user input for numeric options
[PATCH] scripts/sorttable: Mark long_size as __maybe_unused
2026-09-04 19:34 UTC (2+ messages)
[PATCH] kbuild: don't delete in-flight filechk temporaries in asm-headers
2026-09-04 18:19 UTC (5+ messages)
[PATCH RFC v3 00/13] sysctl: add module aliases
2026-09-04 17:45 UTC (5+ messages)
[PATCH] rust: kbuild: add intrinsics to fix Rust 1.100.0 builds
2026-09-04 7:53 UTC (2+ messages)
[PATCH] kconfig: fix extra output from savedefconfig on out-of-range defaults
2026-09-04 3:06 UTC (7+ messages)
[PATCH RFC v3 0/8] kcov: add per-task dataflow tracking for function arguments/return values
2026-09-02 16:29 UTC (9+ messages)
` [PATCH RFC v3 1/8] "
` [PATCH RFC v3 2/8] Documentation: add kcov-dataflow.rst
` [PATCH RFC v3 3/8] selftests/kcov_dataflow: add ioctl interface selftest
` [PATCH RFC v3 4/8] selftests/kcov_dataflow: add rust_ffi_contract selftest
` [PATCH RFC v3 5/8] selftests/kcov_dataflow: add binderfs selftest
` [PATCH RFC v3 6/8] selftests/kcov_dataflow: add eight_struct_args_{c,rust} selftest module
` [PATCH RFC v3 7/8] selftests/kcov_dataflow: add rust_kworker_remote "
` [PATCH RFC v3 8/8] selftests/kcov_dataflow: add trigger-view.py
[PATCH v3 1/3] scripts: add TOML config to container tool
2026-09-02 9:37 UTC (4+ messages)
` [PATCH v3 2/3] Documentation: dev-tools: update container.rst with config file
` [PATCH v3 3/3] Documentation: dev-tools: refer to user ID rather than id
[PATCH v2] kstack_erase: suppress -grecord-gcc-switches for external module builds
2026-09-02 5:21 UTC (6+ messages)
` [PATCH v3] scripts/gcc-plugins: suppress recorded GCC switches for extmod builds
[PATCH] kbuild: ubsan: skip UBSAN for external modules by default
2026-09-01 18:42 UTC (5+ messages)
[PATCH] setlocalversion: make tag local to try_tag()
2026-09-01 0:15 UTC (2+ messages)
[PATCH] kbuild: use prefix-map for host and user progs
2026-09-01 0:14 UTC (2+ messages)
[PATCH V2] scripts/mkcompile_h: Update LINUX_COMPILE_HOST command substitution syntax
2026-09-01 0:14 UTC (2+ messages)
[PATCH] kconfig: error out for recursive range
2026-09-01 0:13 UTC (2+ messages)
[PATCH AUTOSEL 6.18] modpost: Handle malformed WMI GUID strings
2026-08-31 13:28 UTC (2+ messages)
` [PATCH AUTOSEL 6.18-5.10] scripts: modpost: detect and report truncated buf_printf() output
[PATCH v3 00/14] Add support for handling PCIe M.2 Key E connectors in devicetree
2026-08-31 13:02 UTC (11+ messages)
` [PATCH v3 03/14] software node: Implement device_get_match_data fwnode callback
[PATCH] erofs: Fix EROFS_FS_ZIP_LZMA_DEFAULT_MAX_STREAMS default logic
2026-08-31 12:40 UTC (6+ messages)
[PATCH v6 00/13] syscalls: Add a shared table for all archs
2026-08-28 23:19 UTC (14+ messages)
` [PATCH v6 01/13] syscalls: Make --abis parsing more robust
` [PATCH v6 02/13] syscalls: Create unified partial table for all archs
` [PATCH v6 03/13] scripts/syscall.tbl: Use the common table
` [PATCH v6 04/13] arm: Use the common syscall table
` [PATCH v6 05/13] s390: "
` [PATCH v6 06/13] sparc: "
` [PATCH v6 07/13] mips: Remove duplicated syscallnr.sh
` [PATCH v6 08/13] mips: Get rid of custom mips ABIs for syscall tables
` [PATCH v6 09/13] mips: Use the common syscall table
` [PATCH v6 10/13] syscalls: Add an option for offsetting the common table
` [PATCH v6 11/13] alpha: Define entry point for set_mempolicy_home_node syscall
` [PATCH v6 12/13] alpha: Remove alpha_ prefix from custom syscall entries
` [PATCH v6 13/13] alpha: Use the common syscall table
[PATCH 00/27] objtool: dynamically detect noreturns
2026-08-28 19:27 UTC (5+ messages)
` [PATCH 12/27] kbuild: Defer running objtool to link time for all CFG features
[PATCH v2 0/1] kbuild: record real-prereqs in .cmd files
2026-08-28 8:54 UTC (2+ messages)
` [PATCH v2 1/1] "
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox