From: "Michał Kępień" <kernel@kempniu.pl>
To: "Richard Purdie" <rpurdie@rpsys.net>,
"Jacek Anaszewski" <jacek.anaszewski@gmail.com>,
"Pavel Machek" <pavel@ucw.cz>,
"Matthew Garrett" <mjg59@srcf.ucam.org>,
"Pali Rohár" <pali.rohar@gmail.com>,
"Darren Hart" <dvhart@infradead.org>,
"Andy Shevchenko" <andy@infradead.org>,
"Jaroslav Kysela" <perex@perex.cz>,
"Takashi Iwai" <tiwai@suse.com>
Cc: linux-kernel@vger.kernel.org, Alex Hung <alex.hung@canonical.com>,
alsa-devel@alsa-project.org, linux-leds@vger.kernel.org,
platform-driver-x86@vger.kernel.org
Subject: [PATCH v3 1/7] dell-led: remove GUID check from dell_micmute_led_set()
Date: Fri, 17 Feb 2017 08:57:47 +0100 [thread overview]
Message-ID: <20170217075753.12702-2-kernel@kempniu.pl> (raw)
In-Reply-To: <20170217075753.12702-1-kernel@kempniu.pl>
As dell_micmute_led_set() no longer uses the dell_wmi_perform_query()
method, which was removed in commit 0c41a08e131d ("dell-led: use
dell_smbios_send_request() for performing SMBIOS calls"), the
DELL_APP_GUID check is redundant and thus can be safely removed.
Signed-off-by: Michał Kępień <kernel@kempniu.pl>
Tested-by: Alex Hung <alex.hung@canonical.com>
Reviewed-by: Pali Rohár <pali.rohar@gmail.com>
---
drivers/leds/dell-led.c | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/leds/dell-led.c b/drivers/leds/dell-led.c
index b3d6e9c15cf9..e8e8f67224c1 100644
--- a/drivers/leds/dell-led.c
+++ b/drivers/leds/dell-led.c
@@ -51,9 +51,6 @@ static int dell_micmute_led_set(int state)
struct calling_interface_buffer *buffer;
struct calling_interface_token *token;
- if (!wmi_has_guid(DELL_APP_GUID))
- return -ENODEV;
-
if (state == 0)
token = dell_smbios_find_token(GLOBAL_MIC_MUTE_DISABLE);
else if (state == 1)
--
2.11.1
_______________________________________________
Alsa-devel mailing list
Alsa-devel@alsa-project.org
http://mailman.alsa-project.org/mailman/listinfo/alsa-devel
next prev parent reply other threads:[~2017-02-17 7:57 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-02-17 7:57 [PATCH v3 0/7] Move dell-led to drivers/platform/x86 Michał Kępień
2017-02-17 7:57 ` Michał Kępień [this message]
2017-02-17 7:57 ` [PATCH v3 2/7] ALSA: hda - use dell_micmute_led_set() instead of dell_app_wmi_led_set() Michał Kępień
2017-02-17 7:57 ` [PATCH v3 3/7] ALSA: hda - rename dell_led_set_func to dell_micmute_led_set_func Michał Kępień
2017-02-17 7:57 ` [PATCH v3 4/7] platform/x86: dell-laptop: import dell_micmute_led_set() from drivers/leds/dell-led.c Michał Kępień
2017-02-17 7:57 ` [PATCH v3 5/7] dell-led: remove code related to mic mute LED Michał Kępień
2017-02-17 7:57 ` [PATCH v3 6/7] dell-led: move driver to drivers/platform/x86/dell-wmi-led.c Michał Kępień
2017-02-17 7:57 ` [PATCH v3 7/7] platform/x86: dell-wmi-led: fix coding style issues Michał Kępień
2017-02-17 22:15 ` [PATCH v3 0/7] Move dell-led to drivers/platform/x86 Jacek Anaszewski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170217075753.12702-2-kernel@kempniu.pl \
--to=kernel@kempniu.pl \
--cc=alex.hung@canonical.com \
--cc=alsa-devel@alsa-project.org \
--cc=andy@infradead.org \
--cc=dvhart@infradead.org \
--cc=jacek.anaszewski@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-leds@vger.kernel.org \
--cc=mjg59@srcf.ucam.org \
--cc=pali.rohar@gmail.com \
--cc=pavel@ucw.cz \
--cc=perex@perex.cz \
--cc=platform-driver-x86@vger.kernel.org \
--cc=rpurdie@rpsys.net \
--cc=tiwai@suse.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox