From: sashiko-bot@kernel.org
To: Arunachalam <arun07172003@gmail.com>
Cc: lee@kernel.org, linux-leds@vger.kernel.org
Subject: Re: [PATCH v2 4/4] leds: 88pm860x: convert to dev_err_probe()
Date: Thu, 23 Jul 2026 17:02:14 +0000 [thread overview]
Message-ID: <20260723170218.A697E1F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260723164612.3146-4-arun07172003@gmail.com>
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] The commit message lacks the mandatory subsystem prefix capitalization.
--
--- Patch [4]: [PATCH v2 4/4] leds: 88pm860x: convert to dev_err_probe() ---
commit 44af50244a910d0907f1e33477c8de6960595c9a
Author: Arunachalam <arun07172003@gmail.com>
leds: 88pm860x: convert to dev_err_probe()
This commit replaces open-coded dev_err() and return patterns with
dev_err_probe(), which also properly handles -EPROBE_DEFER.
> leds: 88pm860x: convert to dev_err_probe()
[Severity: Low]
This isn't a bug, but the description after the subsystem and driver
prefixes should be capitalized according to the LED subsystem commit
message conventions. Should this be "leds: 88pm860x: Convert to
dev_err_probe()"?
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260723164612.3146-1-arun07172003@gmail.com?part=4
next prev parent reply other threads:[~2026-07-23 17:02 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-23 16:46 [PATCH v2 1/4] leds: cobalt-raq: add missing MODULE_DESCRIPTION Arunachalam
2026-07-23 16:46 ` [PATCH v2 2/4] leds: lp8788: convert to dev_err_probe() Arunachalam
2026-07-23 16:56 ` sashiko-bot
2026-07-23 16:46 ` [PATCH v2 3/4] leds: menf21bmc: " Arunachalam
2026-07-23 16:56 ` sashiko-bot
2026-07-23 16:46 ` [PATCH v2 4/4] leds: 88pm860x: " Arunachalam
2026-07-23 17:02 ` sashiko-bot [this message]
2026-07-23 16:56 ` [PATCH v2 1/4] leds: cobalt-raq: add missing MODULE_DESCRIPTION sashiko-bot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260723170218.A697E1F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=arun07172003@gmail.com \
--cc=lee@kernel.org \
--cc=linux-leds@vger.kernel.org \
--cc=sashiko-reviews@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox