Linux Media Controller development
 help / color / mirror / Atom feed
From: "Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
To: "Rafael J. Wysocki (Intel)" <rafael@kernel.org>
Cc: Sakari Ailus <sakari.ailus@linux.intel.com>,
	linux-media@vger.kernel.org,  linux-acpi@vger.kernel.org,
	Len Brown <lenb@kernel.org>,
	 Daniel Scally <dan.scally@ideasonboard.com>,
	 Hans de Goede <hansg@kernel.org>,
	platform-driver-x86@vger.kernel.org
Subject: Re: [PATCH v2 3/5] ACPI: Support __free() from cleanup.h for ACPI objects
Date: Tue, 25 Aug 2026 15:32:18 +0300 (EEST)	[thread overview]
Message-ID: <134e9566-7913-86d7-1e8b-b2ca9ebec55c@linux.intel.com> (raw)
In-Reply-To: <CAJZ5v0gQVFxSkkjPbRf6bsKdgUBGduZV0M5SWrHoeB246ZLqew@mail.gmail.com>

[-- Attachment #1: Type: text/plain, Size: 1869 bytes --]

On Tue, 25 Aug 2026, Rafael J. Wysocki (Intel) wrote:

> On Tue, Aug 25, 2026 at 2:07 PM Sakari Ailus
> <sakari.ailus@linux.intel.com> wrote:
> >
> > Hi Rafael,
> >
> > On Tue, Aug 25, 2026 at 01:51:18PM +0200, Rafael J. Wysocki (Intel) wrote:
> > > On Mon, Aug 24, 2026 at 11:13 PM Sakari Ailus
> > > <sakari.ailus@linux.intel.com> wrote:
> > > >
> > > > Use DEFINE_FREE() to allow ACPI objects to be released automatically.
> > >
> > > But at least some of them are allocated by ACPICA functions like
> > > acpi_evaluate_object() and so they have no proper constructors.
> >
> > You could still assign the return buffer to a local variable. It's not
> > ideal API-wise though.
> 
> Exactly.
> 
> > I'm not quite sure what was the point you wanted to make but I reckon this
> > wasn't an ack. :-)
> 
> Using the _FREE with variables that are not initialized through a
> constructor is questionable, so this is generally not particularly
> clean.

The driver does call ACPI_FREE() for that pointer so clearly it's already 
using something ending with "_FREE" already. So unless Rafael is 
suggesting ACPI_FREE() should be renamed, I'm a bit lost what that 
even means on concrete terms.

> There is no cleanup.h in ACPICA that is a more traditional C code
> base, so mixing up ACPICA code, which ACPI_FREE() is strictly
> speaking, with cleanup.h stuff is not particularly straightforward
> IMV.  I'd rather not do it.

Perhaps add the DEFINE_FREE() into int3472 driver then, it seems to be 
what intel/pmc is already doing (I don't seem to anymore recall why it was 
added there). Using cleanup.h for that variable it clearly simplifies the 
code flow. It feels a bit stupid to duplicate it there but I guess we'll 
just have to live with that if there's no place in any acpi related 
headers for cleanup.h.

-- 
 i.

  reply	other threads:[~2026-08-25 12:32 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-24 21:13 [PATCH v2 0/5] Fix static analyser and compiler warnings in int3472 Sakari Ailus
2026-08-24 21:13 ` [PATCH v2 1/5] platform/x86: int3472: Address Coccinelle warning on an error print Sakari Ailus
2026-08-24 21:13 ` [PATCH v2 2/5] platform/x86: int3472: Fix uninitialised variable warning Sakari Ailus
2026-08-24 21:13 ` [PATCH v2 3/5] ACPI: Support __free() from cleanup.h for ACPI objects Sakari Ailus
2026-08-25 11:51   ` Rafael J. Wysocki (Intel)
2026-08-25 12:07     ` Sakari Ailus
2026-08-25 12:18       ` Rafael J. Wysocki (Intel)
2026-08-25 12:32         ` Ilpo Järvinen [this message]
2026-08-25 13:02           ` Rafael J. Wysocki (Intel)
2026-08-25 13:08             ` Rafael J. Wysocki (Intel)
2026-08-25 13:51               ` Ilpo Järvinen
2026-08-25 14:42                 ` Rafael J. Wysocki (Intel)
2026-08-25 19:35               ` Sakari Ailus
2026-08-26  9:04                 ` Ilpo Järvinen
2026-08-26 10:17                   ` Rafael J. Wysocki (Intel)
2026-08-25 13:37             ` Ilpo Järvinen
2026-08-25 13:49               ` Rafael J. Wysocki (Intel)
2026-08-24 21:13 ` [PATCH v2 4/5] platform/x86: int3472: Release ACPI objects using __free() Sakari Ailus
2026-08-25 11:54   ` Rafael J. Wysocki (Intel)
2026-08-25 12:04     ` Sakari Ailus
2026-08-25 12:32       ` Rafael J. Wysocki (Intel)
2026-08-24 21:13 ` [PATCH v2 5/5] platform/x86: int3472: Clean up GPIO parsing Sakari Ailus
2026-08-25 10:40   ` Ilpo Järvinen
2026-08-25 10:54     ` Sakari Ailus

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=134e9566-7913-86d7-1e8b-b2ca9ebec55c@linux.intel.com \
    --to=ilpo.jarvinen@linux.intel.com \
    --cc=dan.scally@ideasonboard.com \
    --cc=hansg@kernel.org \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=platform-driver-x86@vger.kernel.org \
    --cc=rafael@kernel.org \
    --cc=sakari.ailus@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox