From: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
To: Sakari Ailus <sakari.ailus@iki.fi>
Cc: Philippe De Muyter <phdm@macq.eu>,
Hans Verkuil <hverkuil@xs4all.nl>,
Luca Ceresoli <luca@lucaceresoli.net>,
linux-media@vger.kernel.org, Leon Luo <leonl@leopardimaging.com>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
Sakari Ailus <sakari.ailus@linux.intel.com>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 3/7] media: imx274: don't hard-code the subdev name to DRIVER_NAME
Date: Thu, 30 Aug 2018 00:23:23 +0300 [thread overview]
Message-ID: <1552922.PBQrL6RDxY@avalon> (raw)
In-Reply-To: <20180829113843.4v63cxf3clvbzbtd@valkosipuli.retiisi.org.uk>
Hello,
On Wednesday, 29 August 2018 14:38:43 EEST Sakari Ailus wrote:
> On Wed, Aug 29, 2018 at 01:29:36PM +0200, Philippe De Muyter wrote:
> > On Wed, Aug 29, 2018 at 02:07:21PM +0300, Sakari Ailus wrote:
> >> On Tue, Aug 28, 2018 at 06:02:55PM +0200, Philippe De Muyter wrote:
[snip]
> >>> Then we should probably also apply the following patch I submitted :
> >>>
> >>> "media: v4l2-common: v4l2_spi_subdev_init : generate unique name"
> >>>
> >>> https://patchwork.kernel.org/patch/10553035/
> >>>
> >>> and perhaps
> >>>
> >>> "media: v4l2-common: simplify v4l2_i2c_subdev_init name generation"
> >>>
> >>> https://patchwork.kernel.org/patch/10553037/
> >>
> >> The problem with this patch is that the existing naming scheme is very
> >> similar while the new one offers no tangible benefits apart from being
> >> in line with the rest of the kernel. That's still not a benefit for uAPI:
> >> changing the name is certain to break user space applications.
> >
> > I agree with you on the patch for v4l2_i2c_subdev_init (I wrote
> > 'perhaps'), but you don't say anything on the one about
> > v4l2_spi_subdev_init :), which fixes an actual bug. I have 2 identical
> > SPI-controlled sensors on the same board, and without my patch they get
> > the same subdev name. Of course, I could fix that in the sensor driver
> > itself, but that's not what we want, or do we ?
>
> Good point. I missed the naming of the SPI devices ignored any bus
> information there. I'm rather inclined towards taking the SPI patch. Hans,
> Mauro, Laurent; any opinion on that?
I agree that the SPI patch makes sense, I think we should take it.
--
Regards,
Laurent Pinchart
next prev parent reply other threads:[~2018-08-30 1:22 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-08-24 16:35 [PATCH 0/7] media: imx274: miscellaneous improvements Luca Ceresoli
2018-08-24 16:35 ` [PATCH 1/7] media: imx274: rename IMX274_DEFAULT_MODE to IMX274_DEFAULT_BINNING Luca Ceresoli
2018-08-24 16:35 ` [PATCH 2/7] media: imx274: rearrange sensor startup register tables Luca Ceresoli
2018-08-24 16:35 ` [PATCH 3/7] media: imx274: don't hard-code the subdev name to DRIVER_NAME Luca Ceresoli
2018-08-25 14:49 ` Sakari Ailus
2018-08-26 20:41 ` Luca Ceresoli
2018-08-28 8:11 ` Philippe De Muyter
2018-08-28 9:22 ` Hans Verkuil
2018-08-28 16:02 ` Philippe De Muyter
2018-08-29 11:07 ` Sakari Ailus
2018-08-29 11:29 ` Philippe De Muyter
2018-08-29 11:38 ` Sakari Ailus
2018-08-29 21:23 ` Laurent Pinchart [this message]
2018-08-30 6:58 ` Philippe De Muyter
2018-08-30 9:33 ` Sakari Ailus
2018-08-24 16:35 ` [PATCH 4/7] media: imx274: rename frmfmt and format to "mode" Luca Ceresoli
2018-08-24 16:35 ` [PATCH 5/7] media: imx274: fix error in function docs Luca Ceresoli
2018-08-24 16:35 ` [PATCH 6/7] media: imx274: add helper to read multibyte registers Luca Ceresoli
2018-08-24 16:35 ` [PATCH 7/7] media: imx274: switch to SPDX license identifier Luca Ceresoli
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1552922.PBQrL6RDxY@avalon \
--to=laurent.pinchart@ideasonboard.com \
--cc=hverkuil@xs4all.nl \
--cc=leonl@leopardimaging.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=luca@lucaceresoli.net \
--cc=mchehab@kernel.org \
--cc=phdm@macq.eu \
--cc=sakari.ailus@iki.fi \
--cc=sakari.ailus@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox