From: Mauro Carvalho Chehab <m.chehab@samsung.com>
To: Hans Verkuil <hverkuil@xs4all.nl>
Cc: Fengguang Wu <fengguang.wu@intel.com>,
Linux Media Mailing List <linux-media@vger.kernel.org>,
Mauro Carvalho Chehab <mchehab@infradead.org>
Subject: Re: [RFC PATCH 1/3] dvbdev: add a dvb_dettach() macro
Date: Sat, 15 Mar 2014 11:06:59 -0300 [thread overview]
Message-ID: <20140315110659.5f435b40@samsung.com> (raw)
In-Reply-To: <532459E8.9060903@xs4all.nl>
Em Sat, 15 Mar 2014 14:47:20 +0100
Hans Verkuil <hverkuil@xs4all.nl> escreveu:
> Hi Mauro,
>
> On 03/15/2014 02:43 PM, Mauro Carvalho Chehab wrote:
> > The dvb_attach() was unbalanced, as there was no dvb_dettach. Ok,
> > on current cases, the dettach is done by dvbdev, but that are some
> > future corner cases where we may need to do this before registering
> > the frontend.
> >
> > So, add a dvb_dettach() and use it at dvb_frontend.c.
>
> Typo: it's spelled 'detach', one 't'.
Fixed, thanks!
The new patches are at:
http://git.linuxtv.org/mchehab/experimental.git/shortlog/refs/heads/dvb_detach
I always assumed that this would be symmetrical, but English is not
always logic ;)
PS.: I won't send a v2 of this RFC patch series just due to that,
as this is just a "cosmetic" correction. So, I'll wait for more
changes before sending a v2.
>
> Regards,
>
> Hans
>
> >
> > Signed-off-by: Mauro Carvalho Chehab <m.chehab@samsung.com>
> > ---
> > drivers/media/dvb-core/dvb_frontend.c | 8 ++++----
> > drivers/media/dvb-core/dvbdev.h | 4 ++++
> > 2 files changed, 8 insertions(+), 4 deletions(-)
> >
> > diff --git a/drivers/media/dvb-core/dvb_frontend.c b/drivers/media/dvb-core/dvb_frontend.c
> > index 6ce435ac866f..24cf4fbf92a8 100644
> > --- a/drivers/media/dvb-core/dvb_frontend.c
> > +++ b/drivers/media/dvb-core/dvb_frontend.c
> > @@ -2666,20 +2666,20 @@ void dvb_frontend_detach(struct dvb_frontend* fe)
> >
> > if (fe->ops.release_sec) {
> > fe->ops.release_sec(fe);
> > - symbol_put_addr(fe->ops.release_sec);
> > + dvb_dettach(fe->ops.release_sec);
> > }
> > if (fe->ops.tuner_ops.release) {
> > fe->ops.tuner_ops.release(fe);
> > - symbol_put_addr(fe->ops.tuner_ops.release);
> > + dvb_dettach(fe->ops.tuner_ops.release);
> > }
> > if (fe->ops.analog_ops.release) {
> > fe->ops.analog_ops.release(fe);
> > - symbol_put_addr(fe->ops.analog_ops.release);
> > + dvb_dettach(fe->ops.analog_ops.release);
> > }
> > ptr = (void*)fe->ops.release;
> > if (ptr) {
> > fe->ops.release(fe);
> > - symbol_put_addr(ptr);
> > + dvb_dettach(ptr);
> > }
> > }
> > #else
> > diff --git a/drivers/media/dvb-core/dvbdev.h b/drivers/media/dvb-core/dvbdev.h
> > index 93a9470d3f0c..49904efc476c 100644
> > --- a/drivers/media/dvb-core/dvbdev.h
> > +++ b/drivers/media/dvb-core/dvbdev.h
> > @@ -136,11 +136,15 @@ extern int dvb_usercopy(struct file *file, unsigned int cmd, unsigned long arg,
> > __r; \
> > })
> >
> > +#define dvb_dettach(FUNC) symbol_put_addr(FUNC)
> > +
> > #else
> > #define dvb_attach(FUNCTION, ARGS...) ({ \
> > FUNCTION(ARGS); \
> > })
> >
> > +#define dvb_dettach(FUNC) {}
> > +
> > #endif
> >
> > #endif /* #ifndef _DVBDEV_H_ */
> >
>
--
Regards,
Mauro
next prev parent reply other threads:[~2014-03-15 14:07 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-03-15 13:43 [RFC PATCH 0/3] Fix compilation breakages with dib7000p Mauro Carvalho Chehab
2014-03-15 13:43 ` [RFC PATCH 1/3] dvbdev: add a dvb_dettach() macro Mauro Carvalho Chehab
2014-03-15 13:47 ` Hans Verkuil
2014-03-15 14:06 ` Mauro Carvalho Chehab [this message]
2014-03-15 13:43 ` [RFC PATCH 2/3] dib7000p: rename dvb_attach to dvb_init Mauro Carvalho Chehab
2014-03-15 13:43 ` [RFC PATCH 3/3] dib7000: export just one symbol Mauro Carvalho Chehab
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140315110659.5f435b40@samsung.com \
--to=m.chehab@samsung.com \
--cc=fengguang.wu@intel.com \
--cc=hverkuil@xs4all.nl \
--cc=linux-media@vger.kernel.org \
--cc=mchehab@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox