From: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
To: Sakari Ailus <sakari.ailus@linux.intel.com>
Cc: linux-media@vger.kernel.org, hdegoede@redhat.com
Subject: Re: [PATCH v2 5/6] media: ccs: Better separate CCS static data access
Date: Mon, 13 Nov 2023 15:57:10 +0200 [thread overview]
Message-ID: <20231113135710.GG24338@pendragon.ideasonboard.com> (raw)
In-Reply-To: <20231113134458.1423754-6-sakari.ailus@linux.intel.com>
Hi Sakari,
Thank you for the patch.
On Mon, Nov 13, 2023 at 03:44:57PM +0200, Sakari Ailus wrote:
> Separate CCS static data read-only register access in ccs-reg-access.c by
> naming them differently.
"naming the access functions differently"
> The code in this file generally deals with reading and writing registers
> where as static data (when it comes to ccs_static_read_only()) contains
> the read-only register values but no hardware registers are accessed in
> that case.
>
> Signed-off-by: Sakari Ailus <sakari.ailus@linux.intel.com>
> ---
> .../driver-api/media/drivers/ccs/mk-ccs-regs | 2 +-
> drivers/media/i2c/ccs/ccs-reg-access.c | 20 +++++++++----------
> 2 files changed, 11 insertions(+), 11 deletions(-)
>
> diff --git a/Documentation/driver-api/media/drivers/ccs/mk-ccs-regs b/Documentation/driver-api/media/drivers/ccs/mk-ccs-regs
> index 01252ee6062b..3d3152b45821 100755
> --- a/Documentation/driver-api/media/drivers/ccs/mk-ccs-regs
> +++ b/Documentation/driver-api/media/drivers/ccs/mk-ccs-regs
> @@ -136,7 +136,7 @@ if (! defined $kernel) {
>
> print $H "#define CCS_FL_FLOAT_IREAL " . flag_str(\$flag, \$all_flags) . "\n";
> print $H "#define CCS_FL_IREAL " . flag_str(\$flag, \$all_flags) . "\n";
> -print $H "#define CCS_BUILD_BUG \
> +print $H "#define CCS_BUILD_BUG \\
This doesn't seem related.
> BUILD_BUG_ON(~CCI_REG_PRIVATE_MASK & ($all_flags))\n"
> if defined $kernel;
>
> diff --git a/drivers/media/i2c/ccs/ccs-reg-access.c b/drivers/media/i2c/ccs/ccs-reg-access.c
> index 25993445f4fe..652d705a2ef5 100644
> --- a/drivers/media/i2c/ccs/ccs-reg-access.c
> +++ b/drivers/media/i2c/ccs/ccs-reg-access.c
> @@ -197,8 +197,8 @@ static int __ccs_read_addr(struct ccs_sensor *sensor, u32 reg, u32 *val,
> return 0;
> }
>
> -static int __ccs_read_data(struct ccs_reg *regs, size_t num_regs,
> - u32 reg, u32 *val)
> +static int __ccs_static_read_only(struct ccs_reg *regs, size_t num_regs,
"static read only" sounds weird when interpreting "read" as a verb. And
if "read" is not a verb, you're missing a verb :-) Maybe
__ccs_read_state_data() would be a better name ? Same below.
> + u32 reg, u32 *val)
> {
> unsigned int width = ccs_reg_width(reg);
> size_t i;
> @@ -235,16 +235,16 @@ static int __ccs_read_data(struct ccs_reg *regs, size_t num_regs,
> return -ENOENT;
> }
>
> -static int ccs_read_data(struct ccs_sensor *sensor, u32 reg, u32 *val)
> +static int ccs_static_read_only(struct ccs_sensor *sensor, u32 reg, u32 *val)
> {
> - if (!__ccs_read_data(sensor->sdata.sensor_read_only_regs,
> - sensor->sdata.num_sensor_read_only_regs,
> - reg, val))
> + if (!__ccs_static_read_only(sensor->sdata.sensor_read_only_regs,
> + sensor->sdata.num_sensor_read_only_regs,
> + reg, val))
> return 0;
>
> - return __ccs_read_data(sensor->mdata.module_read_only_regs,
> - sensor->mdata.num_module_read_only_regs,
> - reg, val);
> + return __ccs_static_read_only(sensor->mdata.module_read_only_regs,
> + sensor->mdata.num_module_read_only_regs,
> + reg, val);
> }
>
> static int ccs_read_addr_raw(struct ccs_sensor *sensor, u32 reg, u32 *val,
> @@ -253,7 +253,7 @@ static int ccs_read_addr_raw(struct ccs_sensor *sensor, u32 reg, u32 *val,
> int rval;
>
> if (data) {
> - rval = ccs_read_data(sensor, reg, val);
> + rval = ccs_static_read_only(sensor, reg, val);
> if (!rval)
> return 0;
> }
--
Regards,
Laurent Pinchart
next prev parent reply other threads:[~2023-11-13 13:57 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-11-13 13:44 [PATCH v2 0/6] Use V4L2 CCI in CCS driver Sakari Ailus
2023-11-13 13:44 ` [PATCH v2 1/6] media: v4l: cci: Include linux/bits.h Sakari Ailus
2023-11-13 13:44 ` [PATCH v2 2/6] media: v4l: cci: Add driver-private bit definitions Sakari Ailus
2023-11-13 13:53 ` Laurent Pinchart
2023-11-13 13:54 ` Laurent Pinchart
2023-11-13 13:56 ` Sakari Ailus
2023-11-13 13:54 ` Sakari Ailus
2023-11-13 13:44 ` [PATCH v2 3/6] media: v4l: cci: Add macros to obtain register width and address Sakari Ailus
2023-11-13 13:44 ` [PATCH v2 4/6] media: ccs: Generate V4L2 CCI compliant register definitions Sakari Ailus
2023-11-13 13:44 ` [PATCH v2 5/6] media: ccs: Better separate CCS static data access Sakari Ailus
2023-11-13 13:57 ` Laurent Pinchart [this message]
2023-11-13 14:08 ` Sakari Ailus
2023-11-13 14:16 ` Laurent Pinchart
2023-11-13 16:00 ` Sakari Ailus
2023-11-13 13:44 ` [PATCH v2 6/6] media: ccs: Use V4L2 CCI for accessing sensor registers Sakari Ailus
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20231113135710.GG24338@pendragon.ideasonboard.com \
--to=laurent.pinchart@ideasonboard.com \
--cc=hdegoede@redhat.com \
--cc=linux-media@vger.kernel.org \
--cc=sakari.ailus@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox