From: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
To: Sakari Ailus <sakari.ailus@linux.intel.com>
Cc: linux-media@vger.kernel.org
Subject: Re: [PATCH v2 1/1] media: mc: Rename pad as origin in __media_pipeline_start()
Date: Tue, 5 Nov 2024 10:03:07 +0200 [thread overview]
Message-ID: <20241105080307.GE27775@pendragon.ideasonboard.com> (raw)
In-Reply-To: <20241105064012.500501-1-sakari.ailus@linux.intel.com>
Hi Sakari,
Thank you for the patch.
On Tue, Nov 05, 2024 at 08:40:12AM +0200, Sakari Ailus wrote:
> Rename the pad field in __media_pipeline_start() to both better describe
> what it is and avoid masking it during the loop.
>
> Signed-off-by: Sakari Ailus <sakari.ailus@linux.intel.com>
> Reviewed-by: Laurent Pinchart <laurent.pinchart+renesas@ideasonboard.com>
> ---
> since v1:
>
> - Also change the argument name in the prototype.
>
> drivers/media/mc/mc-entity.c | 8 ++++----
> include/media/media-entity.h | 4 ++--
> 2 files changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/media/mc/mc-entity.c b/drivers/media/mc/mc-entity.c
> index 96dd0f6ccd0d..0df9fc90cf33 100644
> --- a/drivers/media/mc/mc-entity.c
> +++ b/drivers/media/mc/mc-entity.c
> @@ -768,10 +768,10 @@ static int media_pipeline_populate(struct media_pipeline *pipe,
> return ret;
> }
>
> -__must_check int __media_pipeline_start(struct media_pad *pad,
> +__must_check int __media_pipeline_start(struct media_pad *origin,
> struct media_pipeline *pipe)
> {
> - struct media_device *mdev = pad->graph_obj.mdev;
> + struct media_device *mdev = origin->graph_obj.mdev;
> struct media_pipeline_pad *err_ppad;
> struct media_pipeline_pad *ppad;
> int ret;
> @@ -782,7 +782,7 @@ __must_check int __media_pipeline_start(struct media_pad *pad,
> * If the pad is already part of a pipeline, that pipeline must be the
> * same as the pipe given to media_pipeline_start().
> */
> - if (WARN_ON(pad->pipe && pad->pipe != pipe))
> + if (WARN_ON(origin->pipe && origin->pipe != pipe))
> return -EINVAL;
>
> /*
> @@ -799,7 +799,7 @@ __must_check int __media_pipeline_start(struct media_pad *pad,
> * with media_pipeline_pad instances for each pad found during graph
> * walk.
> */
> - ret = media_pipeline_populate(pipe, pad);
> + ret = media_pipeline_populate(pipe, origin);
> if (ret)
> return ret;
>
> diff --git a/include/media/media-entity.h b/include/media/media-entity.h
> index 0393b23129eb..2fca4556c311 100644
> --- a/include/media/media-entity.h
> +++ b/include/media/media-entity.h
> @@ -1143,7 +1143,7 @@ struct media_entity *media_graph_walk_next(struct media_graph *graph);
>
> /**
> * media_pipeline_start - Mark a pipeline as streaming
> - * @pad: Starting pad
> + * @origin: Starting pad
> * @pipe: Media pipeline to be assigned to all pads in the pipeline.
> *
> * Mark all pads connected to a given pad through enabled links, either
s/to a given pad/to the given @starting pad/
> @@ -1155,7 +1155,7 @@ struct media_entity *media_graph_walk_next(struct media_graph *graph);
> * pipeline pointer must be identical for all nested calls to
> * media_pipeline_start().
> */
> -__must_check int media_pipeline_start(struct media_pad *pad,
> +__must_check int media_pipeline_start(struct media_pad *origin,
> struct media_pipeline *pipe);
> /**
> * __media_pipeline_start - Mark a pipeline as streaming
The documentation for __media_pipeline_start needs a similar update.
--
Regards,
Laurent Pinchart
next prev parent reply other threads:[~2024-11-05 8:03 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-11-05 6:40 [PATCH v2 1/1] media: mc: Rename pad as origin in __media_pipeline_start() Sakari Ailus
2024-11-05 8:03 ` Laurent Pinchart [this message]
2024-11-05 8:14 ` Sakari Ailus
2024-11-05 8:27 ` Laurent Pinchart
2024-11-05 8:29 ` Sakari Ailus
2024-11-05 8:37 ` Laurent Pinchart
2024-11-05 8:44 ` Sakari Ailus
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20241105080307.GE27775@pendragon.ideasonboard.com \
--to=laurent.pinchart@ideasonboard.com \
--cc=linux-media@vger.kernel.org \
--cc=sakari.ailus@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox