From: Matt Evans <matt@ozlabs.org>
To: Alex Williamson <alex@shazbot.org>
Cc: "Leon Romanovsky" <leon@kernel.org>,
"Jason Gunthorpe" <jgg@nvidia.com>,
"Alex Mastro" <amastro@fb.com>,
"Christian König" <christian.koenig@amd.com>,
"Bjorn Helgaas" <bhelgaas@google.com>,
"Logan Gunthorpe" <logang@deltatee.com>,
"Kevin Tian" <kevin.tian@intel.com>,
"Pranjal Shrivastava" <praan@google.com>,
"Longfang Liu" <liulongfang@huawei.com>,
"Mahmoud Adam" <mngyadam@amazon.de>,
"David Matlack" <dmatlack@google.com>,
"Björn Töpel" <bjorn@kernel.org>,
"Sumit Semwal" <sumit.semwal@linaro.org>,
"Ankit Agrawal" <ankita@nvidia.com>,
"Alistair Popple" <apopple@nvidia.com>,
"Vivek Kasireddy" <vivek.kasireddy@intel.com>,
linux-kernel@vger.kernel.org, linux-media@vger.kernel.org,
dri-devel@lists.freedesktop.org, linaro-mm-sig@lists.linaro.org,
kvm@vger.kernel.org, linux-pci@vger.kernel.org
Subject: Re: [PATCH v5 7/9] vfio/pci: Clean up BAR zap and revocation
Date: Thu, 13 Aug 2026 16:49:55 +0100 [thread overview]
Message-ID: <2ba56abd-797c-4051-b345-e025a5ed0421@ozlabs.org> (raw)
In-Reply-To: <20260812140657.247b9fa3@shazbot.org>
Hola Alex,
On 12/08/2026 21:06, Alex Williamson wrote:
> On Tue, 11 Aug 2026 16:58:43 +0100
> Matt Evans <matt@ozlabs.org> wrote:
>
>> Hi Alex,
>>
>> [snip]
>> Isn't the init-time 'event horizon' for writing the bitfield the
>> vfio_register_group_dev() in vfio_pci_core_register_device(), after
>> which synchronisation is needed?
>>
>> The hisi_acc_vfio_pci driver's .probe calls
>> vfio_pci_core_register_device() and _after that_ sets
>> zap_bars_on_revoke, and that's now in the "needs synchronisation to
>> write the bitfield" phase.
>>
>> (Re-reading my comment in vfio_pci_core_register_device() I'd noted
>> this, "Drivers can opt out after registration". Has to be done after by
>> definition as the default's set in vfio_pci_core_register_device().)
>>
>> The concern is just blatting neighbours in the bitfield, not the window
>> of time before the flag's set. The flag's an opt-out of a safe but (for
>> this driver) unnecessary zap, so having it unset for a short time is OK.
>>
>> I still think this really should be a standalone bool, not a bit in the
>> bitfield. It has to be set after registration and having to take a lock
>> to do that has downsides.
>
> You're right on the ordering, the device is live after
> vfio_pci_core_register_device(). However, I think that's evidence that
> vfio-pci-core is setting the default polarity, inferred from the mmap
> op, in the wrong place. It should happen in init, not register_device.
>
> The same mmap op pointer is available in vfio_pci_core_init_dev(), which
Ahaa, they're passed into vfio_alloc_device()!
> is used by all vfio-pci variant drivers in their init callback. The
> proposed vfio_pci_core_register_device() change just needs to be lifted
> into vfio_pci_core_init_dev(). hisi_acc is then modified to fix the
> flag after vfio_pci_core_init_dev(), something like below.
>
> I think that's better than anticipating it being dynamic when we don't
> have a use case that requires it. Thanks,
Yes, that works nicely. Done. As ever, thanks for the suggestion.
Matt
PS: Series v6 has several improvements/review fixes ready, but I'm
holding off posting it. It'd depend on resolving the awful deadlock I
posted about on patch [4/9].
>
> Alex
>
> --- a/drivers/vfio/pci/hisilicon/hisi_acc_vfio_pci.c
> +++ b/drivers/vfio/pci/hisilicon/hisi_acc_vfio_pci.c
> @@ -1564,6 +1564,7 @@ static int hisi_acc_vfio_pci_migrn_init_dev(struct vfio_device *core_vdev)
> struct hisi_acc_vf_core_device *hisi_acc_vdev = hisi_acc_get_vf_dev(core_vdev);
> struct pci_dev *pdev = to_pci_dev(core_vdev->dev);
> struct hisi_qm *pf_qm = hisi_acc_get_pf_qm(pdev);
> + int ret;
>
> hisi_acc_vdev->vf_id = pci_iov_vf_id(pdev) + 1;
> hisi_acc_vdev->pf_qm = pf_qm;
> @@ -1575,7 +1576,9 @@ static int hisi_acc_vfio_pci_migrn_init_dev(struct vfio_device *core_vdev)
> core_vdev->migration_flags = VFIO_MIGRATION_STOP_COPY | VFIO_MIGRATION_PRE_COPY;
> core_vdev->mig_ops = &hisi_acc_vfio_pci_migrn_state_ops;
>
> - return vfio_pci_core_init_dev(core_vdev);
> + ret = vfio_pci_core_init_dev(core_vdev);
> + hisi_acc_vdev->core_device.zap_bars_on_revoke = false;
> + return ret;
> }
>
> static const struct vfio_device_ops hisi_acc_vfio_pci_migrn_ops = {
next prev parent reply other threads:[~2026-08-13 15:50 UTC|newest]
Thread overview: 57+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-15 17:47 [PATCH v5 0/9] vfio/pci: Add mmap() for DMABUFs Matt Evans
2026-07-15 17:47 ` [PATCH v5 1/9] PCI/P2PDMA: Split pool-related cleanup out of pci_p2pdma_release() Matt Evans
2026-07-17 8:02 ` Tian, Kevin
2026-07-28 22:33 ` Alex Williamson
2026-07-29 10:08 ` Leon Romanovsky
2026-08-05 0:31 ` Jason Gunthorpe
2026-07-30 16:45 ` Pranjal Shrivastava
2026-07-15 17:47 ` [PATCH v5 2/9] PCI/P2PDMA: Add CONFIG_PCI_P2PDMA_CORE Matt Evans
2026-07-17 8:02 ` Tian, Kevin
2026-07-30 19:37 ` Pranjal Shrivastava
2026-08-04 15:42 ` Matt Evans
2026-08-04 16:19 ` Logan Gunthorpe
2026-08-05 0:39 ` Jason Gunthorpe
2026-08-05 16:28 ` Matt Evans
2026-08-05 16:40 ` Jason Gunthorpe
2026-08-05 20:50 ` Logan Gunthorpe
2026-08-11 13:45 ` Matt Evans
2026-08-11 14:01 ` Jason Gunthorpe
2026-07-15 17:47 ` [PATCH v5 3/9] vfio/pci: Add a helper to look up PFNs for DMABUFs Matt Evans
2026-07-17 8:02 ` Tian, Kevin
2026-07-29 17:52 ` Alex Williamson
2026-07-30 17:34 ` Matt Evans
2026-07-30 22:55 ` Pranjal Shrivastava
2026-07-31 17:43 ` Matt Evans
2026-08-03 18:22 ` Matt Evans
2026-08-04 19:01 ` Pranjal Shrivastava
2026-08-05 0:41 ` Jason Gunthorpe
2026-07-15 17:47 ` [PATCH v5 4/9] vfio/pci: Add a helper to create a DMABUF for a BAR-map VMA Matt Evans
2026-08-12 22:39 ` Matt Evans
2026-07-15 17:47 ` [PATCH v5 5/9] vfio/pci: Convert BAR mmap() to use a DMABUF Matt Evans
2026-07-15 17:47 ` [PATCH v5 6/9] vfio/pci: Provide a user-facing name for BAR mappings Matt Evans
2026-07-17 8:03 ` Tian, Kevin
2026-07-29 17:52 ` Alex Williamson
2026-07-30 14:37 ` Matt Evans
2026-07-15 17:47 ` [PATCH v5 7/9] vfio/pci: Clean up BAR zap and revocation Matt Evans
2026-07-17 8:03 ` Tian, Kevin
2026-07-29 17:52 ` Alex Williamson
2026-07-30 14:47 ` Matt Evans
2026-08-04 20:10 ` Alex Williamson
2026-08-05 13:58 ` Matt Evans
2026-08-11 15:58 ` Matt Evans
2026-08-12 20:06 ` Alex Williamson
2026-08-13 15:49 ` Matt Evans [this message]
2026-07-30 23:20 ` Pranjal Shrivastava
2026-07-15 17:47 ` [PATCH v5 8/9] vfio/pci: Support mmap() of a VFIO DMABUF Matt Evans
2026-07-17 8:03 ` Tian, Kevin
2026-07-30 23:33 ` Pranjal Shrivastava
2026-07-15 17:47 ` [PATCH v5 9/9] vfio/pci: Permanently revoke a DMABUF on request Matt Evans
2026-07-17 8:03 ` Tian, Kevin
2026-07-30 23:43 ` Pranjal Shrivastava
2026-07-15 18:12 ` [PATCH v5 0/9] vfio/pci: Add mmap() for DMABUFs David Matlack
2026-07-16 14:51 ` Matt Evans
2026-07-16 21:23 ` David Matlack
2026-07-17 8:42 ` David Laight
2026-07-17 16:30 ` David Matlack
2026-07-17 17:12 ` Matt Evans
2026-07-20 21:50 ` David Matlack
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2ba56abd-797c-4051-b345-e025a5ed0421@ozlabs.org \
--to=matt@ozlabs.org \
--cc=alex@shazbot.org \
--cc=amastro@fb.com \
--cc=ankita@nvidia.com \
--cc=apopple@nvidia.com \
--cc=bhelgaas@google.com \
--cc=bjorn@kernel.org \
--cc=christian.koenig@amd.com \
--cc=dmatlack@google.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=jgg@nvidia.com \
--cc=kevin.tian@intel.com \
--cc=kvm@vger.kernel.org \
--cc=leon@kernel.org \
--cc=linaro-mm-sig@lists.linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=liulongfang@huawei.com \
--cc=logang@deltatee.com \
--cc=mngyadam@amazon.de \
--cc=praan@google.com \
--cc=sumit.semwal@linaro.org \
--cc=vivek.kasireddy@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox