From: Hans Verkuil <hverkuil+cisco@kernel.org>
To: Sakari Ailus <sakari.ailus@linux.intel.com>, linux-media@vger.kernel.org
Cc: laurent.pinchart@ideasonboard.com,
Prabhakar <prabhakar.csengg@gmail.com>,
"Kate Hsuan" <hpa@redhat.com>,
"Dave Stevenson" <dave.stevenson@raspberrypi.com>,
"Tommaso Merciai" <tomm.merciai@gmail.com>,
"Benjamin Mugnier" <benjamin.mugnier@foss.st.com>,
"Sylvain Petinot" <sylvain.petinot@foss.st.com>,
"Christophe JAILLET" <christophe.jaillet@wanadoo.fr>,
"Julien Massot" <julien.massot@collabora.com>,
"Naushir Patuck" <naush@raspberrypi.com>,
"Yan, Dongcheng" <dongcheng.yan@intel.com>,
"Stefan Klug" <stefan.klug@ideasonboard.com>,
"Mirela Rabulea" <mirela.rabulea@nxp.com>,
"André Apitzsch" <git@apitzsch.eu>,
"Heimir Thor Sverrisson" <heimir.sverrisson@gmail.com>,
"Kieran Bingham" <kieran.bingham@ideasonboard.com>,
"Mehdi Djait" <mehdi.djait@linux.intel.com>,
"Ricardo Ribalda Delgado" <ribalda@kernel.org>,
"Hans de Goede" <hansg@kernel.org>,
"Jacopo Mondi" <jacopo.mondi@ideasonboard.com>,
"Tomi Valkeinen" <tomi.valkeinen@ideasonboard.com>,
"David Plowman" <david.plowman@raspberrypi.com>,
"Yu, Ong Hock" <ong.hock.yu@intel.com>,
"Ng, Khai Wen" <khai.wen.ng@intel.com>,
"Jai Luthra" <jai.luthra@ideasonboard.com>,
"Rishikesh Donadkar" <r-donadkar@ti.com>
Subject: Re: [PATCH v7 11/14] media: v4l2-subdev: Add v4l2_subdev_call_ci_state_{active,try}
Date: Mon, 10 Aug 2026 16:12:31 +0200 [thread overview]
Message-ID: <65b0c3ab-ae76-49ec-824a-b9d882c28a5c@kernel.org> (raw)
In-Reply-To: <20260807122409.45807-12-sakari.ailus@linux.intel.com>
On 07/08/2026 14:24, Sakari Ailus wrote:
> Add v4l2_subdev_call_ci_state_active(), and
> v4l2_subdev_call_ci_state_try() to call sub-device pad ops that
> take struct v4l2_subdev_client_info pointer as an argument. These ops
> cannot be called using v4l2_subdev_call_state_active() or
> v4l2_subdev_call_state_try() as the client_info argument precedes the
> state argument.
So if we have to jump through all these hoops just because the client_info
pointer precedes the state pointer in the pad op argument list, wouldn't it
be better to swap the order? For example by moving the client_info pointer
as the last argument?
Honestly, these macros are getting really hard to follow, and I'm not sure
it is worth it just to keep the client_info before the state pointer. Yes, that's
the logical order, but at the price of some very hard to read defines.
Or am I missing something?
Regards,
Hans
>
> Signed-off-by: Sakari Ailus <sakari.ailus@linux.intel.com>
> ---
> include/media/v4l2-subdev.h | 95 +++++++++++++++++++++++++++++--------
> 1 file changed, 74 insertions(+), 21 deletions(-)
>
> diff --git a/include/media/v4l2-subdev.h b/include/media/v4l2-subdev.h
> index b8874eeec2e5..307655ee25e0 100644
> --- a/include/media/v4l2-subdev.h
> +++ b/include/media/v4l2-subdev.h
> @@ -1964,6 +1964,22 @@ extern const struct v4l2_subdev_ops v4l2_subdev_call_wrappers;
> __result; \
> })
>
> +#define __v4l2_subdev_call_drop_fourth(first, second, third, fourth, rest...) \
> + v4l2_subdev_call(first, second, third, ##rest)
> +
> +#define __v4l2_subdev_call_state_active(call, sd, o, f, args...) \
> + ({ \
> + int __result; \
> + struct v4l2_subdev_state *state; \
> + state = v4l2_subdev_get_unlocked_active_state(sd); \
> + if (state) \
> + v4l2_subdev_lock_state(state); \
> + __result = call(sd, o, f, NULL, state, ##args); \
> + if (state) \
> + v4l2_subdev_unlock_state(state); \
> + __result; \
> + })
> +
> /**
> * v4l2_subdev_call_state_active - call an operation of a v4l2_subdev which
> * takes state as a parameter, passing the
> @@ -1982,22 +1998,13 @@ extern const struct v4l2_subdev_ops v4l2_subdev_call_wrappers;
> * active state, lock it before calling the op and unlock it after the call.
> */
> #define v4l2_subdev_call_state_active(sd, o, f, args...) \
> - ({ \
> - int __result; \
> - struct v4l2_subdev_state *state; \
> - state = v4l2_subdev_get_unlocked_active_state(sd); \
> - if (state) \
> - v4l2_subdev_lock_state(state); \
> - __result = v4l2_subdev_call(sd, o, f, state, ##args); \
> - if (state) \
> - v4l2_subdev_unlock_state(state); \
> - __result; \
> - })
> + __v4l2_subdev_call_state_active(__v4l2_subdev_call_drop_fourth, \
> + sd, o, f, ##args)
>
> /**
> - * v4l2_subdev_call_state_try - call an operation of a v4l2_subdev which
> - * takes state as a parameter, passing the
> - * subdev a newly allocated try state.
> + * v4l2_subdev_call_ci_state_active - call an operation of a v4l2_subdev which
> + * takes state as a parameter, passing the
> + * subdev its active state.
> *
> * @sd: pointer to the &struct v4l2_subdev
> * @o: name of the element at &struct v4l2_subdev_ops that contains @f.
> @@ -2007,13 +2014,14 @@ extern const struct v4l2_subdev_ops v4l2_subdev_call_wrappers;
> * each element at &struct v4l2_subdev_ops.
> * @args: arguments for @f.
> *
> - * This is similar to v4l2_subdev_call_state_active(), except that as this
> - * version allocates a new state, this is only usable for
> - * V4L2_SUBDEV_FORMAT_TRY use cases.
> - *
> - * Note: only legacy non-MC drivers may need this macro.
> + * This macro is just as v4l2_subdev_call_state_active(), with the exception
> + * that it passes NULL as the client info to sub-device ops that need it
> + * (currently pad ops set_fmt, get_selection and set_selection).
> */
> -#define v4l2_subdev_call_state_try(sd, o, f, args...) \
> +#define v4l2_subdev_call_ci_state_active(sd, o, f, args...) \
> + __v4l2_subdev_call_state_active(v4l2_subdev_call, sd, o, f, ##args)
> +
> +#define __v4l2_subdev_call_state_try(call, sd, o, f, args...) \
> ({ \
> int __result; \
> static struct lock_class_key __key; \
> @@ -2025,13 +2033,58 @@ extern const struct v4l2_subdev_ops v4l2_subdev_call_wrappers;
> __result = PTR_ERR(state); \
> } else { \
> v4l2_subdev_lock_state(state); \
> - __result = v4l2_subdev_call(sd, o, f, state, ##args); \
> + __result = call(sd, o, f, NULL, state, ##args); \
> v4l2_subdev_unlock_state(state); \
> __v4l2_subdev_state_free(state); \
> } \
> __result; \
> })
>
> +/**
> + * v4l2_subdev_call_state_try - call an operation of a v4l2_subdev which
> + * takes state as a parameter, passing the
> + * subdev a newly allocated try state.
> + *
> + * @sd: pointer to the &struct v4l2_subdev
> + * @o: name of the element at &struct v4l2_subdev_ops that contains @f.
> + * Each element there groups a set of callbacks functions.
> + * @f: callback function to be called.
> + * The callback functions are defined in groups, according to
> + * each element at &struct v4l2_subdev_ops.
> + * @args: arguments for @f.
> + *
> + * This is similar to v4l2_subdev_call_state_active(), except that as this
> + * version allocates a new state, this is only usable for
> + * V4L2_SUBDEV_FORMAT_TRY use cases.
> + *
> + * Note: only legacy non-MC drivers may need this macro.
> + */
> +#define v4l2_subdev_call_state_try(sd, o, f, args...) \
> + __v4l2_subdev_call_state_try(__v4l2_subdev_call_drop_fourth, sd, o, f, \
> + ##args);
> +
> +/**
> + * v4l2_subdev_call_ci_state_try - call an operation of a v4l2_subdev which
> + * takes state as a parameter, passing the
> + * subdev a newly allocated try state.
> + *
> + * @sd: pointer to the &struct v4l2_subdev
> + * @o: name of the element at &struct v4l2_subdev_ops that contains @f.
> + * Each element there groups a set of callbacks functions.
> + * @f: callback function to be called.
> + * The callback functions are defined in groups, according to
> + * each element at &struct v4l2_subdev_ops.
> + * @args: arguments for @f.
> + *
> + * This is similar to v4l2_subdev_call_state_try(), with the exception
> + * that it passes NULL as the client info to sub-device ops that need it
> + * (currently pad ops set_fmt, get_selection and set_selection).
> + *
> + * Note: only legacy non-MC drivers may need this macro.
> + */
> +#define v4l2_subdev_call_ci_state_try(sd, o, f, args...) \
> + __v4l2_subdev_call_state_try(v4l2_subdev_call, sd, o, f, ##args);
> +
> /**
> * v4l2_subdev_has_op - Checks if a subdev defines a certain operation.
> *
next prev parent reply other threads:[~2026-08-10 14:12 UTC|newest]
Thread overview: 25+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-07 12:23 [PATCH v7 00/14] Metadata series preparation Sakari Ailus
2026-08-07 12:23 ` [PATCH v7 01/14] media: Documentation: Improve pixel rate calculation documentation Sakari Ailus
2026-08-07 12:23 ` [PATCH v7 02/14] media: imx219: Account rate_factor in setting upper exposure limit Sakari Ailus
2026-08-07 12:23 ` [PATCH v7 03/14] media: imx219: Account for rate_factor in control steps Sakari Ailus
2026-08-10 15:10 ` Laurent Pinchart
2026-08-07 12:23 ` [PATCH v7 04/14] media: imx219: The horizontal blanking step is 8 Sakari Ailus
2026-08-07 12:24 ` [PATCH v7 05/14] media: imx219: Rename "binning" as "bin_hv" in imx219_set_pad_format Sakari Ailus
2026-08-07 12:24 ` [PATCH v7 06/14] media: Improve enable_streams and disable_streams documentation Sakari Ailus
2026-08-07 12:24 ` [PATCH v7 07/14] media: v4l2-subdev: Move subdev client capabilities into a new struct Sakari Ailus
2026-08-10 15:13 ` Laurent Pinchart
2026-08-07 12:24 ` [PATCH v7 08/14] media: v4l2-subdev: Move op check to sub-device op wrappers Sakari Ailus
2026-08-07 12:24 ` [PATCH v7 09/14] media: v4l2-subdev: Always call get_fmt() if set_fmt() is unavailable Sakari Ailus
2026-08-10 13:12 ` Hans Verkuil
2026-08-10 15:26 ` Laurent Pinchart
2026-08-07 12:24 ` [PATCH v7 10/14] media: v4l2-subdev: Don't assign set_fmt where it's equivalent to get_fmt Sakari Ailus
2026-08-10 13:13 ` Hans Verkuil
2026-08-10 15:30 ` Laurent Pinchart
2026-08-07 12:24 ` [PATCH v7 11/14] media: v4l2-subdev: Add v4l2_subdev_call_ci_state_{active,try} Sakari Ailus
2026-08-10 14:12 ` Hans Verkuil [this message]
2026-08-10 15:32 ` Laurent Pinchart
2026-08-11 7:20 ` Sakari Ailus
2026-08-11 8:38 ` Laurent Pinchart
2026-08-07 12:24 ` [PATCH v7 12/14] media: mt9m001: Pass sub-device state to set_selection() callback Sakari Ailus
2026-08-07 12:24 ` [PATCH v7 13/14] media: cvs: Drop comments on sub-device operations Sakari Ailus
2026-08-07 12:24 ` [PATCH v7 14/14] media: v4l2-subdev: Add struct v4l2_subdev_client_info pointer to pad ops Sakari Ailus
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=65b0c3ab-ae76-49ec-824a-b9d882c28a5c@kernel.org \
--to=hverkuil+cisco@kernel.org \
--cc=benjamin.mugnier@foss.st.com \
--cc=christophe.jaillet@wanadoo.fr \
--cc=dave.stevenson@raspberrypi.com \
--cc=david.plowman@raspberrypi.com \
--cc=dongcheng.yan@intel.com \
--cc=git@apitzsch.eu \
--cc=hansg@kernel.org \
--cc=heimir.sverrisson@gmail.com \
--cc=hpa@redhat.com \
--cc=jacopo.mondi@ideasonboard.com \
--cc=jai.luthra@ideasonboard.com \
--cc=julien.massot@collabora.com \
--cc=khai.wen.ng@intel.com \
--cc=kieran.bingham@ideasonboard.com \
--cc=laurent.pinchart@ideasonboard.com \
--cc=linux-media@vger.kernel.org \
--cc=mehdi.djait@linux.intel.com \
--cc=mirela.rabulea@nxp.com \
--cc=naush@raspberrypi.com \
--cc=ong.hock.yu@intel.com \
--cc=prabhakar.csengg@gmail.com \
--cc=r-donadkar@ti.com \
--cc=ribalda@kernel.org \
--cc=sakari.ailus@linux.intel.com \
--cc=stefan.klug@ideasonboard.com \
--cc=sylvain.petinot@foss.st.com \
--cc=tomi.valkeinen@ideasonboard.com \
--cc=tomm.merciai@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox