Linux Media Controller development
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@intel.com>
To: Rishab Madhugiri <rishab.madhugiri@gmail.com>
Cc: hansg@kernel.org, mchehab@kernel.org, gregkh@linuxfoundation.org,
	dan.carpenter@linaro.org, andy@kernel.org,
	sakari.ailus@linux.intel.com, linux-staging@lists.linux.dev,
	linux-media@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2] staging: media: atomisp: Use ARRAY_SIZE macro
Date: Thu, 13 Aug 2026 12:44:40 +0300	[thread overview]
Message-ID: <an2SCK1slBHQNNB-@ashevche-desk.local> (raw)
In-Reply-To: <20260813075529.153217-1-rishab.madhugiri@gmail.com>

On Thu, Aug 13, 2026 at 07:55:29AM +0000, Rishab Madhugiri wrote:
> Clean up loop bound calculation by replacing sizeof(bds_factors) /
> sizeof(struct bayer_ds_factor) with the ARRAY_SIZE() helper macro
> to improve readability and maintainability.

> v2: Move loop increment to the same line as the for statement as requested.

This should go...

> Signed-off-by: Rishab Madhugiri <rishab.madhugiri@gmail.com>
> ---

...under here, so it won't be included into Git history.

...

> -	for (i = 0; i < sizeof(bds_factors) / sizeof(struct bayer_ds_factor);
> -	     i++) {
> +	for (i = 0; i < ARRAY_SIZE(bds_factors); i++) {

While at it, also consider

	for (unsigned int i = 0; i < ARRAY_SIZE(bds_factors); i++) {

and dropping the above definition since i is not used outside of the loop.

-- 
With Best Regards,
Andy Shevchenko



      parent reply	other threads:[~2026-08-13  9:44 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-13  2:03 [PATCH] staging: media: atomisp: Use ARRAY_SIZE macro Rishab Madhugiri
2026-08-13  7:16 ` Dan Carpenter
2026-08-13  7:55   ` [PATCH v2] " Rishab Madhugiri
2026-08-13  8:15     ` Dan Carpenter
2026-08-13  9:44     ` Andy Shevchenko [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=an2SCK1slBHQNNB-@ashevche-desk.local \
    --to=andriy.shevchenko@intel.com \
    --cc=andy@kernel.org \
    --cc=dan.carpenter@linaro.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=hansg@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=linux-staging@lists.linux.dev \
    --cc=mchehab@kernel.org \
    --cc=rishab.madhugiri@gmail.com \
    --cc=sakari.ailus@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox