Linux Media Controller development
 help / color / mirror / Atom feed
From: AngeloGioacchino Del Regno  <angelogioacchino.delregno@collabora.com>
To: "Yunfei Dong (董云飞)" <Yunfei.Dong@mediatek.com>,
	"wenst@chromium.org" <wenst@chromium.org>,
	"benjamin.gaignard@collabora.com"
	<benjamin.gaignard@collabora.com>,
	"nfraprado@collabora.com" <nfraprado@collabora.com>,
	"nicolas.dufresne@collabora.com" <nicolas.dufresne@collabora.com>,
	"nhebert@chromium.org" <nhebert@chromium.org>,
	"hverkuil-cisco@xs4all.nl" <hverkuil-cisco@xs4all.nl>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"linux-mediatek@lists.infradead.org" 
	<linux-mediatek@lists.infradead.org>,
	"frkoenig@chromium.org" <frkoenig@chromium.org>,
	"stevecho@chromium.org" <stevecho@chromium.org>,
	"linux-media@vger.kernel.org" <linux-media@vger.kernel.org>,
	"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
	"daniel@ffwll.ch" <daniel@ffwll.ch>,
	Project_Global_Chrome_Upstream_Group 
	<Project_Global_Chrome_Upstream_Group@mediatek.com>,
	"hsinyi@chromium.org" <hsinyi@chromium.org>,
	"linux-arm-kernel@lists.infradead.org" 
	<linux-arm-kernel@lists.infradead.org>
Subject: Re: [PATCH v2,04/10] media: mediatek: vcodec: remove the dependency of debug log
Date: Wed, 14 Jun 2023 13:50:19 +0200	[thread overview]
Message-ID: <b89035bf-cbdd-e99a-1332-a11885ae8f8b@collabora.com> (raw)
In-Reply-To: <1ea03faee8da26e17690c707464ab1cda405a313.camel@mediatek.com>

Il 14/06/23 11:17, Yunfei Dong (董云飞) ha scritto:
> Hi AngeloGioacchino,
> 
> How do you think about Nicolas's suggestion?
> 

Please don't top-post!

Nicolas' suggestion looks good. Please go on.

P.S.: Sorry for the late reply.

Cheers,
Angelo


> On Thu, 2023-06-08 at 11:17 -0400, Nicolas Dufresne wrote:
>>   	
>> External email : Please do not click links or open attachments until
>> you have verified the sender or the content.
>>   Le jeudi 08 juin 2023 à 16:06 +0200, AngeloGioacchino Del Regno a
>> écrit :
>>> Il 08/06/23 15:11, Nicolas Dufresne ha scritto:
>>>> Le jeudi 08 juin 2023 à 07:27 +0000, Yunfei Dong (董云飞) a écrit :
>>>>> Hi Nicolas,
>>>>>
>>>>> Thanks for your review.
>>>>> On Wed, 2023-06-07 at 21:41 -0400, Nicolas Dufresne wrote:
>>>>>>    
>>>>>> External email : Please do not click links or open
>> attachments until
>>>>>> you have verified the sender or the content.
>>>>>>    Hi Yunfei,
>>>>>>
>>>>>> Le mercredi 07 juin 2023 à 16:48 +0800, Yunfei Dong a écrit :
>>>>>>> 'mtk_vcodec_debug' and 'mtk_vcodec_err' depends on
>> 'mtk_vcodec_ctx'
>>>>>>> to get the index of each instance, using the index directly
>> instead
>>>>>>> of with 'mtk_vcodec_ctx'.
>>>>>>>
>>>>>>> Signed-off-by: Yunfei Dong <yunfei.dong@mediatek.com>
>>>>>>> ---
>>>>>>>    .../mediatek/vcodec/mtk_vcodec_util.h         |  26 ++-
>>>>>>>    .../vcodec/vdec/vdec_av1_req_lat_if.c         | 105
>> +++++++-----
>>>>>>>    .../mediatek/vcodec/vdec/vdec_h264_if.c       |  62 ++++-
>> --
>>>>>>>    .../mediatek/vcodec/vdec/vdec_h264_req_if.c   |  39 +++--
>>>>>>>    .../vcodec/vdec/vdec_h264_req_multi_if.c      |  80
>> +++++----
>>>>>>>    .../vcodec/vdec/vdec_hevc_req_multi_if.c      |  67 ++++-
>> ---
>>>>>>>    .../mediatek/vcodec/vdec/vdec_vp8_if.c        |  54 ++++-
>> --
>>>>>>>    .../mediatek/vcodec/vdec/vdec_vp8_req_if.c    |  46 +++
>> ---
>>>>>>>    .../mediatek/vcodec/vdec/vdec_vp9_if.c        | 152
>> ++++++++++--
>>>>>> ------
>>>>>>>    .../vcodec/vdec/vdec_vp9_req_lat_if.c         |  84
>> ++++++----
>>>>>>>    .../platform/mediatek/vcodec/vdec_vpu_if.c    |  59 ++++-
>> --
>>>>>>>    .../mediatek/vcodec/venc/venc_h264_if.c       |  86
>> +++++-----
>>>>>>>    .../mediatek/vcodec/venc/venc_vp8_if.c        |  48 +++
>> ---
>>>>>>>    .../platform/mediatek/vcodec/venc_vpu_if.c    |  64 ++++-
>> ---
>>>>>>>    14 files changed, 565 insertions(+), 407 deletions(-)
>>>>>>>
>>>>>>> diff --git
>>>>>> a/drivers/media/platform/mediatek/vcodec/mtk_vcodec_util.h
>>>>>> b/drivers/media/platform/mediatek/vcodec/mtk_vcodec_util.h
>>>>>>> index ecb0bdf3a4f4..ddc12c3e2983 100644
>>>>>>> ---
>> a/drivers/media/platform/mediatek/vcodec/mtk_vcodec_util.h
>>>>>>> +++
>> b/drivers/media/platform/mediatek/vcodec/mtk_vcodec_util.h
>>>>>>> @@ -31,9 +31,8 @@ struct mtk_vcodec_dev;
>>>>>>>    #define mtk_v4l2_err(fmt, args...)                \
>>>>>>>    pr_err("[MTK_V4L2][ERROR] " fmt "\n", ##args)
>>>>>>>    
>>>>>>> -#define mtk_vcodec_err(h, fmt, args...)\
>>>>>>> -pr_err("[MTK_VCODEC][ERROR][%d]: " fmt "\n",\
>>>>>>> -       ((struct mtk_vcodec_ctx *)(h)->ctx)->id, ##args)
>>>>>>> +#define mtk_vcodec_err(plat_dev, inst_id, fmt,
>>>>>> args...)                                 \
>>>>>>> +dev_err(&(plat_dev)->dev, "[MTK_VCODEC][ERROR][%d]: " fmt
>> "\n",
>>>>>> inst_id, ##args)
>>>>>>>    
>>>>>>>    #if defined(CONFIG_DEBUG_FS)
>>>>>>>    extern int mtk_v4l2_dbg_level;
>>>>>>> @@ -46,27 +45,24 @@ extern int mtk_vcodec_dbg;
>>>>>>>     __func__, __LINE__, ##args);        \
>>>>>>>    } while (0)
>>>>>>>    
>>>>>>> -#define mtk_vcodec_debug(h, fmt,
>> args...)                      \
>>>>>>> -do {                      \
>>>>>>> -if (mtk_vcodec_dbg)                      \
>>>>>>> -dev_dbg(&(((struct mtk_vcodec_ctx *)(h)->ctx)->dev-
>>> plat_dev-
>>>>>>> dev),   \
>>>>>>> -"[MTK_VCODEC][%d]: %s, %d " fmt
>> "\n",                         \
>>>>>>> -((struct mtk_vcodec_ctx *)(h)->ctx)-
>>> id,                      \
>>>>>>> -__func__, __LINE__,
>> ##args);                                  \
>>>>>>> +#define mtk_vcodec_debug(plat_dev, inst_id, fmt,
>>>>>> args...)                               \
>>>>>>> +do
>>>>>> {
>>>>>>           \
>>>>>>> +if
>>>>>> (mtk_vcodec_dbg)
>>>>>> \
>>>>>>> +dev_dbg(&(plat_dev)->dev, "[MTK_VCODEC][%d]: %s, %d " fmt
>> "\n", \
>>>>>>
>>>>>> At least in this patch, you systematically pass plat_dev as
>>>>>> <something>->ctx->dev->plat_dev, which is quite long and
>> verbose, any
>>>>>> reason we
>>>>>> can't just pass that <something> here ? We can follow the
>> same
>>>>>> structure path
>>>>>> for both encoder/decoder ?
>>>>>>
>>>>>
>>>>> In order to separate encode and decoder, need to define two
>> different
>>>>> struct mtk_vcodec_dec_ctx and struct mtk_vcodec_enc_ctx.
>>>>>
>>>>> struct mtk_vcodec_ctx won't be used again, need to use platform
>> device
>>>>> to print dev_dbg and dev_err.
>>>>>
>>>>> encoder and decoder using the same interface to print log
>> message.
>>>>
>>>> Just a reminder, I'm just making suggestions, there is no strict
>> action required
>>>> here other then a discussion to try and make the logging a bit
>> more light.
>>>>
>>>> My points was that C macros don't care about types, so if you
>> keep the path to
>>>> the platform device the same (ctx->dev->plat_dev), you could just
>> pass the ctx
>>>> as argument. What I don't know though myself, is if this is
>> actually feasible in
>>>> all code path, but considering you had access to the instance
>> previously, I
>>>> thought it should.
>>>>
>>>
>>> One macro used to access two different structures?
>>>
>>> Please, no.
>>
>> Its up to you. I do think this is an empty statement. Still believe
>> we avoid
>> this code "deterioration". One can always be creative to workaround
>> your
>> concerns.
>>
>> struct base_ctx {
>> struct dev dev;
>> }
>>
>> struct enc_ctx {
>> struct base_ctx;
>> ...
>> }
>>
>> struct src_ctx {
>> ...
>> }
>>
>> But this is in no way more safe then a naming convention, this is
>> macro calls,
>> its not typed.
>>
>> Nicolas
>>
> 
> In order to speed up the upstream progress, maybe we can discuss it in
> chat.
> 
> Best Reagrds,
> Yunfei Dong
>>>
>>> Regards,
>>> Angelo
>>>
>>>> regards,
>>>> Nicolas
>>>>
>>>>>
>>>>> Best Regards,
>>>>> Yunfei Dong
>>>>>>> +inst_id, __func__, __LINE__, ##args);                   \
>>>>>>>    } while (0)
>>>>>>>    #else
>>>>>>>    #define mtk_v4l2_debug(level, fmt, args...) pr_debug(fmt,
>> ##args)
>>>>>>>    
>>>>>>> -#define mtk_vcodec_debug(h, fmt, args...)\
>>>>>>> -pr_debug("[MTK_VCODEC][%d]: " fmt "\n",\
>>>>>>
>>>>> ...snip...
>>>>
>>>
>>



  reply	other threads:[~2023-06-14 11:50 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-06-07  8:48 [PATCH v2,0/10] media: mediatek: vcodec: separate encoder and decoder Yunfei Dong
2023-06-07  8:48 ` [PATCH v2,01/10] media: mediatek: vcodec: remove unused parameter Yunfei Dong
2023-06-07  8:48 ` [PATCH v2,02/10] media: mediatek: vcodec: align fw interface Yunfei Dong
2023-06-07  8:48 ` [PATCH v2,03/10] media: mediatek: vcodec: re-write shared interface Yunfei Dong
2023-06-07  8:48 ` [PATCH v2,04/10] media: mediatek: vcodec: remove the dependency of debug log Yunfei Dong
2023-06-08  1:41   ` Nicolas Dufresne
2023-06-08  7:27     ` Yunfei Dong (董云飞)
2023-06-08 13:11       ` Nicolas Dufresne
2023-06-08 14:06         ` AngeloGioacchino Del Regno
2023-06-08 15:17           ` Nicolas Dufresne
2023-06-11  2:09             ` Yunfei Dong (董云飞)
2023-06-14  9:17             ` Yunfei Dong (董云飞)
2023-06-14 11:50               ` AngeloGioacchino Del Regno [this message]
2023-06-07  8:48 ` [PATCH v2,05/10] mediatek: vcodec: replace pr_* with dev_* for v4l2 debug message Yunfei Dong
2023-06-07  8:48 ` [PATCH v2,06/10] mediatek: vcodec: separate struct mtk_vcodec_ctx Yunfei Dong
2023-06-07  8:48 ` [PATCH v2,07/10] mediatek: vcodec: separate struct mtk_vcodec_dev Yunfei Dong
2023-06-07  8:48 ` [PATCH v2,08/10] mediatek: vcodec: fix unreasonable parameter definition and style Yunfei Dong
2023-06-07  8:49 ` [PATCH v2,09/10] mediatek: vcodec: remove unused include header Yunfei Dong
2023-06-07  8:49 ` [PATCH v2,10/10] mediatek: vcodec: separete decoder and encoder Yunfei Dong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b89035bf-cbdd-e99a-1332-a11885ae8f8b@collabora.com \
    --to=angelogioacchino.delregno@collabora.com \
    --cc=Project_Global_Chrome_Upstream_Group@mediatek.com \
    --cc=Yunfei.Dong@mediatek.com \
    --cc=benjamin.gaignard@collabora.com \
    --cc=daniel@ffwll.ch \
    --cc=devicetree@vger.kernel.org \
    --cc=frkoenig@chromium.org \
    --cc=hsinyi@chromium.org \
    --cc=hverkuil-cisco@xs4all.nl \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=nfraprado@collabora.com \
    --cc=nhebert@chromium.org \
    --cc=nicolas.dufresne@collabora.com \
    --cc=stevecho@chromium.org \
    --cc=wenst@chromium.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox